Audio sounds through only the left channel

Today (after a couple of Pro Tools session in 96 kHz) I had to manually reset the Dorico audio driver back to 44,1.
After that I only have audio on channel 1. And only one channel to chose from in play preferences. (See attachment.)

I have restarted the computer, and deleted the VSTAudioEngine3-folder to no avail.

Any ideas?
Bild 2020-02-01 kl. 11.58.jpeg

[Edit] Originally you could find here a recipe to fix a Dorico project file from the left-only issue, but as Dorico evolved over time, this recipe did not work anymore, so I deleted it. Instead, if you also ran into that problem, please send the affected project file to ‘u dot stoermer at steinberg dot de’ and I will fix it for you.
Please also note a related section from the Dorico FAQ:
" On macOS, AirPods and Bluetooth headsets easily bring Dorico’s audio engine into trouble due to the low spec built-in microphone. So here is the recommended way of dealing with them on Mac:

  • Stop Dorico
  • Make sure that the AirPods or Bluetooth headset is working with other apps, e.g. Apple Music.
  • Launch Applications/Utilities/Audio MIDI Setup
  • On the Audio Devices page create a new Aggregate Device
  • In that device let only the stereo outputs of the AirPods or Bluetooth headset participate, nothing else
  • Optionally, rename that device to your liking
  • Start Dorico and go to Edit > Device Setup
  • In the list of ASIO drivers your newly-created aggregate device shall turn up now. Select it, close the dialog, done.
  • Don’t get tempted to select the other AirPods or Bluetooth headset related entries in the ASIO driver list: you might end up with situations where only the left audio will play out and it’s difficult to recover from that."
7 Likes

Thank you very much, Ulf! It worked like a charm!

Very interesting solution, I could never have worked it out myself.

Greetings from Stockholm!

If you are on a Mac, I’ve had this happen from time to time. No idea why. All the sudden things sound funny, and I go into the universal Mac preferences pane, check audio and the slider is skewed all the way to one side. Sliding it back (without doing anything to dorico) does the trick. Again, I have no idea how/why this happens, but it has occurred at least 5 times in the last year.

Thanks for this! I think it’s related to using a single AirPod. This is how mine started misbehaving. It may also be related to the fact that one of my AirPods is a replacement after losing the original, so my AirPods always come up as “#2” when pairing etc.

Yes, it must be somehow BlueTooth related. I recently had another customer with this problem and he sent me a recipe of how to reproduce it. I don’t have access to a Mac right now, but will try it out as soon as I do have again. Once we have a consistent reproduction of the issue it will become quite easy to fix, I think. Stay tuned.

Great job!

Worked excelent!

1 Like

Thanks for the feedback, @yoshi-1 .
I’m glad it to hear it worked for you. But actually this shouldn’t happen in first place.
But I have not been able to reproduce it yet myself, though I tried very hard.
I have a theory that it has to do with switching to BlueTooth headphones and then back to built-in audio, but on the machines that I have at hand it always works as expected.
Do you also use AirPods or other BT headsets, yoshi-1? Or could you give another hint of how this could happen?

Dear Ulf,
I am encountering this panning problem on a project (once again, after passing from a Bluetooth speaker to built-in output)… Can I send you the project via email? Or is there any workaround I can try?

Thank you in advance

No, please send me, I’ll fix it for you.

Any idea on how one could solve this issue on Windows 11?

Best,
Joonas

Hi @joonas , is it really the same issue like in this thread here? I think we fixed this one in the software some time ago. Or is it rather the famous new issue? Please have a look at this thread

thats exactly it!

Hi I’m having the greyed playback button problem, can you please help or teach me how to fix the issue?

Hi @rafosga, welcome to the forum.

But your problem is a different one. To get an overview please open a project in Dorico and then choose from the menu Help > Create Diagnostics Report and post the corresponding zip file here. Thanks

It’s the same problem of “[Play button greyed out]”
Dorico Diagnostics.zip (2.2 MB)
I can’t post the link, sorry

Hi @rafosga , thanks for the data, but you appear to not having installed the Dorico Sound Installation package (about 10 GB worth of data). Everything else looks normal
Do you have valid reasons (e.g. low disk space) for not having done that?
You can also use Kontakt insteead, but you have to load the sound patches all yourself.
Or you write an own Playback template for it. Whatever suits you best.

Actually I thought I did, how strange, and I’m using Halion and Kontakt for this project… Thanks btw! I will install what you told me.

Hello Ulf,
the same error with me, but not one file, but all. Sound only out of the left Channel. Scores exportet as Audio (mp3 or wav) have sound on both channels. Screenrecordings for Practicing-Demos have only left Channel.
Audio Settings:
Stereo-Ausgabe
Maybe that’s re reason? But I can’t choose anything in “Stereo-Ausgabe”
Pan ist adjustet to center but moving Pan slider left / right does not effect the Playback anyway.


Thank you for your help
best regards
Rainer

Hi @Rainer_Hornig , this is actually a different problem. Please have a look in this thread for a solution.