Barres and fret numbers

I’m slowly going through the back-and forth process of adding barre lines to guitar music. I have figure out how to set a duration for the barreb but I cannot figure out the last step: how to add a frey number so you’ll know where to position it. Akso, information such as the duration lin e and the half- or full indication are below the staff, where they should be above it. Thankyou

Hey!
I am a guitarist and willing to help, but since guitar notation can be somewhat non standardized, do you have an example of what you want to achieve? :wink:

Benji

Thanks for the reply, Benji. I thought that classical guitar music was very much standardised! Anyway, in the example the full barre on the 5th fret goes from the first beat in the bar to the first beat in the next bar.

01 - Full score - Untitled Project 1.pdf (25.3 KB)

I forgot to mention, 6th string down to D

Well, I don’t play classical guitar, so… :wink:
But I’ve wrestled with position markers, Barré and fingerings for a good while now…´
Here’s what I do:

For the Barré indication, use the provided “C”-Symbol, as you’ve figured out :slight_smile:, and you can set it above or below.
I also made positioning indicators in Roman numerals as Playing Techniques. The cool thing is, in my playback setup, I have a VSTi that can respond to these PT, so it sounds very authentic!
Let me know if this helps…

Benji

I’ve just replied this one to someone else!
But here is what I suggested anyway…

https://forums.steinberg.net/t/re-barre-chord-fingering-annotations-for-classical-guitar/728114
and my latest userlibrary is
userlibrary.xml (260.5 KB)

Andy, when I click on the link, it says ‘private’.

Sorry about that. I’ve copied the content out here …

I hope this works easily for you.
Here is the user library file…
userlibrary.xml (260.5 KB)

Here’s an example of what the result looks like and an image of where to put the file.
(It might be an idea to drag your original out in case you want to revert).

Now restart Dorico and you should be able to follow these instructions:-

Enter (Barré) Positions as follows:-
Click note or rhythmic position and press Shift->P
(For a continuation line, select the first and last notes relevant).

In the pop-up box enter …
for simple position indicators enter pn where n is the position number n .
for barrés enter cn where n is the position number n .
for half barrés enter hcn where n is the position number n .
Click return to exit.

The pn, cn and hcn entries are my own shorthand to bring up the relevant ‘glyph’.

It it easy to change the extension line to a solid one if you prefer within the Edit Playing Techniques dialog.
Choose category-> Guitar from the dropdown menu, select a position marker, change the continuation type and then click the little star that sets it as default…

1 Like

Exactly what I need! I’ll try it later today. Thanks for your detailed help
John

Andy, I’ve never used .xml files before (maybe because I’m on Mac??). I inputted into the popover okay, got the C for a full barre, plus the duration, but the one thing I can’t get is the fret number! How??
Thanks

I’m on a Mac too.
Did you find the user library.xml file in your Library->Application Support->Steinberg->Dorico n folder (add the Dorico version number for ‘n’)? That’s the user library.xml file to take out to desktop (in case things go wrong) and replace with the one you downloaded. Restart Dorico and it should work.
If you click Library->Playing techniques you should see this under the Guitar category.

Hi, Andy;
I’m getting there!
I went to Library/playing techniques, and I proceeded to the guitar category. and set it up according to your file, and the full barre C is there, however there still seems to be no provision for adding the fret number,

Strange - did you put the userlibrary.xml file in the right Dorico folder and do a restart?
I do know that, a while ago, someone else managed it OK.

I couldn’t actually open your .xml file: it says “invalid file format.” However, I went to the library /playing techniques page, and did the steps for full barre, and the “C” came up just as I wanted. However, there seems to be no election choice for fret numbers ??

Andy, I just cannot get that fret number to come up! Any more suggestions? Sorry to drag it along so much, but I’m almost tere. Also, no matter where I look in the online help manual I can’t find the solution there at all.
Thanks for your patience.

John

I’m sorry this is proving tricky.
Are you using Dorico 4 - if it’s an earlier version, the one I gave may not be compatible.
Also, are you OK with finding the User Library (typically this is hidden).
And do you live in the UK?
If so I could give you a call!

Andy, I tried this in Dorico 4.3 on a Mac and it seems to work – thanks! But I couldn’t find a user library file before I copied yours across. Does this file only get created when you first customize something? I hope I didn’t inadvertently replace the original file.

I’m a little surprised that this still needs a workaround.

Andy, in your screenshot all the barre notations appear above the staff, where they belong. I’m finding that mine sometimes appear below the staff. I expect this can be corrected in Engrave mode (which I’ve stayed away from so far) but I’d like to stop it happening in the first place, and I can’t work out what is causing it. Any ideas, please?

Andy, Wensleydale:
I’m in Australia. But, its a small place, so I should be easy to find if you can manage a Dorico-sponsored trip
(The first time I went to Oban, I met an old lady from Mull who taught gaelic in the schools. When she heard where I was from, she said: “Oooh, Australia! I’ve got a daughter there! Now…where is she?..ah yes - Thompson street…do you know it?”)
I’m on 4.3
Wensleydale, I have found that, since being guided through several processes by Andy, my barre notations now appear at the top. If you go, as Andy says, to Library/playing techniques/ full barre or half barre, you’ll find all the choices for setting it up correctly - except one: those pesky barre numbers still refuse to show themselves. Andy, your MS excerpt is a paragon of rightness! How do you do it?

John

John

Good morning John! “Above” is the default placement for barre notation, and I haven’t changed it. There appear to be certain circumstances in which the default is overridden and the barre goes under the staff. I don’t know whether those circumstances are dictated by Dorico itself or by Andy’s user library file.

But I’m ahead of you as regards the fret numbers. If I put, say, “c2” in the popover, I get the barre marked “CII”. If you’re not getting this, perhaps you haven’t successfully installed Andy’s file?