BUG 6.02 - serious playback issues with warp

Playback with warped audio when using the tempo track is seriously screwed in 6.02.

It may be related to this -
http://steinberg.net/forum/viewtopic.php?f=19&t=3485
which is supposed to have been fixed

To reproduce -

1 Take a piece of audio (a drum beat is a good one) and turn warp on for it - doesn’t matter which algorithm.
2 Put it into a part and chop it up a little - move a few beats around
3 Turn on the tempo track and insert a tempo change somewhere - do it out of the way of your audio
4 Your chopped up drum beat will now play out of time and the audio will drop out

This is new, and isn’t a feature of earlier V6 versions. Anyone using tempo tracks and warped audio like myself is going to have to roll back to 6.01 until this is fixed because you’ll never be sure your audio tracks are playing back correctly.

Does anybody check this stuff?
Test.zip (869 KB)

Bumping

Bump

All you gotta do is load the test session to hear a simple drum loop not playing back correctly.

This needs acknowledging and fixing.

Ironic…

In your example project try adjusting the start points of your cut pieces to the start of the audio then quant.

Hippo

Hi mate

You’ve completely misunderstood what the problem is!

Turn off the tempo track and you’ll see - it’s that that is screwing up the audio playback, not edit points in the audio.

I’ll say it again, warped audio is working OK - UNTIL you turn on the tempo track and insert some tempo changes anywhere in the song. Then, the audio playback gets corrupted at every edit point you make.

I’ve updated my attached test file so it’s really obvious what the issue is!
Test 2.zip (1.71 MB)

I see the and hear “the problem” and my answer is the same alter the start point of the audio clips to the start point of the audio in the clip qauantise and the problem is solved.

Hippo

I’m not quite sure what you’re trying to prove with this :confused:

What if you’ve got a track with drums where you’ve ‘beat detected’ the audio? You suggesting that you just adjust each individual edit point manually? It’d be a damn sight easier if it just worked correctly to start with wouldn’t it?

This is something that was broken in 6.0 ( http://steinberg.net/forum/viewtopic.php?f=19&t=3485 but manifested in a different way), was fixed in 6.0.1, and is now broken again in 6.0.2.

I simply want Steinberg to acknowledge the problem, add it to the bug database, and then fix it in the next release.

Does disabling and reenabling the tempo track for the project get it to play back correctly for you? I saw that suggestion in an old thread when I was looking something else up, the reproduction of the problem in that thread sounds a little similar to yours:

From http://www.steinberg.net/forum/viewtopic.php?f=76&t=4445 :



No - when the tempo track is turned off, the audio plays back fine. But re-enabling it causes it to go wrong again.

vinyl,
I know this is not the answer you’re looking for but have you tried “bounce selection” on the warped PARTS prior to altering tempo? Make sure Parts are snapped to bars first.

I’ve had an assortment of warping issues and have resigned myself to “bouncing” parts and/or tracks in order to avoid problems.

When I need to do anything fancy I still find it more efficient to do my warping in LIVE and rewire that to my cubase project.

good luck
s

Hi mate

This is a work around at best.

It’s ok for stuff thats at a fixed tempo, but anything thats going through a speed change will need to bounced at a fixed tempo and then warped a 2nd time for the tempo change - not good for sound quality.

The reason I’m pursuing this is that I’ve got tracks in progress that used warping and tempo changes, that now no longer play back correctly after the 6.02 update.

Bumping - just wanna give Steiny a lil chance to download the session I’ve posted and check it out

Bumping.

Steinberg - please can someone just open the attached session so we can get this added to the bugbase.

Tried your project and agrees that it’s a strange behaviour.

On the other hand - not knowing exactly what you’re trying to achieve - I think it’s a little odd to chop a 1 bar loop up in big chunks like you have, and then activating Musical Mode on each segment.

If you just apply Musical Mode to the whole loop this doesn’t happen.

If you want to rearrange the loop you should chop the loop up with hitpoints and then Create Slices instead.

Kris.

I’m not sure if this is 100% related, but if you look at my recent post, I found a pretty bad bug probably related to stretching a 125bpm loop to 120bpm that repros by doing almost nothing (just inserting the audio into the project in musical mode, looping the project, and letting it play a little while).

http://www.steinberg.net/forum/viewtopic.php?f=19&t=8474

Hi Kris

This is a session that shows the bug in a simple and easily reproducible way - It’s in no way an indication of what I’m trying to achieve musically :smiley:

This is a re-incarnation of an elastique pro implementation bug that was in the initial 6.0 release, but that Steinberg fixed in 6.01.

Anyone using edited warped audio AND the tempo track, will find that tracks created with 6.0 / 6.0.1 will no longer play back correctly. That in itself is why Steinberg needs to fix this ASAP.

Reported (28683)