Bug ? Logical Project Editor Supur Operation

Auf Deutsch

Unerwartetes Verhalten beim ändern von Parameter 1 wert der Option „ Spuroperation“

Es gibt hier folgende 3 Parameter 1 Optionen.

  • Einschalten
  • Ausschalten
  • Umschalten.

Meine Erwartungshaltung wäre der Parameter 1 Wert „ Umschalten“ ändert den jeweiligen Istzustand des Inserts und die Parameter 1 Werte Einschalten und Ausschalten tun das was ihre Namensgebung vorsieht.

Bei Instrumenten Spuren schaltet der Parameter1 wert Umschalten aber leider nur den Midi Insert-Effekt ein/aus und nicht den Audio-Insert-Effekt .

Bei allen anderen Spurarten schein die Funktion wie erwartet zu funktionieren.

Nun der Grund warum ich glaube, dass der „Projektbezogener Logical-Editors“ hier nicht wie vorgesehen arbeitet.

Ändere ich im oben dargestellten Beispiel den Parameter1 Wert auf Einschalten werden Jetz auch plötzlich die Audio-Insert-Effekte auf Instrumentenspuren mit eingeschaltet.

Ändere ich den Parameter1 Wert auf Ausschalten dann werden die Audio-Insert-Effekte auch wieder ausgeschaltet.

Mit dem jetzigen Verhalten ist es mir z.b. unmöglich ein Preset zu erstellen, dass alle Inserts auf Spuren Ein/AUS schaltet, wenn diese ausgewählt sind.

Anleitung zum Reproduzieren dieses Verhaltens:

  • Neues Projekt Öffnen.
  • Von jeder Spur Art eine Spur hinzufügen.
  • Den „ Projektbezogener Logical-Editors“ öffnen
  • Preset „ Init“ laden
  • Im Oberen Fenster auf das Plus Symbol klicken und folgendes einstellen.
    • Ziel der Aktion = Container-Typ
    • Bedingung = Gleich
    • Parameter 1 = Spur
  • Nun im unteren Fenster auf das Plus Symbol clicken und folgendes einstellen
    • Ziel der Aktion = Spur Operation
    • Bearbeitung = Insert Bypass
    • Parameter 1 = Umschalten

So sollte das nun aussehen:

  • Mit diesen Einstellungen nun auf die Schaltfläche Übernehmen Klicken. Ihr solltet folgendes in eurem Projektfenster sehen.
  • Jetzt nochmal auf die Schaltfläche Übernehmen klicken
  • Jetzt den Parameter 1 Wert im unteren Fenster auf Einschalten ändern und nochmal auf übernehmen klicken ihr solltet nun folgendes Bild im Projektfenster sehen.

Hi,

This is an English forum, please.

If I understand you right, it works for me here. If I set the very same Project Logical Preset, all Insert Bypass are disabled (even on the Instrument track, even if the MIDI Inserts are Bypassed and Audio Inserts are not bypassed).

Hi Martin sorry about that.

I have translated my issue for you

Project Logical Editor Bug on Track Operation Setting.

Unexpected behaviour when changing parameter 1 value of the “Track Operation” option

The following 3 parameter 1 options are available on this setting.

  • Enable
  • Disable
  • Toggle

My expectation would be the parameter 1 value “Toggle” changes the respective active state of the Channel inserts.

The Option Enable to me means that the insert is turned on.

The Option Disable to me means the inserts are turned off

On instrument tracks, the parameter 1 value toggle unfortunately only toggles the MIDI-Insert-effect on / off but it does not toggle the Audio-insert- effect on/off .

Please mind that Instrument Tracks unlike the other Tracks in Cubase have both MIDI and Audio Inserts.

Other tracks only have one or the other.

Now the reason why I believe that the “project logical editor” does not work as intended is described below.

  • If I set the parameter1 value to toggle the audio insert effects on instrument are not toggled but the Midi-Insert-effects are.
  • If I set the parameter 1 value to Enabled both Audio-insert-effect and MIDI-insert-effect are turned on. And when set to Disabled both are turned off.

My question is if Enable and Disable turn on/of all Insert types on Instrument and Sample Tracks, shouldn’t the Toggle option do the same? With the only difference being that it starts from the State the Inserts are set to at the time of application.

Instructions for reproducing this behaviour:

  • Open a new project.
  • Add one of each track type to the project.
  • Open the “Project Logical Editor”
  • Load pre-set “Init”

In the upper window click on the plus symbol and set the following.

  • File Target = container type
  • Condition = Equal
  • Parameter 1 = track
  • Now click on the plus symbol in the lower window and set the following
  • Action Target = track operation
  • Operation = insert bypass
  • Parameter 1 = toggle

It should look like this:

With these settings now click on the Apply button.
You should see the following in your project Window

  • Now click the Apply button again
  • Now change the parameter 1 value in the lower window to Enabled and click on apply button
  • you should now see the following picture in the project window.

comparing both steps it is clear to see on both images that in one case all Inserts are deactivated and in the other the Audio-Insert-effects on the Instrument and Sample Track are left out!

Hi,

Thank you, now I can reproduce it.

Reported to Steinberg. Thank you.

1 Like