Can't load plugins on saved projects

I have had this issue with my previous WIN 7 OS and now Win 10, on a certain point I can’t open another plugins and sometimes I even get a crash. Any solutions for this?
Win 10 Cubase 9.0.10 RME HDSPE Aio

Hello,

this is known, you can find info on the status here: https://www.steinberg.net/forums/viewtopic.php?f=251&t=107253#p597485
and a longer discussion thread here: https://www.steinberg.net/forums/viewtopic.php?f=226&t=95005

But this does not trigger any crashes, so it must be a separate issue.

Kind regards,

Yes this seems like my issue, the crash happens rarley.
Any ETA on when it will be fixed?
Thanks Kfir

Hello,

the problem is Steinberg cannot fix it on its own. It is due to an OS limitation and requires that all devs switch to dynamically loaded libraries (or alternatively, MS removes or increases the limitation).
Work on our side is in progress, but if 3rd parties do not switch to dynamically loaded libraries, this will only push the limitation further.

Thanks Fabio for the explnation, just to make sure , when I try to load Ozone 7 for current project (which already have on it instances of Ozone 7 ) it sometimes give me the attach error, is this the same issue you are discussing?
eror.jpg

Hello,

I would actually follow the advice and contact iZotope support, perhaps they have experience with the error message. Usually, the issue in the threads I linked is that plug-ins won’t just open, leaving an empty insert silently, without any warning returned.
But as we’re talking about a dll slot limitation, the error you posted might refer to plug-in not being able to load an external resource. Just to make sure, this happens when loading either the VST2 or VST3 version and the iZ is still present in the same path where the iZotope file (e.g. iZOzone.dll and iZotopeOzone.dll)?

When I try to open plugins it saying “plug-in removed” on the left history lane. it’s happening randomly, actually yesterday I tried to alt-drag some of the problematic plugins (on the saved session) and it’s working. most of my problems are with iZotope plugins and Acustica. With iZotope like I said sometimes I get this error I mentioned and sometime with restarting Cubase it works fine.
With Acustica I some time getting error “No DLL were found in the Waterfall procedure”
On a fresh project everything working fine and the Dll’s are in the right path.
All and all I don’t think it’s a plugin related because it happened to me with allot of plugins from different vendors.
Kfir

I see, it could be indeed be related to that issue.

The problem with this issue is that it is impossible to say when (as in ‘how many plug-in instances’) it will occur. Some plug-ins already use dynamic libraries, others can use more slots than others. So, it might occur anywhere between a little more than 100 instances or 300 - also, it is triggered easier when you use many unique plug-ins (several instances of the same plug-ins are less prone to cause this than the same amount of instances with different plugs).

Now I tried to load iZotope neutron on a saved project, and Cubase crash, can I send you the crashdump?

PM sent.