Chord roots with accidentals too far from slash

Hi,

I’ve got chord symbols on alternate roots as shown in the pic:

Is there any way to get the F# root closer to the slash? I’m sure it’s something to do with the kerning of the font of the sharp (I think that’s what it’s called but I’m probably using a word I’ve read somewhere without any idea what it means…), but I can’t work out why it’s displaced so far…

If anyone knows of a way I can sort this, or a font they’ve found that looks like Bravura that doesn’t need so much space around sharps n flats, that’d be amazing!

Ta.

Pierce

(‘Kerning’ is horizontal spacing adjustments between pairs of letters FYI.)

Yes, surely this is caused by the ♯ being both full-size and superscript. Can you do without one or the other? (How did you get both?)

I didn’t do anything but scale them up a bit, I like the positioning of the accidental, just not the size…
(And if your use the ‘chord symbol music text font’ size to make them bigger, you make the slash bigger too, making my issue even worse)

It looks great on chords without the altered bass notes, they just take up too much room under the slash…

Cheers, for the reply…

P

Dorico factors in the accidental height here, even if it wouldn’t cause a collision. This is obviously not always desirable, and can cause visual discrepancies as you’ve discovered like below (middle alignment selected):

I don’t have an easy solution for you other than don’t use diagonal arrangement. It’s fine with linear:

Your accidental positioning is a bit wonky though IMO. If you really want superscripted accidentals, I would bring the size down a bit. Under Engraving Options / Chord Symbols / Design / “Scale factor for subscript and superscript components” maybe try a bit smaller percentage.

Dorico is missing any sort of font style or adjustment settings for the slashes. I gave up waiting for this a while ago, so I made them myself with a doricolib file. If you want control over the slashes, unzip the doricolib file contained in the zip file below and add it to your user DefaultLibraryAdditions folder. In Windows this lives at Users\yournamehere\AppData\Roaming\Steinberg\Dorico 5\DefaultLibraryAdditions
Chord Symbols Slash Font.zip (917 Bytes)

I don’t think it will work on an existing file without using Library Manager to import it, but for any New file you’ll now have this functioning Font Style:
font

Obviously depending on your settings you might need to make a Y axis adjustment if you change the size, so you can do that directly in the doricolib file. I have my scale percentages set to work as desired without actually changing the size here, but feel free to just change the scale percentage (values must match) and yOffset (positive values are down) as needed.

doricolib file code here
<?xml version="1.0" encoding="utf-8"?>
<kScoreLibrary>
	<glyphDefinitions>
		<entities array="true">
			<GlyphPrimitiveEntityDefinition>
				<name>bass.slash</name>
				<entityID>glyph.bass.slash</entityID>
				<parentEntityID/>
				<inheritanceMask>0</inheritanceMask>
				<codePoint>0xE87B</codePoint>
				<isSmufl>true</isSmufl>
				<alternateForGlyph/>
				<fontStyle>font.chordsymbolsslash</fontStyle>
				<pointSize>1</pointSize>
				<rotation>0</rotation>
				<colour>kDefault</colour>
			</GlyphPrimitiveEntityDefinition>
			<GlyphPrimitiveEntityDefinition>
				<name>bass.slashdiagonal</name>
				<entityID>glyph.bass.slashdiagonal</entityID>
				<parentEntityID/>
				<inheritanceMask>0</inheritanceMask>
				<codePoint>0xE87C</codePoint>
				<isSmufl>true</isSmufl>
				<alternateForGlyph/>
				<fontStyle>font.chordsymbolsslash</fontStyle>
				<pointSize>1</pointSize>
				<rotation>0</rotation>
				<colour>kDefault</colour>
			</GlyphPrimitiveEntityDefinition>
		</entities>
	</glyphDefinitions>
	<compositeDefinitions>
		<entities array="true">
			<CompositeDefinition>
				<name>bass.slash</name>
				<entityID>comp.bass.slash</entityID>
				<parentEntityID/>
				<inheritanceMask>0</inheritanceMask>
				<category>kChordSymbols</category>
				<components array="true">
					<component>
						<componentId>glyph.bass.slash</componentId>
						<componentType>kGlyph</componentType>
						<xOffset>0</xOffset>
						<yOffset>0.5</yOffset>
						<xScale>125.000000</xScale>
						<yScale>125.000000</yScale>
						<zOrder>0</zOrder>
						<maxOpticalScale>100</maxOpticalScale>
						<componentInstance>0</componentInstance>
						<colour>kDefault</colour>
					</component>
				</components>
				<relativeAttachments array="true"/>
				<scalingRules array="true"/>
			</CompositeDefinition>
			<CompositeDefinition>
				<name>bass.slashdiagonal</name>
				<entityID>comp.bass.slashdiagonal</entityID>
				<parentEntityID/>
				<inheritanceMask>0</inheritanceMask>
				<category>kChordSymbols</category>
				<components array="true">
					<component>
						<componentId>glyph.bass.slashdiagonal</componentId>
						<componentType>kGlyph</componentType>
						<xOffset>0</xOffset>
						<yOffset>0</yOffset>
						<xScale>85.000000</xScale>
						<yScale>85.000000</yScale>
						<zOrder>0</zOrder>
						<maxOpticalScale>100</maxOpticalScale>
						<componentInstance>0</componentInstance>
						<colour>kDefault</colour>
					</component>
				</components>
				<relativeAttachments array="true"/>
				<scalingRules array="true"/>
			</CompositeDefinition>
		</entities>
	</compositeDefinitions>
	<fontstyles>
		<entities array="true">
			<FontStyleEntityDefinition>
				<name>Chord Symbols Slash Font</name>
				<entityID>font.chordsymbolsslash</entityID>
				<parentEntityID>font.chordsymbolsmusictext</parentEntityID>
				<inheritanceMask>0xFFFF</inheritanceMask>
				<fontname>Bravura Text</fontname>
				<colour>kDefault</colour>
				<size>kStaveRelativeSize, 11</size>
				<weight>kNormal</weight>
				<italic>false</italic>
				<underlined>false</underlined>
				<namedStyle>Regular</namedStyle>
				<substituteFamilyNames>steamVariantList:list: </substituteFamilyNames>
			</FontStyleEntityDefinition>
		</entities>
	</fontstyles>
</kScoreLibrary>
1 Like

Fred, that’s incredible! Thank you.

I love this forum.

Pierce

1 Like

Hi Fred,

I’m probably doing something wrong, but I followed your instructions and the entry comes up in font styles, but nothing I do changes the font. I’ve gone with baseline accidentals in the chord symbols but when I get those at the right size, the slash is not big enough… I’ve tried changing the x and y scales in your .doricolib file and that makes no difference, nor does editing the font size or any other parameter of the 'chord symbols slash font ’

Cheers,

P

  1. Unzip the file and add the doricolib file inside the zip to the DefaultLibraryAdditions folder at Users\yournamehere\AppData\Roaming\Steinberg\Dorico 5\DefaultLibraryAdditions if you’re using Windows. (Don’t add the zip file. I just have to use it because we can’t post doricolib files on the forum.) If you don’t have that folder, go ahead and create it.
  2. Start Dorico (or restart), and create a file from File/New
  3. Add some chords with alternate bass notes.

With my default settings, I now have this:

As an example, if I adjust the size of that font style to something comically large, I can get this:

If I really wanted that first slash to be so large, I would adjust the yOffset value to be a larger number to move it down, then restart Dorico and try the process over again. There is a bit of trial and error with this, but once you find the settings you like, you never have to mess with it again. Let me know if you still can’t get it working!

:joy:

That’s gold. Next time you do up an example you need to make the example as entertaining as possible.

1 Like

LOL! Once properly installed, that Font Style really can be any size.

Perfect! That’s exactly how I want them… :rofl:

In all seriousness, will this only work on new files? The ‘chord symbols slash font’ item in front styles comes up in all files but doesn’t change anything in existing files…

Will it work on existing templates?

P

There are a lot of elements that get loaded into Dorico at the time of file creation. The “Glyph Primitives” library is one of them and since the doricolib file changes those glyph definitions to use the new font style, it won’t automatically work on older files. You can use the Library Manager to bring these into an existing file though. Just select Glyph Primitives on the left, and it should import the new definitions for the slashes. After that the new font style should work.

Thank you!

I’ll try that in the morning. (It’s midnight here…)

P

1 Like

Can’t you make the slashes an axe or something?

1 Like

Haha! If you want to change it to another SMuFL glyph, you can just change the codePoint to enter another SMuFL code:

Pick any SMuFL glyph you want!
glasses

Don’t get me started on silliness like that…

I’ve used the library manager to import the glyph primitives like you said, which has worked to enable the font settings of the slashes! Hurrah!

But I’ve now got lots of duplicated entried in my font styles list, which I’m not sure I should have?

after importing glyph primitives

Sorry to be a PITA…

P

I’m not sure where these came from as your .doricolib file only defines the slash font…?

Sorry, as the doricolib stuff isn’t really documented or supported, I’m not really sure what’s going on here either. If you are only importing the Glyph Primitives, and not Font Styles too, I’m guessing that Dorico is creating a new style for anything you’ve changed from your default settings. The full list of “glyph primitives” and their assigned font styles is in the Program Files\Steinberg\Dorico5\glyphs.xml file, plus any added doricolib files or userlibrary.xml entries that override those factory definitions.

I think I remember Daniel posting that Dorico 5 has improvements over D4 with not creating duplicate styles, so I’m assuming those styles that are duplicated are actually different from your defaults. I’m not really sure what can be done about that. You could try importing Font Styles first with the Library Manager, in order to reset them to your User Library defaults, then import Glyph Primitives, then go make the changes you need to make to your Font Styles for this project. I can’t guarantee that would work, but it seems like it might.