CPU overload during export

I know this issue has been discussed several times, e.g.
http://www.steinberg.net/forum/viewtopic.php?f=20&t=1436
http://www.steinberg.net/forum/viewtopic.php?f=20&t=3820&p=26384&hilit=CPU+overload#p26384
http://www.steinberg.net/forum/viewtopic.php?f=19&t=3721&p=26270&hilit=CPU+overload#p26270
http://www.steinberg.net/forum/viewtopic.php?f=20&t=3820&p=25786&hilit=CPU+overload#p25786
sofar it seems that the origin of the problems is not 100% identified, otherwise the issue wouldn’t come up again and again. But it appears more than regularly with external instruments which is very annoying. I assume and am pretty sure, that this CPU which it refers to suggests more an ASIO CPU problem than a real CPU one. Anyway…
I’d like to collect once again all the knowledge concerning this issue in this Post to help others and perhaps myself if someone comes up with some good new know-how.

Insofar I noticed several things when this happens:

  1. during the export of one (external instrument) track, all other tracks are playing too. This is silly, specially as they haven’t interlaced routings. It would be CPU saving to just play the track which is exported (or all tracks connected to…) this wouldn’t be hard to program
  2. It seems to happen often with external instruments (though also VSTi’s provoke that issue… but the freezing option’s easier there). But arguing with external instruments: if it would be like that, then Cubase would have a severe programming failure (IMHO). If you can’t export external instruments, why include them? (Ok, problem is not always appearing)
  3. why don’t I get a CPU overload exception if I reroute the audio-signal from one channel to a new audio-channel and record it there or when I just listen to the track? this is supposedly the same or even more CPU-consuming than just “Export” or Bounce it.

Until now I have found several solution-suggestions:

    • increase buffer size
  • freeze all possible tracks
  • reroute the audio signal to a new audio track and record it there (but with delay which needs to be compensated manually)

but as far as I noticed, these are just workarounds for the real problem… Buffer Size doesn’t always help, much less with external instruments, freeze is not possible on all chanels and doesn’t help if you can’t freeze the channel you like to freeze :wink:. Only the rerouting solution seems the most viable one, with the negative side-effect of needing to manually compensate the delay…

Again I’d like to bring up that issue, becuase I think it is highly annoying to have sooooo much CPU overload exceptions to create Audio-signals frm external instruments. Why the function if the use/export is not supported? Or in other words: If I can listen to the track or reroute the audio signal and record it there without a CPU overload exception, why do I get one during export? An additional write to HD shouldn’t be an ASIO or CPU issue…

Is there any more know-how or possible solutions I forgot to mention?

1 Like

Many reasons. Hitting the RAM limit, mixing internal and external VSTi’s (external aren’t delay compensated unless they’re set up as external instruments), even starting projects at the first bar can cause it as playback begins before everything can sync. Soundcard sharing resources, using the /3GB switch without the /userva= switch set to the correct setting etc. can also cause this issue. So, basically it can be caused by many different things so no definitave answer can be had. It’s a case by case basis.

Also, ASIO overload has nothing to do with CPU. Two different animals.

Agreed, off course there can be more and many reasons.

I was tending more in anotehr direction: I don’t have a clou, why I get a CPU overload exception on my macbookPro when exporting one single external Instrument track.
I’ve got 4Gb RAM
ASIO is on the half to 2/3 of max.
no other app is accessing the soundcard
There’s plenty of CPU headroom left (cubase & firefox only applications on a dualCore system)
(–> OK… by rechecking I see the following, so still 50% CPU left)

           prog          %CPU
1884- Cubase 5     89.1 14:36.37 27/1 1    741  1200  574M   70M    653M   623M   1785M  1884 1582 running
1663  firefox-bin  27.8 11:12.16 26/1 1    217  2711+ 274M-  111M   520M+  378M+  3408M+ 1663 1582 running
1693- plugin-conta 11.6 05:39.98 48   1    330  1187  78M    87M    105M   122M   1150M  1663 1663 sleeping
114   WindowServer 10.3 02:55.01 5    1    252- 1424  9368K+ 119M-  113M   47M+   2848M  114  1    sleeping
0-    kernel_task  5.9  02:37.28 79/2 0    2    1037+ 30M+   0B     293M+  79M+   1852M+ 0    0    running
2045  top          5.5  00:00.43 1/1  0    24   33    1312K  264K   1888K  17M    2378M  2045 2021 running

BUT I try to export just one single external instrument, but the whole rest is playing too (a kind of senseless) as just one track is exported and even ControlRoom deactivated and/or not all the tracks are being played-back… so why play and use and play all instruments, all channel inserts & sends and thereby consuming much more RAM & CPU instead of only the ones which are in the exported track?


P.S: Concerning ASIO & CPU: I know that technically they’re completely different. ASIO is a software construct a kind of bridge to the Sound-system (using the CPU for the needed Audio calculations, so it’s a kind of virtual construct for the Ausio-system though heavily using the CPU and RAM in the system). CPU is plain hardware processing all commands in the operational System. But once I had this problem before, and if I’m not wrong I think I remember I was told or read that When the message “CPU overload during export” Cubase infact referes to the ASIO-calculations reaching it’s limits, not the hardware CPU. That’s also the reason why the ASIo has it’s own performance-meter in cubase, and as a virtual construct the max. should be depending on CPU & RAM of the machine, but in fact I think it has it’s own limit, depending on buffer size etc. So I am pretty sure, that this message actually refers to the ASIO-system reaching it’s limit…

Questions:

  • Is there a way to tell Cubase to only play the exported track (and save CPU & RAM of the others)
  • I have frozen already most of channels, some I can’t because they’re using BeatDesigner and Cubase won’t let me freeze them (around 5 GrooveAgentOne Channels). What else can I do to lower ASIO load?
  • Is there an easier way to bounce one ext.Instr. track to an audio track by re-routing the signals and record them on a new audio track (obviously assuming that the export of a single track fails)

STRANGE OBSERVATION: AS I was freezing one channel, CPU load of Cubase 5 lowered from around 90% to 50%. After the freeze it jumped up again to 90%… any explanation?

I find this error very weired but I think sometimes is related to a Hard Drive error, but I’ll like to confirm…

I explain, I’ve bought a new Laptop (Lenovo y700 15isk), specs:
-i7 6700HQ.
-8GB RAM.
-Video: GTX 960M 2GB.
-HDD: 1TB 5,400 RPM.
This one has Windows 10, and I’m using old Cubase 5.
I use a ZOOM R16 as interface… I’d many problems with that laptop, I got cracking sounds and interference sounds when playing only virtual instruments. And when doing a normal export I got those noises exported, so I tried a Real Time export and the noises went away (almost all), but many times I got this error message of “CPU overload” when exporting.

My old Laptop (Dell Studio 1557), specs:
-i7 720QM.
-4GB RAM.
-Video: ATI Mobility Radeon HD4570 512GB.
-HDD: 300GB 7,200 RPM.
Using Windows 7, also using Cubase 5.
Also using ZOOM R16 as interface… I don’t get any cracking or interferences noises while playing virtual instruments or anything. And when I export on Real Time the same project I don’t any error and it exports perfectly…

The new Laptop has double RAM, a triple better video card and a more than 5 times better CPU… So the only problem I see is the HDD or that Windows 10 has many compatibility problems with Cubase 5, but I remember installing Windows 10 on my Dell Laptop and I didn’t have problems with Cubase 5. I went back to Windows 7 because I couldn’t install some drivers of my Dell Laptop on Windows 10 (like the Video Card and Bluetooth).

Can anyone confirm my guess? Is the problem the HDD? Because it’s strange the lenovo is a 3 times better machine, but with audio it doesn’t proves to be better.