cpu overload for no reason.

I have a song that I’m working on which is all vst instruments and a few reverb plugins as well. In real time play back CPUID HWMonitor is showing I never go above 20% cpu usage on any core (AMD FX8350). I have 16 gigs of ram, this project is barely using any. I use a DEDICATED 7200rmp WD black drive for my sample libraries.

I’ve tried every work around and encountered the same issue or a new one.

For example realtime export results in cpu overload message. Non-realtime export results in off time notes and some midi data not being triggered (ie legato of my strings).

I changed buffer size to 2048 (using ur22) from 1024. This had the exact same affect during PLAYBACK as the non-realtime export, notes off-time, legato not triggered ect, restarted cubase playback at 2048 sound correct. Still can’t export mixdown.

I tried freezing tracks then exporting, cpu overload.

I deleted EVERYTHING but 1 single vst/intrument/track. Still cpu overload. Froze it, still overload.

Decreased export to 8 bit just for a laugh, cpu overload. :neutral_face:

Before anyone asks or recommends to me…here is how I’ve been working with cubase:

Activate multi-processing = CHECKED
Activate ASIO Guard = UNCHECKED
Audio Priority = BOOST
Activate steinberg audio power scheme = UNCHECKED

I’m a gamer also so my computer (windows settings/bios settings) is optimized for performance. NO POWER SAVING.

I’m about 3 hours deep into solving this problem. And I thought phase issues where going to be my problem today… :neutral_face:

I have occasionally had export problems which, bizarrely have disappeared after changing the render start point (non real time)

By the way I have two systems similar to yours, I would have Audio Priority Normal and ASIO Guard ON to get the best grunt from my systems. I have never been anywhere close to maxing out audio even with masses of audio tracks, so I don’t see the need for Audio Priority on boost.

One more thought is to “Backup Project” - keep a note of which version is active!) and then try export again from the backup. Then any audio is streaming from a different disc location, probably less fragmented.

I hope any one of these thoughts help you solve your problem.

A work around would be to freeze the tracks. Start a new project, import said tracks, export stereo mix down.

However there are a few points where the song is getting “spliced” - not asio peaks, not overloads, just missing time of the song around quarter note-ish length so…yeah unacceptable sounds off time and stupid just like the non-realtime export, which makes sense since it’s a freezing is essentially the same thing, a non-realtime export…

So technically there are two issues now I guess. Cpu (non)overload. and rendering it in some autistic down-syndrome manner.

*EDIT
I just opened up some past projects. ALL of them have the same issues. I can’t export. As soon as it hits the first note of the song in realtime export I get the cpu-overload message, non real time export results in notes off time, missing time ect as stated above 9,000 times.

I’ve already reinstalled cubase twice and windows once, in order to fix cubase issues. I’ve only owned cubase for under a year. I don’t understand how it’s possible to get these random bi-monthly WORKFLOW BREAKING issues when I don’t change ANY software or hardware options. It makes no sense. On top of this my UR22 inputs died after 3 months of owning the unit. I’m not happy.

*EDIT
I just created a new project with no tracks, nothing. Cpu overload while rendering. GG.

If previous projects now stall, it would imply that your hardware set up has changed / broken. Full reboot(power lead out) might help. Posting your system specs is definitely needed. Is your dedicated drive internal, or USB for example?

It seems to me like some kind of bottle-necking. Do try the workarounds I suggested first.

Good luck

I’ve tried every possible work around I can think of mate, including what you said. I mean I’ve spent a good 5 hours total trying random things at this point.

I don’t think my system is bottle-necking, based on the fact that rendering a project with zero tracks gets me the same error. I’ll state here that I typically use render in real time and it’s always worked for me. At times I’m dealing with 50-100 tracks with orchestral type music.

Stress tested my ram, and cpu. It’s fine. I play games, so I already knew it was fine but yeah…

System specs:
Windows 8.1 64bit
AMD FX8350
GTX 970
16 gigs DDR3 2133 ram
3 WD Black internal 7200rmp drives (one of which is devoted to my sample libraries)

I’d just say reinstall cubase but this could happen again… :
https://www.steinberg.net/forums/viewtopic.php?f=226&t=86944
And there is NO WAY I’m going to do a fresh install of windows once or twice a year.

Is your audio device running at the correct sample rate ?
I had a problem years ago, when my old Motu 828 was stuck on 96k and the project was 44.1k.
Is your ASIO meter peaking on play ?
Tried starting Cubase in safe mode, to reset the preferences?
Oh and have you used heavy hitpoint detection and editing ?

I might be misunderstanding and way off base here but…

I’ve quite a few scores that emulate ‘legato’ by extending the previous note a little past the start of the next note.

For some synths/plugins this can cause a problem if the same note is repeated using this legato technique. It’s no problem as long as the ‘next legato note’ is NOT the same as the one just before it, or if the instrument is NOT a polyphonic mode instrument. So…if you’re using that particular legato-emulation technique…
First try increasing the number of voices your plugin allows for itself (more on that later), and if that doesn’t work:
Make sure that a note doesn’t overlap itself. I.E. two C2 on events coming before any note off event: C2 on, then comes another C2 on, then a few milliseconds later a C2 off comes and kills BOTH instances of C2 playing…

As for ‘sound dropping out and what seems to be CPU spikes’, consider this:
When using this legato technique, even if you don’t have a note following itself…it can quickly ‘double’ the amount of voices or polyphony the track needs to play back without ‘notes or events getting stolen’. Effectively, that ‘overlap’ period used to create the legato effect require double the number of voices as the same track with no notes overlapping. So…if your plugin allows it, double the number of voices/tones it can play back.

Just as an example…Halion 5 comes set to 128 voices out of the box. A typical classical score (I.E. Beethoven’s 3rd Symphony) requires around 300 voices when I use this ‘legato effect’ on the string and wind parts in combination with the HSO soundset. In contrast, if I use a logic editor to get rid of all the ‘emulated legato’ (overlapping)…the voice count is less than 200, but STILL more than the default 128. So, right out of the shoot, I know I need to bump up the number of voices H5 will allow itself in the H5 ‘Options Tab’. If I neglect to do this…it SOUNDS BAD…as in drop outs…and possibly even ‘stuck notes’. Once I bump up the polyphony limits for the plugin…it sounds great and even on my ancient AMD Phenom with only 8gig DDR2 memory…it’s good to go for many more tracks of VSTi voices and VST processing plugins before I need to consider rendering some tracks down to audio.

I’ve some plugins that just do NOT like overlapping legato at all. In most cases I only need to watch out for back to back occurrences of the same note (make sure those do NOT overlap)…and otherwise it’s OK. Also…it really does not matter if Cubase is the host, or something else (like Sibelius)…some plugins/synths/samplers just do NOT like overlapping occurrences of the same note…and any of them will need ‘double the number of voices’ available if you use the overlapping legato technique.

For me, as a general rule of thumb…if I’m working with passages that need a lot of ‘legato’…I’ll go in and make a patch that adjusts the attack and release times with a pedal or key switch rather than using the old ‘overlapping notes’ approach. It’ll still need MORE voices than a non legato/connected phrase. Of course, if I’m strapped for time and must deal with a misbehaving track that uses the ole fake legato tactic…I’ll just work up a quick logic editor that makes sure back to back occurrences of the ‘same note’ do NOT overlap.

Yes def the correct sample rate.
ASIO meter is not peaking at all.
Have yet to start cubase in safe mode (didn’t know there was such a thing), vast majority of preferences are default…but I will try.
I don’t use hitpoint detection at all.

Wow that’s a lot of effort you put in, thanks. But I’m afraid I’m already aware of all that information! I’m mostly working with East West libraries with the new PLAY software. The issues I’ve mentioned are actually missing time across ALL tracks, the whole song…just happened to be at a point of a massive legato with strings… it’s not that the legato isn’t triggering I guess. I realized it just missing a couple chunks of time for no reason (when it does render…otherwise cpu overload.) For a second I thought maybe I forgot to increase voices, and your comment reminded me to… however the fact I can’t even render an EMPTY midi or audio track, or empty project proves the problem is fundamentally bigger and not vst specific. It’s cubase.

So I tried two other asio drivers. They both worked with realtime and non realtime rendering on projects ranging from 10 to 50 tracks utilizing insane amounts of voices and 12 gigs of ram. :sunglasses:

I switched back to my steinberg driver and all the sudden it decides to work. So I guess I solved that problem…

As far as the skipping/missing time in this specific project upon rendering (it’s PERFECT on project playback)… I think I’ve narrowed it down to a specific string patch.

The combination of the two issues made it even more confusing. But they appear to have been two separate issues all along. If I can render I’m happy. This other issue has to be a bug with CC stuff. I’m sure I’ll figure it out.

Thanks for actually helping and responding guys. My last experience on this forum was horrible. (horribly lacking any response).

So interestingly enough the issue starts happening again only on this one certain project. Once the issue has developed it is present during any rendering of any project. As soon as I switch to different asio driver it’s fine again. So the issue is the Steinberg Yamaha USB ASIO driver (UR22 interface).

I’m about to the point of scrapping the idea of using said driver. period. If there’s one thing I hate in life more than anything, it’s a faulty driver. AMD users will know my pain :laughing:

There are known issues with the UR series drivers and especially with the UR22 on some system setups. It seems to be rare though and not sure if it is even related to your issue. Steinberg is still looking into it.

Not sure if this link will give any insight but here it is anyway.


Best to you!

https://www.steinberg.net/forums/viewtopic.php?f=157&t=73667

CPU overload for no reason (you know of) If you ask me the reason I am sure you use 32 bits old plug ins within your system and THIS create a CPU overload. Start a new test song with all your files (while keeping your original song) Just keep the 64 bit plug close the 32 bit plug in and play back … Do this test test you will see I am right. Thanks Goodnite

What?

What?[/quote]

I say his CPU overload because he probably use older 32 bits plug-ins in a 64 bits system. I just suggest to test it it and close the 32 bits plug ins. What is wrong with my answer that you dont understand dude? I mean englsih is my second langage I do my best . so the way you say ‘‘what’’ is very rude This answer is not nonsense in fact its probably the best answer to his question and at least the good direction Bye dude

Same issue here. Also using Steinberg Yamaha USB Driver. I’m not using any 32 bit plug ins. All 64 bit in 64bit Cubase 8.5.10 Pro. Frustrating. Can’t freeze. Can’t mix down. Just stuck with CPU overload.

I can also confirm it is Steinberg Yamaha USB driver causing CPU OVERLOAD even though CPU use maxes at 19% and RAM use under 6GB. Am already using the latest driver. Other ASIO drivers do not ever give CPU overload! But they are not fully working either when I do AUDIO mixdown or Render in place with a Mox VST3 channel.

Steinberg, will this be updated/fixed?