Cubase 12.0.50 changing output routing/showing different routing in Inspector and channel settings

I found a rather concerning issue: Cubase will silently change the output routing on tracks, which will end up routing signals to where they don’t belong and thus mess up a mix.

I spent hours hunting down such an errant track routing and initially thought I had made a mistake, until I noticed the issue occur without me touching the routing.

Sometimes this change in routing will result in audio being routed where it doesn’t belong, and sometimes it shows as incorrect routing in the Inspector window, but will show the correct routing in the channel settings window.

Here’s an example - this is a track that is set up to receive the output from a group track as an input, and that is routed to “no bus” for its output (I use this as a “dead end track” to export specially configured stems by selecting it in the Export Audio dialog). The channel settings will correctly show this routing, but the Inspector shows that this is routed to “Main” (when it is, and should be, routed to “no bus”).

Sometimes I can fix this by selecting “no bus” in the Inspector to make the channel settings and inspector windows consistent again, but I’ve had cases where I make that selection in the inspector but the routing jumps right back to “main”.

This is a spurious issue, and I don’t really have the time to dig around to see if I can make a reproducible case, so I’m posting this here, hoping that somebody else has encountered this and is further along in the diagnostic process!

Just want to add I had a case with 12.0.40 where I had several Komplete Kontrol VSTs receiving midi via the routing in a midi channel. At a couple of occasions it got all garbled up and sent things all over the place. Also, hard to replicate so I did not report, but sounds quite similar just midi vs audio. And the name updates of the midi channels did not follow through either.

1 Like

Probably not related (since it’s MIDI instead of audio), and there’s 3rd party code involved, but still annoying!


This puzzles me… I’m wondering the W button is not dialed in the Channel Settings Window neither.

Would you be willing to share the project (the only faulty track). Does the issue remain of you Back up Project?

It would be great to know, how did you get to this state. Did you import the track?

1 Like

It is puzzling for sure.

What do you mean that the W button isn’t dialed in?

Let me spend some time trying to reproduce this, and I’ll share more detailed findings then to make it easier to narrow down. Stay tuned!


I mean the Write automation. In the Project window the button is disabled (because of the Lock), but in the Channel Settings Window the button is enabled.

I don’t understand - I don’t have write automation enabled anywhere in the project, including on the channel settings on the track in question (see red circle)?

Martin, the Lock is only for disabling the editing of the Events. It has nothing to do with the Write automation. Your posts are really confusing sometimes, and the Write and Lock buttons aren’t even involved in this topic, maybe you answered in the wrong place ? :sweat_smile:

I don’t think he meant that it’s enabled, but rather possible to enable it on the channel settings window, whereas on the track inspector it’s greyed out so you can’t enable it.


Here the Automation Write button is disabled. I would say it’s because of the Lock. The Lock doesn’t allow you to edit the parameters, therefore it doesn’t allow you to write an automation.

What is confusing on it?


But maybe it’s somehow related and it maybe leads to something…

Good point, it could lead to another entry on the issues wiki that no-one is willing to pin? :slight_smile:

1 Like

Ah, now I understand (thanks @skijumptoes for jumping in and helping explain).

That is indeed odd, and I will check whether unlocking the track will make any difference.

It may or may not be related, but either way, good to bottom out on that and figure it out.

I’ll report back after I’ve found some time to do this.