Cubase 12 ONLY - Drop outs in Kontakt when more than 4 librarys playing

@KennyEastMids , just to make sure, you have already updated to 12.0.20, haven’t you?

Please let me add a general comment about the way things are expressed sometimes: I think it is highly understandable that a person who stumbles into problems with a piece of software that did not exist before for seemingly no good reason is somewhat emotional and maybe not chosing the right tone in the first place. Professional support is to a high degree about being able to manage and deescalate these situations (instead of pouring “oil into the fire” by posting more or less equally emotional replies. I have made the mistake of being too emotional in some situations repeatedly - and it will for sure happen again - what I/and others! need then is support. Respectful support. sometimes a little hint like “please let us focus on the issue you have and switch to a respectful tone”. Me personally - I profit/benefit from such reactions in cases where I maybe was too emotional.

1 Like

I’m trying to reproduce your issue in Cubase 12.0.0 and 12.0.20, you didn’t specify which articulations you have on your multi, so here’s what I did:

5x Kontakt 6.7.1 tracks (vln1, vln2, vla, cello, bass) each containing one SF Chamber Strings Performance Legato.
5x Kontakt 6.7.1 tracks (vln1, vln2, vla, cello, bass) each containing one SF Studio Strings Performance Legato.
*I chose the Performance Legatos because they are the most CPU intensive patches.

All tracks play just fine, my CPU barely hit 10%. I wrote a very busy passage and random CC1/CC2/CC11 data, and made sure all tracks were playing during the test.

Here are my settings:

Cubase
32 bit float
Multi Processing CHECKED
ASIO-Guard CHECKED
ASIO-Guard Level Normal
Audio Priority Boost

Kontakt
Multiprocessing 8 Cores
Preload size 24kb

Windows 11 21H2, i7 11th gen, samples hosted on SATA SSD, MOTU Ultralite AVB, 256 buffer size.
I also tested on my Windows 10 computer, it’s an old FX8350, Focusrite Scarlett 2i2 3rd gen, 256 buffer size. CPU sits around 35% while playing.

I have Kontakt set to use all cores on both computers, even with Multi Processing enabled in Cubase. That’s what work best for my particular setup.

If you want, please attach the MIDI file and articulations used (you can write that on each track name) and I’ll give it a try.

1 Like

@zolhof Thank you for your support! Appreciated!

@KennyEastMids Is there anything else in your setup that you didn’t mention so far? Do you use any plug-ins in the Control Room or on the Main Bus?

Do the dropouts also happen when no track is selected (and no track is processed in real-time)?

Have you tried to backup and delete your preferences and then start Cubase? Ideally both, Cubase 11 and Cubase 12, preferences folder.

Do you insert Kontakt as a Rack Instrument or an Instrument Track?

1 Like

Yes I upgraded on the day it was released.

Hi zolhof

Thank you for trying to help, it is really appreciated.

I have been in and out of a clients recording session all afternoon and this evening so I have only just got the chance to reply.

I can confirm that the articulations you have used are the ones I used except I used except I was using standard legato (not performance) to save on CPU but so that we are both using the same I will do the following tonight.

I will create a new blank project in Cubase pro 12 with the same settings as you.
I will add one instance of Kontakt as a Track Instrument, and one instance as a Rack Instrument.

In to each Kontakt I will then load -
5x Kontakt 6.7.1 tracks (vln1, vln2, vla, cello, bass) each containing one SF Chamber Strings Performance Legato.
5x Kontakt 6.7.1 tracks (vln1, vln2, vla, cello, bass) each containing one SF Studio Strings Performance Legato.

This way we are both testing with the same.

When I can tomorrow (we have sessions booked in all day), I will screen capture it as video (with sound) so you can see the settings within CB 11 & CB 12 are exactly the same and will then play back my MIDI files.

This way you can see and hear the issue happening rather than me trying to describe it.

I can also zip up the CB 11 & CB 12 project files and MIDI Files together with the plug-in Reports that Matthias has asked for so that you can see everything.

Due to another CB 12 issue where my Arturia MiniLab mk II has stopped working after installing the v12.0.20 update (it worked perfectly before), I have performed a clean fresh install of v12.0…00, v12.0.10 and then v12.0…20 as admin so all previous Cubase preferences have been (backed up as Matthias suggested) but then deleted from the system.
https://forums.steinberg.net/t/since-v12-0-20-my-arturia-minilab-mk-ii-no-longer-works-in-cb-pro-12/785557

So for the test I have fresh install of CB Pro 12.0.20 Build 263 and the only 3rd party plugin is Kontakt 6.7.1.

I can also confirm that even when I had all of my 3rd party plugins installed my CPU usage was quite low, as was memory usage.

With the fresh Cubase 12 install the CPU and Memory usage is even lower but the issue still happens.

I appreciate you trying to help me and I hope that the video will let you see and hear what is going on.

1 Like

@KennyEastMids Unfortunately we cannot reproduce the issue on our systems.

What does your system have, that we don’t?

Do you have any kind of other peripheral hardware attached? A screen splitter for multiple screens? Or a specific MIDI controller? Anything unusual that might interfere with Cubase 12?

Also, where are the Kontakt library stored? On the internal drive or an external hard disk?

Or do you use any kind of software on your systems that is active in the background while you are running Cubase?

Or very dense controller data maybe?
There was someone else (or was it you on another forum) that stated it starts happening when all needed controller data, midi CC’s, are added. He could fix it by using not to many instruments per kontakt instance, but did not like that solution.
Also kontakt has a strange relation with asio guard. And remember when you record enable 1 .midi track, the whole kontakt instance goes to real time mode, not just the one instrument.

No worries man, that’s an odd issue but hopefully you will find the culprit. You shouldn’t be having any performance loss from C11 to C12, your i7 isn’t that different from mine and it certainly smokes my old FX8350. It makes me think this is something related to Windows, a specific setting that didn’t migrate from previous versions, or some weird MIDI overload.

In my particular case, if I limit the number of cores in Kontakt, it severely affects performance. That’s always been the case with my FX8350 and it’s the same with my new i7. So I have cores maxed out in Kontakt (also VEPro when I use it) and have Multiprocessing enabled in Cubase. I’ve read many recommendations over the years to limit the number of cores in Kontakt/VEPro and let Cubase handle it, but that simply doesn’t work for me. Of course, it’s all trial and error, so your case my vary.

A few things I always do:

  • Exclude every single DAW-related folder in Windows Defender (or 3rd party anti-virus). Here are the ones I have:
All sample drives entirely
C:\Program Files (x86)\Common Files\PACE
C:\Program Files (x86)\eLicenser
C:\Program Files (x86)\iLok License Manager
C:\Program Files (x86)\MOTU
C:\Program Files (x86)\Spitfire Audio
C:\Program Files\Common Files\VST3
C:\Program Files\eLIcenser
C:\Program Files\Native Instruments
C:\Program Files\SINE Player
C:\Program Files\Steinberg
C:\Program Files\Vienna Assistant
C:\Program Files\Vienna Ensemble Pro
C:\Program Files\VSTPlugins
C:\ProgramData\eLicenser
C:\ProgramData\MOTU
C:\ProgramData\PACE
C:\ProgramData\Spectrasonics
C:\ProgramData\Steinberg
C:\ProgramData\VSL
C:\Users\USERNAME\AppData\Local\Native Instruments
C:\Users\USERNAME\AppData\Local\Orchestral Tools
C:\Users\USERNAME\AppData\Local\Spectrasonics
C:\Users\USERNAME\AppData\Local\SteinbergActivationManager
C:\Users\USERNAME\AppData\Local\VSL
C:\Users\USERNAME\AppData\Roaming\com.spitfireaudio
C:\Users\USERNAME\AppData\Roaming\Spitfire Audio
C:\Users\USERNAME\AppData\Roaming\Steinberg
C:\Users\USERNAME\AppData\Roaming\VSL
C:\Users\USERNAME\Documents\VST3 Presets

It may look overkill but I want to make sure Windows Defender isn’t trying to access sensitive files during a session (and I don’t want to disable Defender altogether).

  • Block Cubase, VEPro, Kontakt, etc in Firewall, again don’t want anything getting in the way during a session. If you need Cubase to be connected to the Internet, skip this one
  • Disable indexing in all sample drives (right click drive letter and uncheck “Allow files on this drive to have contents indexed”)

Kontakt
CPU overload protection DISABLED
Multiprocessor support MAX
Preload size 24kb
Usage Data Tracking DISABLED

Looking forward to the video and MIDI, it will be easier to compare notes. It’s frustrating when things stop working seemingly out of nowhere, I can sympathize.

Edit. Double check if ASIO-Guard is actually enabled for Kontakt in the VST Plugin Manager.

Hi Matthias

Thank you for your reply and I am sorry that I have not replied until now but one of my engineers tested positive for Covid and I had to cover a 3 day booking for tracking.

Normally I would have a Arturia MiniLab MK II, a SSL UF8 and a Korg NanoKONTROL Studio connected but no screen splitters or anything else. None of these controllers should cause any issue with Cubase 12, and they all work perfectly on Cubase 11.

When this issue first started, the first thing that I did was unplug all hardware so that the only things connected were my mouse and my Steinberg UR22c.
in the video that I am uploading that will show you the issue, it is a fresh clean install of Cubase Pro 12 v12.0.20 with only the UR22c and a Mouse plugged in.

They are on an internal NVMe M.2 2TB SSD.

My drives:
System Drive - Samsung SSD 970 EVO Plus 500GB
Library Drive - Samsung NVMe M.2 SSD 970 EVO Plus 2TB
Projects Drive - Samsung NVMe M.2 SSD 860 EVO 1TB

The only software that could run in the background is the SSL 360 app (when the UF8 is connected), The Arturia Software center (when the MiniLab MK II is connected), the Korg MIDI Editor (when the Korg nanoKONTROL Studio is connected) and the Laptop manufactures temperature and fan control software.

If I shutdown the temperature and fan control software the laptop fans run at full speed which, due to fan noise, interferes with recording and mixing.

I would have thought if any of these are to blame then they would also cause issues in Cubase Pro 11, Ableton Live 11, Pro Tools 12 and Studio One 5 but they do not, I have no problems at all in these programs, only Cubase Pro 12.

You can see it all in this video…

Video for Cubase tech support

Hi zolhof

I matched your testing, I was using normal Legarto articulations but I have now changed them to Performance Legato to match yours.

In this video, you can see my system specs, Cubase Pro 11 playing perfectly and Cubase Pro 12 with either MIDI or/and audio dropouts - I hope that this helps…
For Cubase tech support

Anyone ?

I put a lot of effort and my personal time in to making that video for Steinberg that clearly shows the problem when there should not be one.

You have not replied - why?