Cubase 12 Pitch shift issue

Hi all, anyone facing issues with the pitch shift process? I am unable to transpose a whole octave (audio track) but was perfectly able to do the same thing in Cubase 11.

You’re more likely to get a useful response if you give a little more detail about what this actually means

Hi Raino, sure, let me fix that and add some context.
So, when selecting an audio track and I go process > pitch shift in Cubase 11, it looks like this:

When you zoom in, please notice the range brackets underneath the keyboard

Have to split in two comments because of attachment restrictions

Here is the same process with Cubase 12:

Please notice how the same range brackets are allowing for a shorter transpose interval which doesn’t allow me to pitch shift my audio track down an octave, which is big problem for my work process since I was using this a lot.

Am I missing something in my project settings or does this affect others as well?

Thanks in advance!

The restrictions will go away as you read/post more on the forum.

This isn’t a area where I have much expertise as I mostly use Melodyne for stuff like this. But there certainly folks around who will know.

The restrictions go away when you reach Trust Level 1. This is how you get there:

Get to trust level 1 by…
*** Entering at least 5 topics**
*** Reading at least 30 posts**
*** Spend a total of 10 minutes reading posts**

By reading they just mean slowly scrolling by a post. So 10 minutes and you’re good to go. No posting required.

Understanding Discourse Trust Levels



I can reproduce what you are observing and no playing around with as many things as possible seems to change it. It fact, I observed other strange behavior when adjusting the Pitch Shift Base Root/Pitch settings. The range did not always follow those settings and often various transpose values would pop-up when I adjusted the root value or pitch.
I suppose you could work around this using a pitch plugin if you have something appropriate.
Hope this gets fixed soon.

1 Like

Thanks a lot for taking a look and trying to reproduce the error!

Ok, looks like we have found a bug here. I’ll report it in the correct category so the devs can take a look :slight_smile:

1 Like

Just edit your initial post to add the issue tag


This seems to be an issue with the MPEX algorithms only. If you select one of the Ă©lastique alternatives from the lower right drop down list, much wider pitch ranges are supported.


Hmmm, sorry, I can’t find the option to edit it… still new here to the forum :smiley:
Do you mean like to recreate it with the additional tag?

You should see an Edit button on your own posts


No it’s the one next to the topic title.

Can you elaborate ? We need to make a full list of the issues related to Pitch Shift processing, including repro sequences.

I have added it to the Issues Wiki.


Change Root and Pitch. Check the range. And what happened to the root note display (red)

Martin90 got it right. Just use the élastique algorithm. It seems to behave properly and doesn’t have the range issues.

Thanks for adding it into the issue Wiki! :smiley:

Unfortunately I don’t have the edit option next to the topic title, but having it placed in the issue wiki should do the trick

@SF_Green, yes, using the élastique algorithm is a workaround, but I don’t think we can mark it as a solution yet since the initial problem persists.

@SF_Green @djuko Actually, not being able to transpose one octave with MPEX algorithms isn’t an issue. As you can see it only goes -11 to +11 semitones. If you want to transpose with no limits, then select the elastique algorithms. So there is no workaround of some kind, it’s like that by design…

The only issue is with the range and transpose visual indicators under the keyboard, only when MPEX algorithm is selected.
When you scroll the Root Note Pitch with the mouse wheel or by clicking the arrows, you’ll see that when you’re done going up, then the next time you go down will cause the range brackets to go up instead, but only one time, the subsequent scrolls will make the brackets go in the proper direction, but will always precede the Root Note in red by one semitone.
It does this with both directions. To make it more obvious just scroll up and down repeatedly by only one tick.
Just note that the Root Note in red follows properly. The visual indicators of the range and transpose values are always off, but you can still click out of the brackets to select the transpose value as long as it is +/- 11 semitones around the Root Note.
Sometimes the Transpose Note in blue visually ends out of the +/- 11 range, but if you apply the processing you’ll see that it will only transpose to -11 or +11, because that’s still the value that appears in the box.
The issue is purely visual, although it can effectively change the transpose values on its own while changing the Root Note Pitch, but they’ll always stay within the real transpose range.

Yes, that’s right. However, in Cubase 11 it’s possible to alter the pitch by ±16 semitones with the MPEX algorithms. So they have been restricted in Cubase 12 for some reason. I also read somewhere that MPEX is not supported on M1 Macs in native mode. Maybe it’s just an outdated algorithm that will be completely replaced by élastique at some point.


Martin 90’s response solved it for me: change the MPEX option! It’ll give you the octave!