Cubase 6.5 / Artist 6.5 / PadShop Installer solution

Hi all,

We are sorry, but there has been an issue with the download host, leading to corrupted Installers. Users which qualify for the Cubase 6.5 / Cubase Artist 6.5 Grace Period update and have downloaded the corresponding file are not affected!

Please accept our apologies for any inconvenience caused and we hope you’ll soon enjoy the new features of the 6.5 update!

All customers who purchased the update, should have received a new download link in their Asknet account by now. Please use this link to download the update!

Thanks for choosing Cubase!

Helge Vogt
Product Marketing Manager Cubase
Steinberg Media Technologies GmbH

Thanks Helge, downloading now. Will report if it works when it’s ready :slight_smile:

1 Like

I can not purchase but downloading (so far so good) from ftp. Would like to do the payments but how if my cart still appears to be empty?


shop repaired (at last :/)

1 Like

Extracting works now, haven’t been this far yet :slight_smile:

1 Like

Yep, all working fine, cheers for the quick fix Steinberg!

Good to hear! :slight_smile:
Thanks for your patience!

Oh dear…!

Downloaded new ver from ftp site (as per Helge’s note).

Extraction goes ok, but at the end it stops with ‘Installer has stopped working’.

Cannot proceed any further. The Steinberg_Cubase 6.5 folder created contains *.msi files, Additional Content folder etc. and a Setup.exe.

Double-clicking the Setup.exe says the same message, (that it has stopped working). The *.msi packaged files won’t work, stating ‘Another version of this program is already installed. Installation of this version cannot continue…’

And now I’m bored.

I’ve tried twice to do the unpack; rebooting in-between.

As my sig says, I am on Vista32 SP2 btw…

Any clues please…?

Hello Puma,
Log-in to your Asknet account and download the link again. The files on the Asknet server were just changed, it should work now for you. :slight_smile:

Hmmm… ok, well thanks for that. I’ll give it a go. But how does this relate to Helge’s new ‘link’ (to the ftp site download), which is what I am trying…? Just curious…

I’ll update the post in a minute to reflect just that :slight_smile:


My point being, I’ve got the problem (‘installer has stopped working’) with the file at the ftp site link; is it going to be the same file at the AskNet site…?!? (which i am trying to d/load now.)

No, your download was interrupted before it was finished. Please check your Asknet account for a new download link or re-download from the ftp (though Asknet is faster).


Hi Helge - no, sorry. Both times the file fully d/loaded ok (758,243 Kb). From the ftp site, or just now from AskNET. Then, the unpacking/extraction got to the end of its process and then the (Windows) message ‘Setup has stopped working’. I hit the ‘view details’ button and it says Setup.exe has crashed.

Problem Event Name: APPCRASH
Application Name: Setup.exe
Application Version:
Application Timestamp: 4f31103a
Fault Module Name: KERNEL32.dll
Fault Module Version: 6.0.6002.18005
Fault Module Timestamp: 49e037dd
Exception Code: e0434f4d
Exception Offset: 0003fbae
OS Version: 6.0.6002.
Locale ID: 2057

Thanks in anticipation of any more clues you may have… :frowning:

Is is safe to download from the link provided at time of purchase (about 2 minutes ago 11:50 am EST) or is the ftp link still recommended for Mac OXS?

Best regards,

Edited Message
It is safe!!!

I downloaded the Mac OSX installer from the link provided at time of purchase. No problems opening the installer and no problems with VST Performance etc so far :mrgreen:

i5 MacBook Pro 8GB RAM OSX 10.7.3

:arrow_right: More to follow this evening.

Hi Puma,
please try running the Installer as an Administrator by right-clicking and selecting “Run as Administrator”. Does it help?


Trying now…!

EDIT:- no, still crashes at end of extraction/unpacking…! Do you have a Vista box with C6.0.5 around anywhere perhaps, you could try this on…? Also, I have a thread open, for others to post their results on Vista32 in the main forum. I know its not supported, but C6.0.5 is perfectly fine…

Ok, we can have a look at it tomorrow. We really need a break for today.


Of course…! Thanks for your time so far Helge.

Mac version can’t be installed, the update does not find a valid Cubase 6 installation.

I have already installed the latest elc driver! OS X 10.6.8


From where did you install the update? From the Shop or the ftp site?

I ended up downloading both, but the one from the Shop finished first so that the one I installed.

I did have to enter the activation code in the ELC. Did you go through that step?