Cubase Pro 11 loses focus on Windows 10 (old bug still not fixed?)

Cubase Pro 11.0.0 Build 300 on Windows 10 v18363.1198 loses focus after certain operations.
The behaviour seems to be the same across the various operations.

After importing media to the pool.

  1. New project.
  2. CTRL+P, right click, import media.
  3. Select file in browser, click import.
    -> Result = Cubase loses focus.
    This seems to be related

After adding/attempting to add a group track to selected channels.

  1. New project.
  2. Add two tracks and select both.
  3. Right lick and select new track, create group channel for selected channels.
  4. Click ok or cancel in the add track dialog.
    -> Result = Cubase loses focus.
    This seems to be related

Please take a look at this, it needs to be properly resolved.
Thank you!

Still going on, and it’s not just those instances you mentioned, this happens in other applications on Windows as well. This might be an MS Windows problem.

Yep, this has been bothering me for years since the windowing model changed around V 6.5 or 7 if I recall correctly.

I included this issue in my response to the user satisfaction survey as well.

Thanks for chiming in guys, the more who point this out to Steinberg the better.

I have hundreds of other apps installed on my machine that doesn’t have this problem, so I’m fairly confident this is a Cubase/Steinberg problem.

Perhaps the developers and testers only use Cubase as the only running software?
Otherwise they would for sure have seen this issue. I’ve seen it daily for years.

Count me in as someone who experiences this multiple times every day on Win10 (1909).

But I also don’t know if it’s more of a Cubase issue or more of a Windows issue.

1 Like

I have this problem too and haven’t noticed it with other apps (only cubase).
It would be great if it gets solved!!
I’am in cubase 11 pro and it has happened since version 8 or 9 I think.

1 Like

Same here, has been an issue for I don’t know how long. Happens every single time I do detect silence, which is epilepsy inducing when you run it on multiple events since the Cubase window will start flashing. Once it’s finished, it’s always out of focus.

Me too. It happens reliably with Cubase Win10, and certain other Windows applications.

Yes, happens here as well, e.g. export midi file …focus shifts to another program on another screen!?!

Thanks for chiming in.
I must have gotten so used to it that I started to block how often it really happens.

I’ll start putting together an extensive list of what actions in Cubase triggers the behaviour.
This really needs to be sorted.

Hello everyone, the same problem occurs to me but also when I open a vsti

Work life took over for a bit, I’ll make sure to put together a list over the weekend.
It happened again last night when adding an instrument track.

It’s a big problem - and yes, it’s been on Windows since they changed their already original flawed windows implementation. Would love to see it fixed …
dbh

Never encountered that bug before but now I noticed it in the latest update Cubase Pro 11.0.10. It happens to me when:

  • I open the control panel of my Focusrite in the Cubase studio setup, close the control panel, and then close the studio setup
  • I click “store” in the preferences, then close the preferences window (also when storing key commands and probably at other similar places too)

Not that severe of a bug but pretty annoying.

This is a part of a rather strange windows management which belongs to Cubase culture since its beginning : I remember that Cubase on Atari ST (yes, circa 1985… :sauropod:) had a specific windows layout called M-ROS, if I remember well. Since, Cubase has never really worked like any other regular applications, at least, on Windows (I don’t know if OSX users are experiencing the same pitfalls).

More concretely, the Cubase ‘vanishing’ behavior happens with only specific window. In my case, mostly, it’s the Audio system and the Generic remote panes of the Studio setup… window that are involved, as well as the Profile manager one. I cannot confirm that it is happening when adding an instrument track, though there is a kind of delay more or less important and depending of the VSTi used before Cubase is in focus again.

FWIW and it’s by no mean an extensive test, but it seems that the new modal windows with OK, Cancel and Close rounded corners buttons are prone to make Cubase vanish, but only when some changes have been done, this, no matter the way used to close them (even the X upper right icon makes Cubase disappear).

The more old fashioned windows (with no rounded buttons and a grey background) such as Preferences or Key commands ones work as expected in all cases, here (IOW, Cubase stay on focus after closing them).

At the end, there is obviously a serious work to be done to streamline the whole application behavior… :neutral_face:

I cannot repro any of these in Win 10, would be nice to see a video of it. I am trying to think if I have experienced this but did not know it?
I do notice odd behavior (which is annoying) that the main Cubase window doesn’t show all its contents while it is not in focus, very hard when copying something to another program or visa-versa.
Also, I noticed the the solid grey background always disappears sometimes and reverts to it not being displayed (this changed around Cubase 7 afaik)… I wish there was a feature to ‘always show solid background’ on main Cubase display or something…
/p

Try this:

Launch Cubase, and and maximize the Project Window (note: not the “Cubase Desktop”)

  • Open a web browser.
  • switch to Cubase
  • Open Studio Settings
  • add a generic remote, and edit any row.
  • hit OK

Browser comes in front of Cubase

1 Like

Thank you Steve, I can repro it now with your method.

I’m running cubase 11 pro on a pc an facing the following behavior:

  1. add new track in a project
  2. select an output where the track will be routed
  3. confirm with “ok”.
    The focus jumps out of cubase and I have to reselect the cubase window to continue. Keeping the choosen output for adding other tracks works fine. But by changing the output of a new audio track to another bus than the current will repeat the issue.

Yes, known problem which has been reported. I’ll merge this topic with the others.