Disappearing CD/DVD burner bug back again?

i don’t know which version it was, 10.0.20 or 10.0.30, that made, on windows, my CD/DVD burner inaccessible, i.e. didn’t show up in explorer.

the same thing happened with .50; it is there in the BIOS, but not for windows (in device management it is crossed out, so to say).

it was mentioned the last time by more people, but not now. but the correlation; installing update of wavelab, and CD/DVD burner “gone”… i didn’t see it after 1 or 2 days… seems to me, now the most obvious cause, because it happened before.

i reply to myself. mounting iso’s does not work also anymore (trying to install something via native access). so i think this bug is back again, it gives some trouble…

windows 10 pro (20H2).

hi Howl

I’m on 20H2 - my optical drive is fine (not sure when I actually last used it though!)

What’s the specific bug you are referring to ? And what happens when yo re-enable it in device manager ?

I am on Windoze 10 Professional 20H2 and just tested the two CD/DVD burners (one USB one internal) … both are working as expected… including right click ‘eject’ etc… These are Pioneer ‘premiums’.

Device SCSI\CdRom&Ven_HL-DT-ST&Prod_DVDRAM_GH24NSD1\4&39693902&0&040000 was migrated.

Last Device Instance Id: SCSI\CdRom&Ven_HL-DT-ST&Prod_DVDRAM_GH24NSD1\4&39693902&0&040000
Class Guid: {4d36e965-e325-11ce-bfc1-08002be10318}
Location Path:
Migration Rank: 0x0
Present: true

but: Kan dit apparaat niet starten omdat de configuratiegegevens in het register onvolledig of beschadigd zijn. (Code 19)

can start this device because configurationsinfo in the register is damaged, my bad translation.

the same problem as before. it has a warning, can’t enable it.

mounting iso’s (virtual cd/dvd) does also not work anymore. this has been reported before, as i mentioned. perhaps not everyone experiences this problem.

or something else has messed things up. but i can’t determine what that could be. accept wavelab, usuals suspect. shall try the search function.

perhaps, in this case, it can be something else, but i only remember that i updated wavelab, and nothing else. but my memory and me…

but if this happens, as it happened before, me thinks: wavelab.

of course i can be absolutely wrong.

thanks for your response! i built my desktop myself, but can’t remember the manufacterer, it could also be the second one, the first one was a leftover, and “died” soon…

a cheap burner, that works great. built in, by the way, no usb, sata.

already mentioned: BIOS detects the burner, it seems windows too, but the register fault…

I’ve been using wavelab since v1.5 and never had that happen. I’m not saying it’s impossible of course…but I’m not sure why you are linking the problem to wavelab ?

have you tried fixing up the registry - shouldn’t be too difficult to find ?

or just uninstall in device manager - and reboot ?

i shall try to do that; i found the previous thread, it was version 10.0.3 that also causes this:

there is a workaround, didn’t try that, 10.0.40 was soon available. but still… i hope somebody can confirm.

the registry can’t be damaged by something else, educated guess. i still think wavelab is responsible, see the older thread. but i can be wrong, but i can’t figure out what will do that.

o troubleshooting, is it these times, how many support tickets, troubleshooting i did. a lot has been resolved. but still… i am bit tired of troubleshooting, but i will give it a try.

thanks again! (and perhaps it only appears this problem, if wavelab again is the cause, can’t be sure of course, on certain systems. i have native access, or other installers, that mount virtual drives. a guess… i know my stuff about computers, but less and less, so i am not anymore the to go guy for computer problems… i let them figure it out themselves, with a little help…)

interesting - did you try the registry fix from here …

1 Like

i shall try that. maybe a virus scanner problem. avast bugs every installer nowadays.
but 10.0.4 was the solution for me. strangely. o well. will try it.

will let you know, and thanks again for your help!

Hi Guys, I also logged a call after an update to WL Elements v10 arrived (v10.0.30) as my CD/DVD drive had registry errors, however when I rolled back to v10.0.20 Full the issue went away.
I then tried v10.0.40 and it failed again until I applied v10.0.40 full
Then guess what v10.0.50 came out and broke my CD/DVD drive again so keeping to the previous version until the next full release.
Clearly a developer issue with the updates not applying the patch correctly to some CD/DVD drives. This also breaks my external Blue ray USB DVD player as well but when reverting to previous working version they both work perfectly for any apps or CD/DVD/Blue ray disks!

ok confirmed (almost) that is wavelab again causes this issue.

the .50 version is coming, i hope this will solve it again.

workarounds, i don’t like. frankly.

Same problem with my setup. After using the full installer for version 10.0.40 everything works as expected. Then I apply the patch 10.0.50. CD drive gone. Device manager: Error 19. After registry fix: CD drive available in every program except WL.
For me it looks like something is wrong with the update installer, and the problem should be searched there.
As it is now: If we want to use the CD/DVD drive, we have to work with the second newest version of WL. Why is there no full installer for version 10.0.50?

i didn’t try the register fix yet, but WL does not find the CD/DVD drive, in that case, as you mention.

strange that this keep appearing.

hhbalmer, If the registry fix works for you to get the drive back in Explorer, then the old ccm registry fix should get it back for Wavelab too. You can check what’s in UpperFilters with just 10.0.40 Full installed, but I’m pretty sure it should be GEARAspiWDM, and I’m guessing that’s what you need to have in 10.0.50 too because that’s what I have and 10.0.50 works here in Windows 10 1909…

You might just want to wait for the Wavelab 10.0.60 update which probably should work, but if you really want to get it working in 10.0.50 and you’ve already tried the Steinberg registry fix and it got you the drive in Explorer, and you’re comfortable editing the registry, then you could try to do the registry fix again, but this time, after removing ASAPI from UpperFilters, add GEARAspiWDM there, and then press Enter to move to the next line, then click OK. Then I think the drive “should” work for both Explorer and Wavelab.

But I would back up the registry first, and be sure you would be comfortable restoring the registry, or at least that key, in case it doesn’t work or breaks something else. In other words, as they say in the Steinberg document “at your own risk”, and maybe better to wait for 10.0.60 if you don’t really need to do this.

Also, just wondered, do you have a LowerFilters entry? I don’t.

I mean I hope it’s fixed in 10.0.60. Has Steinberg said it would be fixed? I don’t see that stated here or in the previous thread. And since it’s only happening to some of you and not to most of us. And only on Windows… Maybe a support ticket would help to confirm.

it was there in 10.0.3, not in 10.0.4 and now again back in 10.0.5 (strangely the page from steinberg mentions 10.0.4…), it seems alternating. yes i am windows. i have an internal cd/dvd burner (don’t know manufacturer, self-built system, but a burner is a burner…). windows 10 pro 20H2 by the way, isn’t that important.

a support ticket? because this forum is closely watched by the main developer (as spectralayers forum), it is better calling genie… @PG1

The CD driver is the same one since many years. Hence no change between 10.0.30/40/50
If you see some changes, this must be something that have changed on your system.
You might try to reinstall the CD drive alone
http://www.gearsoftware.com/downloads.php?dir=updates/windows/drivers/&file=Driver_Installer_x64_WinXP.exe

Thank you for the answer. Unfortunately the problem is the same. I just did the following things:

  1. Uninstall Wavelab
  2. Install Wavelab 10.0.40 with full installer
  3. Check the registry: UpperFilters is GEARAspiWDM, no LowerFilters.
  4. Check CD drive: Available in Explorer and in Wavelab
  5. Install Wavelab 10.0.50 with update installer (there is no full installer)
  6. CD drive has disappeared from Explorer and WL.
  7. Check registry: UpperFilters is GEARAspiWDM. I reenter it (for if it’s corrupted) and restart the computer. No change.
  8. I delete UpperFilters and restart.
  9. CD drive available in Explorer, CD Architect etc., but not in Wavelab.

So it seems to be impossible to use the CD drive in WL 10.0.50 in my setup.

Windows: 20H2
Processor: AMD 1800x
CD drive: ASUS

But did you install the gearsoftware driver installer (see PG’s post above your’s)?