Distance between chord symbol and altered bass notes in diagonal arrangement - too big

Hi
I use the font PetaChords for my jazz sheets. It’s a very nice font and I find it highly readable. But there is a minor problem with the default distance between the chord symbol and the altered bass when it is placed using diagonal arrangement, which I kind of like - I think!
Take a look at this and tell me if you know how to make the distance between the Dbmajor7 and the Ab smaller. And it’s not a solution to do it in engrave mode, because I then will have to do it for ALL chords!!
Skærmbillede 2023-06-16 kl. 15.11.52

This recently came up on the Dorico FB group and I couldn’t figure out a global solution there either. Do you have the Notation Express templates? Do they automatically fix it with an included doricolib file? It looks good in their preview pic, although they may have manually adjusted that in Engrave:
slash

I think the kerning pairs are set in the chordSymbolComponentKerningPairs.xml file. Obviously there’s no setting for PetaChords. I’m not sure if it’s possible to create entries for the PetaChord comp.bass.slashdiagonal IDs with a doricolib file or not, but that’s the only idea I have, as there’s no global setting to adjust this poor spacing. It’s possible this spacing is simply hardwired in and there’s just no way to adjust it globally at all. Obviously you can create overrides in Project Default Appearances, but that’s hours and hours of work just to account for the most common possibilities.

I know @pianoleo was involved in creating these templates, so perhaps he’ll know if the Am/C symbol from the image above was manually edited or if they figured a way to fix the spacing globally for PetaChords.

I’m afraid the preview pic is actually taken from the Sibelius version of the Scoring Express templates, and in the Dorico version we opted to use ordinary linear positioning for altered bass notes, like so:

image

…on account of the fact that Dorico doesn’t give good control over this spacing.

Sorry!

1 Like

I played around with this a bit more, but gave up. If there’s an editable setting that controls this, I haven’t figured out how to access it. It seems like there just needs to be Engraving Options settings to control this.

deleted as I’m trying something different …