Dorico - One of my projects crashes the audio engine


Something very odd is happening to one of my projects specifically. It seems to be a 50/50 chance of it happening, but essentially:

When I open this project, sometimes the audio simply does not start. The audio engine button at the top starts as turned off. I can see NotePerformer starting, and I can switch playback templates - but no sound. Turning the audio engine on does nothing or freezes Dorico. After closing the project, instead of going back to the Hub window, it closes to desktop, and Dorico will now no longer open (even killing the VSTAudioEngine process doesn’t help), and a restart is necessary.

Sometimes, I can open another project (which will load without any problems), and then open this one, and it will load properly. However, it’s just as common for this project to crash Dorico entirely and leave me no choice but to force close and restart.

I haven’t encountered any other errors or odd things; this project in particular just seems to not want to work about half of the time. When it does work, it loads slower than the others, and the audio engine button is sometimes a bit odd in that I occasionally need to disable it only to have Dorico re-enable it again.

Any help with this would be greatly appreciated.

Link to the project as a zipped Dorico project file: Bloodstained - Lost - Google Drive

I’m on the latest version of Dorico 4 (
Windows 11 Pro (latest build at time of writing), Dorico is installed on an SSD drive, 128 RAM, AMD Ryzen 7 5800X 8-core processor. External audio interface is a Focusrite Scarlett 4i4.

Thank you for your time!

Can you do Help > Create Diagnostic Report and share the resulting zip file? That will allow us to see any relevant crash logs.

Have you tried re-applying the NotePerformer playback template to your project? That should clean things up and fix up any spurious audio engine or plug-in data in the project that could be contributing to the problem.

OK! “Luckily”, when I booted up the project just now, this problem happened again. This is the diagnostics file:

Re-applying the NotePerformer playback template seems to do nothing at all; interestingly, after doing it a few times to test it out, now even the option to bring up the Playback Template dialog is greyed out in the menu:


(playback template grayed out.png - Google Drive if the above upload doesn’t work)

… and turning off the audio engine at this point crashed Dorico to the point of having to force close it (and I’ll need to restart my computer until it will work again, I think).

Update: Starting up Dorico now makes it get stuck on “Wait for audio engine initialisation”.

Hi @Fredrik_Hathen ,

first of all thanks for the diagnostics. Contained are 3 crash dumps of the audio engine. I loaded them into the debugger and they clearly show Kontakt as the culprit for the crashing. So from our side there is nothing we can do about it. You’ll need to get in contact with Native Instruments and file a bug report with them, and even best if you provide them the 3 crash dumps from the diagnostics (they are in the subfolder Chrashes).

If Dorico does not start up because it is waiting for the audio engine, then simply use the Task Manager and kill the VSTAudioEngine process. After that Dorico shall start up just fine again.

Actually no, I have to be more precise. The audio engine is not crashing, but Kontakt is waiting indefinitely for some event that does not arrive and therefore blocks the audio engine’s main thread. But the effect is the same, nothing is working any more.

Thank you for your response, Ulf!

This is very strange. No instance of Kontakt whatsoever is loaded in this project. Only NotePerformer. Would there be a way to stop Kontakt from loading in Dorico, as an interim bugfix? Native Instruments are famously slow at responding and this is causing quite a bit of trouble. It also never happens in any of my other projects - only this one, despite it not containing any instance of Kontakt.

I understand if there’s nothing else you can do, but it’s so bizarre that it’s happening and it would be great if there was some sort of “hotfix” that could solve this while I contact NI.

Added thing I have noticed after a lot of testing: A way to get around this for now - which works 100% of the time, as far as I can tell - is to open another project first, and then (while that project is still open) open this “bugged” project. This causes the audio to load.

I wanted you to know this, in case there’s something in there that would be useful to you; maybe there’s some oddity in the audio engine that you could look into for a future update?

Regardless, I really appreciate your help thus far. One of the things I love about Dorico is how easy it is to get help.

EDIT: I have discovered that the above solution only works while that first project (not the bugged one) is open; if I close it, then the audio dies in my “bugged” project and does not come back on. If I then open another project, the audio engine comes back on for both of them - the “bugged” one as well.

Is this something that could be looked into at all?

EDIT 2 - final one, I swear: I exported this project as MusicXML, imported it to a new file, and saved it. This new file now starts without any problems at all. It seems the problem is now… solved? I still wonder if this is anything that you may want to look into, RE: how your audio engine loads things. I apologize for this long thread but I genuinely want to try and help others, in case this happens to them.

I lied - final final edit. The only thing I can think of that I did with this project and not the others was experimenting a lot with trying to put an aleatoric box into Dorico along with an arrow. Is it possible that broke something?

Anyway, I am going to actually stop now. I hope this helps in some way. I have also contacted NI, but I don’t hold out much hope that they will respond. Thank you for your time!

Hi @Fredrik_Hathen, do you still have that initial project which gave you the headache? I’d like to have a look at that one. If you don’t want to post it here publicly, could you please send it via private message? Thanks

It’s still up on the same Drive link listed above: Bloodstained - Lost - Google Drive

It contains, as you’ll see, a sort of hacked-together aleatoric box with an arrow in the piano. That’s about the one thing it has compared to the other projects that work flawlessly, so hopefully that’ll lead to something!

Ah okay, now I see, actually the audio engine data of the project says there is still a Kontakt instance and so it also gets created when loading the project. But Dorico on the other hand thinks it is not there any more and thus does not show it. Then Kontakt gets in trouble and everything gets stuck.
Well, now with your XML export and reimport you got rid of that “hidden” Kontakt instance. Let’s keep fingers crossed it stays now that way.
Actually, it was just with the 4.3.11 update that we put a fix into Dorico so that this does not happen any more in first place, but let us know should you get into the same situation again. Then we know we’d have further work to do…

1 Like

Greetings, I have the exact same audio initialisation message in Dorico (just reinstalled 4.3.xx today) when trying to start the software, same when starting from a project file. Unable to open any project. Win 10 (up to date), 128GB ram, all m.2 drives, Focusrite Scarlett 8. All have worked great with Dorico. Also, other DAW’s and instruments all work no problem. Since last starting Dorico I did update to Kontakt 7, if suspect… I don’t see any VST for Kontakt or NI in Task Manager processes or services. Is this a known issue? Any suggestions? Thanks in advance. I’m stuck.

Hi @RobG7, but you can still start Dorico up until the hub window, right? If so, please choose from the menu Help > Create Diagnostics Report and post the corresponding zip file here. Thanks

Thanks Ulf, but no . Dorico hangs on the start up splash screen (with DORICO logo) whether I start the app or try to start with a project file. It shows the in the lower left corner, multiple processes flashing through and then hangs at “wait for audio initilisation”. All other DAW and stand alone instruments are working fine with my focusrite drivers. I.m perplexed. Should I uninstall and try a fresh install?

Reinstalling is unlikely to make any difference, I’m afraid. Can you try running the script linked to in this post:

This should grab all of the relevant logs and put them in a zip file on your desktop, which you can then attach to a reply here.

Thanks Daniel. I ran the script and it created a 20mb file, which will not upload, pop up message says max size is 4mb. Here is a link to the file in Google Docs if you are able to use that?

Otherwise I await your advice to share another way.

FYI, Dorico 3.5 hung up at the splash screen as well with “audio engine:waiting for connection” message. In case its relevant, in the past 2 weeks (like many at this time of year) I added the following: 1. Kontakt 7 upgrade from 6.7 with Cremona string quartet, 2. Izotope Ozone V10 upgrade from 9 with bundle incl. Neoverb, 3. 3 Ample Sound guitars instruments (had two previously). If that helps. Thanks again.

Hi @RobG7 , thanks for the data. At first sight it looks like some VST3 plug-in is making . Could you please try following:
Rename the folder C:\Program Files\Common Files\VST3 to something else, e.g. _VST3 and start Dorico again. Does it then run well?
If so, stop it and create a new VST3 folder and move one plug-in over from the _VST3 folder. Then start up again and see how it goes. Continue with moving plug-ins one by one and starting up. When Dorico fails to run up properly, then the last moved plug-in is the culprit.

Ulf, that was it! Thank you!!! I decided to sort by date, as I assumed it was a recent one. Out of the upgrades I shared with you I forgot one. I installed an update of the new Virharmonic Bohemian Cello just a week ago. That was the first VST3 listed (by date). I removed it and poof…Dorico started up and is working again. Same reliability as before. Side note: I had both the Bohemian Violin and Cello instruments when they only ran in the UVI player. Beautiful instruments but very resource hungry and finicky for MIDI control. They recently released their own player, and that was the culprit. Thanks again for your expertise and direction!!! Cheers! Rob

1 Like

Is this an area where someone from the Dorico dev team could have a conversation with the Cubase dev team about handling VST plugins validation, sub-sets, missing, black-listing, etc? There’s a whole interface for it in Cubase.