Dorico 4 does not start on Windows 10

Hello I dont know if it is ok to post this here, but I am having the same issue in Windows 10.
I installed an upgrade form Dorico pro 3.5 to Dorico pro 4 and it wont start, inidicating it is waiting for audio engine…
I am using NotePerformer and Dorico 3.5 is still working.
geert.zip (1.8 MB)

Welcome to the forum, Geert. It looks to my semi-trained eye as if the audio engine cannot start: can you please check this other thread:

The symptoms may not be exactly the same, but the cause may be: please take a look and see if any of the shared components mentioned in that thread could be implicated on your system.

Hello
I moved the shared components, but issue still persists.
Also, I can not move the initial splash screen and don’t get the hub window visible.
Note that if I try to start HaLion Sonic SE, I get this message
imagen
meaning that the entrypoint SetThreadDpiHostingBehavior cannot be found in HALionSonic SE.exe (dont know if this can be related) .

That is unrelated and only pertinent for the HSSE standalone app but that is not necessary for Dorico.
Could you please zip up the folder C:/Users/your-name/AppData/Roaming/Steinberg and post here?
Also have a look in your Documents folder there should be the subfolder Steinberg/CrashDumps. Please also zip up that CrashDumps folder and also post here. Thanks

Geert_Roaming_Steinberg and Crashdumps.zip (2.5 MB)
Hello
I ommited some sub folders from roaming Steinberg folder because the resulting zip was to large for uploading.
Here is an image of the whole folder in case you need one of the ommited folders.
imagen
Thanks for taking the time.
Geert

Same problem here

Well, hopefully you realise that simply posting “Same problem here” won’t fix it :slight_smile:

Please provide the same kinds of information that Geert is providing, and we can try to make some suggestions.

I had the same problem when I first upgraded to Dorico 4. It hung while trying to access the audio engine. I solved it by running Dorico 3.5 first, closing it, and then running Dorico 4. It works now, without that procedure, but it still takes a long time to connect to the audio engine.

It’s to be expected that the first time you start up the new version it will take a little while to scan any plug-ins etc. you may have on your system, but after that it should be somewhat quicker.

@geert_vanhauwaert , thanks for the data. I’m currently not at a Win machine but will have a look at your crashdumps later today. I’ll be back… :wink:

Hello again @geert_vanhauwaert . I thought this will be easy, because I saw some crash dumps, but they are actually from the audio engine of D3.5 and not D4.
Now, looking at the logs of Dorico, they always say “launched audio engine” and thereafter break off. The funny thing is, the audio engine logs are empty, no, not empty, there are none, so that means the audio engine never even made an attempt to start up.
Let’s take this step by step from now on. Please go to
C:\Program Files\Steinberg\Dorico4\VSTAudioEngine
and double click VSTAudioEngine5.exe. Then a splashscreen should appear for a couple of seconds and go away, so that the process then runs in the background.
Then zip up the folder C:/Users/your-name/AppData/Roaming/Steinberg/Dorico 4 AudioEngine again and post here.
You then need to kill the VSTAudioEngine process in TaskManager.

One other thing sprang into my mind. I hope you don’t try to launch D4 while D3.5 is still open as that is not supported.

Hello
Sorry for the delay,
When I double click on VSTAudioEngine5.exe I get this message on screen:
imagen
This is similar to what I get when launching HalionSonic S.E. It tells that if can not find the entrypoint SetThreadDpiHostingBehavior in VSTAudioEngine5.exe.

Yesterday I lauched Dorico 4 and let it there to see if if showed the hub at some time, but it did not. Then I started Dorico 3.5 and its playback was very strange, until I realized that I forgot to kill Dorico 4. So I seems that Dorico 4 is usign resources in that state.

Hi @geert_vanhauwaert , what exact version of Windows are you running? Because that function SetThreadDpiHostingBehaviour is only supported from Windows 10, version 1803 onwards.

Hello
My windows 10 is version 1709
imagen

@geert_vanhauwaert , I’m sorry to say, but in that case you need to update your Windows in order to run Dorico 4.
Our website also states as system requirement:
64-bit Windows 10 Version 21H2 (or higher), 64-bit Windows 11 Version 21H2 (or higher)

Sorry, I must confess I didn’t read the 21H2 part of the requirement. I will try to upgrade asap.

Thank you for pointing this out.

1 Like

Some good news
I upgraded to Windows 10 pro version 20H2 (step previos to go to 21H2 and Dorico 4 is already working ok

1 Like

tried this and it worked. I ran 3.5, closed it then ran 4 and it opened. it. after a few times it stopped working. repeated the process and it now works and continues to work. initially it said "Host service2.simplitoc.com not found. works for now.