DspmixFX not working UR44C + Macbook Pro 13

I recently bought a brand new Steinberg UR 44C, I registered, installed and activated all the tools and software necessary to use it.
The first time I opened dspmixfx, the interface was not being recognized . I uninstalled and then installed everything again. Now I open dspmixfx and the interface is being recognized , but it won’t work in anyway. No signal coming in or coming out.
MacOSX does recognize the UR44C, which means I can still use it through iTunes, Spotify and ProTools, both inputs and outputs.
When I try to update the firmware, I always get an error message: “Update failed. Please check the connection and reboot this software, then try again.” according to the manual, that’s a sign it may be damaged.

I’ve read every topic thay relates to my problem, and the one that resembles the most to my case is this one, which concludes that the interface was indeed malfunctioning.

Can anyone think of something I may be doing wrong?

Is that an M1 Macbook? that essential troubleshooting info is needed at the very least.

Anyway check UR22C - M1 MBP Big Sur

This is the most important piece of info at the moment. In the linked thread, it is stated that there are currently no drivers that work with the M1 chip, this the device is not supported.
On my end, I was in contact directly with Steinberg because I was seeking a reimbursement on my purchase of cubase because it was unusable due to GUI glitches. Throughout our steps to resolve the issue, we tried everything and in the end, we discovered that cubase worked perfectly
when the UR44C was not plugged into the computer. The UR44C was glitching cubase out, along with all the other issues I had, which I mentioned in the post.
I was then in contact with my regional (Canada) Steinberg team and after numerous trials of uninstalling and installing drivers, the device was deemed faulty. I got it replaced on warranty and am now using my replacement UR44C with cubase with no issues.

Hopefully you get your situation figured out. Reach out to the support team. In my experience, they’ve been excellent to work with.

Hi! No… I have an Intel Macbook Pro 13, mid-2014, High Sierra (10.13).

How long did it take for them to replace your UR44C?? I’m kind of in a hurry because I’m supposed to start working in a project next week :S

Have you actually installed the Steinberg/Yamaha driver?

Yes, I installled it along with the other tools. “Yamaha Steinberg USB Driver V 2.0.5”

Are there permissions or security requirements you have to configure?

Can you launch the driver control panel?

Seeing you recently bought it new, if Yamaha / Steinberg deem it to be malfunctioning (DOA), it should be replaced instantly. Mine was replaced by the store that initially sold it to me. Initially they were going to send it away to Steinberg so they gave me a rental unit in the interim, but they replaced it 1 week later and I returned the rental unit.

  1. Forums here are great and helpful but get in touch with customer support. They are the experts and can help problem solve your issue. They will lead you through all the steps required to confirm whether your device is the culprit, or your computer.
  2. If you indeed got a lemon, they will tell you. At that point, the store you got it from should replace it on the spot (check their return / exchange policy), but especially if Steinberg says it’s a lemon, you should not have any issues exchanging.

I already gave Yamaha and Steinberg all security permissions needed, since it was highlighted in the manual. When I launch the driver control panel, it looks exactly like the image you sent to me.

Thanks Bison! Yes, I got in touch with the store that sold it to me (Yamaha Colombia), on friday, but the guy told me I would have to wait until tomorrow, since customer support doesn’t work on weekends and today is a holiday here in Colombia. I just wanted to know if I could figure things out with your help and maybe win a couple of days in the process. Now that I have your feedback, I can describe my problem better to customer support. Thanks to all! I’ll keep you posted.

1 Like

Have you tried it in different USB ports? I had a strange issue where after I unplugged it from the original USB port, it was never recognized on other ports. I know it sounds strange, but the more information you have, the easier it is to find the problem.

Hi! I tried connecting the UR44C to another USB port and nothing changed. Still no signal.

Yesterday I went to the Steinberg Dealer and they tested the interface in one of their iMacs, it turned out the interface was working perfectly, I even updated the Firmware in their office. So I came back home and looked for other Yamaha/Steinberg software on my MacBook. I deleted Yamaha USB-Midi driver, Yamaha Network-USB driver, CL editor and QL editor, along with all folders and files located in Library folders and subfolders, except for elicenser. I was very meticulous at this task. I restarted my MacBook and reinstalled URC Tools. dpsmixFX now recognizes my interface and works perfectly.

I hope the problem doesn’t come back when I reinstall Yamaha MIDI driver (to use a DGX620 keyboard) and QL/CL editors, since I really need that software to work in the longterm. Anyway, thanks to all for you attention!