External instruments audio routing

I have set up my mini brute as an external instrument. If I add a new instrument track it comes up fine. The instrument track has its own audio channel but the audio from the mini brute won’t come through it. I know the midi side is working fine.

Is this is how it is supposed to work or do I still have to create another audio track for the minibrute and use the existing channel just for midi? It would be much less confisung if it was all on one channel like a vst instrument

thanks in advance

it’s in the manual that you can use external instrument by right clicking while hovering over the tracks and adding an instrument track which is midi and audio together in one track

Hi thanks

yes I have done that but there is no audio coming into the mixer despite the correct input being assigned in VST connections

is the monitor button on on your track ?

yes , really odd

Have you set up its MIDI port: Devices/MIDI Device Manager? Because if this is not set up correctly, even thought the instruments shows up in the External Plug-ins list, it will not receive MIDI control unless you have MIDI set to “local” on your instrument.

This is just a suggestion because I’ve had External plug-ins loose their MIDI port. So even if you have already set this up it’s worth checking.

Good luck.

yes i have thanks for the response. if i load up the channel through the F11 VST instruments panel all the midi works fine, but the audio channel is then separate.

also if i right click the channel strip to add the VST instrument it comes up correctly with an audio fader, but no sound comes out. The instruments I am trying to use are mono and when I save & close cubase, then re-open it the software says audio will be silent because it was expecting a stereo signal. confused as it doesn’t say this error on loading

whats your system , whats your audio interface ?

sounds like you haven’t enabled the correct ASIO driver in your device setup

I’m running 64 bit windows & Cubase 7.04

My audio interface is a focusrite Pro 40

Have you the latest focusrite asio installed and selected ?
Have you got the record enabled on the track or the monitor button ?
Have shut down your computer after changing any settings and rebooted ?

Is it set up as mono external instrument…?

people were trying to help you here why haven’t you replied ?

https://www.steinberg.net/forum/viewtopic.php?f=81&t=39994

Sorry had to collect daughter, I do really appreciate the help

I have the latest ASIO drivers & firmware for the saffire

record enabled on the track and the monitor button on

just tried a reboot and still the same

and the external instrument is set up as mono

odd thing is if I right click track & add instrument the midi channels all send on channel 1 despite me setting up the midi device on track 2

You can not use mono instruments with instrument tracks. Read your manual.
Use the instrument rack, or set the external FX up as stereo.

You´re welcome…

You know what? Nothing p!sses me off more than when you go to the trouble of offering people help and advice only to see them disappear without trace. How busy must they be to take a few seconds to simply post the magic word?

http://www.steinberg.net/forum/viewtopic.php?f=175&t=40116

wow some of you guys are really touchy, I’ve said thanks all along but have just got back from a weeks holiday with limited internet access. So again many thanks for your help.

I have managed to get this working sort of, by using the mono to stereo plugin steinberg provide.

However when i create midi devices for my synths everything works fine until I restart cubase and then all the midi devices have disappeared. I also note that if I select to install a midi device there are no pre-set panels which I have read there are supposed to be.