General Automation Bug

Hello there,

I have serious issues with automation since using Cubase 10. I don’t remember having it on Cubase 9.5 though.
I have a lot of automated EQ or Reverb on a group track, that gets activated only on
specific parts.

It happens that the automation of the EQ or the reverb is on “bypass” or “Send disabled” and visually it seems to be okay,
but when I listen to the track the EQ/Reverb is active. On reverbs for example I see also an output on the fx track.
I often copy/paste automation points, but also write a lot of them by hand. I hardly ever use the pencil tool, only the normal mouse cursor.

Only solution is to rewrite the automation over the area where it seems to be buggy (this time I use the pencil tool).
It seems to appear only on automations with 2 states (ON/OFF), it appears not to be plugin dependent, since different plugins are affected, but also cubase internal busses like SENDs where no plugin is involved.
It does happen like 2-3 times per project.

Nevertheless this main feature of a DAW should not be buggy at all.
This is a big problem, you simply can’t trust what you see, and things like this are destroying mixes and workflow. Especially if you have a lot of tracks with a lot of automation going on. Not to mention the time you loose because of this issue.

I can’t confirm there’s a bug, only to offer a workaround. I have had issues with automating the state of bypass in older versions of cubase - resulted in glitches - so I never do it now (and to be fair, the very nature of bypass is bound to result in discontinuities in the waveform ie: clicks etc). With eq, I automate the gain to 0db where I want it to “bypass”. With reverb, I’d just pull the volume of the fx buss down or the send to the fx down. Are you using the reverb as an insert on a group track? If so, I’d automate the mix amount, rather than bypass.

Okay yes I see where this could work. But if you have an auomated EQ with more than one EQ point and want to bypass the entire EQ using your method, it gets really messy.
Lets say you have an automated EQ with 4 EQ points… you then need 4 gain automation lanes underneath the track/group and automate the gain back to 0db. Thats horrible… Or how do you deal with that?

If I need to do big moves like that, I’ll send the channel to 2 groups, eq on 1 group, none on the other, automate volume up and down to switch between eq and non-eq states (with quick ramps, not hard jumps, to avoid discontinuities) :slight_smile:

Thanks for the suggestion, but that’s not quite a fast and easy workaround, I am glad it works for you though.
This is as simple as automation can be, ON/OFF.
Isn’t there anybody else having this issue or didn’t they notice yet? Cannot really believe it happens to me only.

I just tested automation of toggling bypass on plugins and it worked. Is the issue 100% reproducible on your system? Post a step by step procedure of how you get it to happen, and I’ll see if I can reproduce it here.

Unfortunately it is not 100% reproducible…
It happens from time to time, that makes it even worse.

Today i had the issue again and made some screenshots:

As you see on Screenshot 1 and 2, the plugin is doing what the automation lane is showing, everything is normal.

But on this last screenshot you see the parameter shows “bypassed” but the automation lane is showing the opposite.

Is bypass still whacked if you restart cubase?

Fabfilter only or other plugins too?

Group channel or other channels too?

Can you make a copy of the song with all the audio parts removed and upload the cpr so other users can see if they get the issue on their systems?

Is bypass still whacked if you restart cubase?
I saved the project where the bug was happening and reopened it and the issue was gone somehow. I will try this again, the next time it is happening. That does not make it better though…
But why the question? Have there been other Bugs like this before which disappeared by closing/reopening Cubase?

Fabfilter only or other plugins too?
As already stated it is not only fabfilter, it also happened with 3-4 other plugins. I mostly do this with EQ or Reverb.

Group channel or other channels too?
I only use automation of this kind on group channels, so I cannot say for sure if it is only happening there. But as the automation procedure is the same with audio channels too, its happening most problably on other channels too.

Can you make a copy of the song with all the audio parts removed and upload the cpr so other users can see if they get the issue on their systems?
Yes, if I manage to capture the bug in a cpr file after reopening it I will upload it!

Okay, had the issue again… if reopen the project, the bug is gone.
It only happens in the currently opened project.
By reopening the project Cubase seems to re-read/rebuild the automation correctly.
So I unfortunately cannot provide you any file…
Maybe thats why nobody seemed to notice this bug.

I have a vague memory of something similar happening to me years ago with an older version of cubase. And in later versions, occasionally if I open a project with some plugins bypassed, then enable the plugins, the plugins won’t work and/or latency compensation is wrong. The only way to fix it is to save the project with the plugins activated, then re-open it.

Oh damn, now as you say it, something similar happened to me short time ago.I reopened a 9.5 project to remaster it and somehow only the floor tom track was sounding really bad. Had to save the track preset and reload it and everything was fine. Everything else I tried did not work…
Anyway things like these are really annoying, as you always have to keep them in mind.
Such basic things like bypassing plugins and read out automation lanes…

Hi, I agree the bug exist for C10. I’ve had a lot of problems with it and everytime I’m forced to use two state automation I double check if it works and sometimes it doesn’t.

Lately I found next bug in C10 with automation of group tracks - sometimes you can’t copy and paste the automation. Right now I’m in the project I’ve had a template for the whole album and now in every song of this album I can’t copy and paste the automation (but only on group tracks).

Anybybody had this before?

I have the exactly same issue, and it is intermitent. Sometimes Cubase does not follow my automation “paint”. And I do the same bypassing and not bypassing the plugin. I also have issues trying to set the value typing its value in the status above. I type the value and the value is not set.

Hello, it happens to me that I perform an automation and sometimes cubase does not read it, especially the channel filters, but when opening the channel there if you read it, it is very tedious to have to be opening the channels, help please.
R is activated, everything in order and the problem continues.

For some time I have this issue with automation. It persists in 10.5.20 (Elements)

The issue is that autiomation is not only choppy but it is also unstable:

https://www.youtube.com/watch?v=H3l1yZmHxt0


I’m not sure if I should create new thread for this problem?

This sounds remarkably similar to a problem I’m starting to have. I notice the same behaviour but when automating the ‘mute’ function on the track. No plugins involved, just the simple ‘on/off’ track mute automation lane (in this case on a group track). And, like you, I can’t seem to recreate it in a reliable way yet, but it’s happening regularly. Cubase seems to ignore some of the instructions but not others, and each playthrough it’ll choose different ones to ignore. Reloading the project solves the problem, so this sounds more and more like a bug to me. It is worrying, I use lots of automation in a mix and need to know it’s reliable.
Details of my problem can be found here if needed:
https://www.steinberg.net/forums/viewtopic.php?f=286&t=192709

I have managed to recreate our problem using a very simple test. Please, Tj99 and anyone else with this issue, read my post and try it out for yourself. Hopefully if we get multiple confirmations either we can solve it or Steinberg will see that there is indeed a bug. Thanks!
https://www.steinberg.net/forums/viewtopic.php?f=286&t=192767