Generic low latency asio driver issue

I have switched from my 7 years old laptop to my new one, having Win10, Cubase 11 Pro, I have noticed that when I set the generic low latency asio driver as my audio and midi driver, playing the midi keyboard is a big issue with so significant latency that i am not able to play. Normally when I am in my mini studio and connected to Steinberg UR816C , the yamaha asio driver works just fine for midi .
so recording and playing midi in this setup is without any problem, Once I am out of my studio and Steinberg Audio and midi interface is not connected, I am using generic low latency asio driver. for such things like mixing, editing tracks it is just ok, but recently I decided to just connect midi keyboard and record some stuff in. With this driver it is impossible. When I change driver from Generic Low Latency to asio4all, the problem disappears and everything works fine. Isn’t it a big failure, that cubase own solution ( genericLow latency asio driver) is not able to handle midi correctly the way third party drivers do ??? And to add one more question , one my new laptop I have generic Low Latency ASIO driver ver -x64, which seems to be the latest one, but on my old laptop i have ver so older version has higher number ???

interesting update: I just took asio files from my old laptop and copied them to my new one, now I can run cubase using the same asio version driver, ver My expectation was big but nothing has changed, the issue still here, midi latency making the driver useless for my purpose. Then I fiddled some asio driver settings and It happened to get rid of the midi latency when i uncheck tho box : Allow ASIO application to take exclusive control … ok but the project sample rate has changed…

one even more interesting update: I have project where unchecking the box Allow “ASIO application to take exclusive control …” is solving midi latency issue with Generic low latency asio driver, but i have another cubase project when this adjutment doesnt wokt at all, and guess what !!! in this project even asio4all driver is failing too, latency in midi so high, that it is impossible to play anything in time. AM I MISSING ANYTHING?? Is the behaviour of ASIO driver project dependent in any magic way ???

The audio driver has nothing to do with MIDI. What you hear is most probably Audio latency, in which case you should reduce the buffer size.

ok audio driver has nothing to do with MIDI, so explain why my MIDI works with one audio driver but not with other, it probably has something to do with it. I just recorded few notes in the project, where the issue is present and can clearly see these notes are slightly moved out of timing, I also heard them out of timing while recording, and the same I can hear during playback. Then I quantized them and they are sound in time now, so if it is a buffer problem. why the note played in time from the track perfectly sits on the measure and the same note played more or less in time, sound later and is also recored later on the track ?

do you konw any trick how set the buffer to even smaller numbers then I have right now?

You shouldn’t be using the Generic Low Latency ASIO Driver. It’s an obsolete driver that hasn’t been updated for ages and it will cause you more trouble than anything else.
As you can see there’s only 3 options for the buffer size : small, middle and large. And not to mention that this generic driver so old that it isn’t even multi-client compatible.
Please use ASIO4ALL instead, you’ll be able to set the buffer size precisely.

Also check the following guides :

As for the MIDI issue, please observe the ASIO Latency Compensation Active by Default setting in Preferences → Record → MIDI :

Determines the initial state of the ASIO Latency Compensation button in the track list for MIDI or instrument tracks.

If you record live on a VST instrument, you usually compensate the latency of your audio card by playing too early. In consequence, the timestamps are recorded too early. By activating this option, all recorded events are moved by the current latency, and playback sounds like during the recording situation.

Looks like you have it enabled, and you are trying to input the notes on the beats without playing early, doing so will counteract the effect of the option and cause the notes to be recorded too late.
Try disabling it.

Don’t forget the check the Latency Compensation state on the tracks, as toggling the one in Preferences won’t toggle the existing tracks automatically, this is only for when you add new tracks.