Halion Sonic 7 : Presets panel goes blank

I own Halion 6 full and downloaded Halion Sonic 7 just to try it because it’s M1 native unlike Halion 6 full. I have not bought Halion full 7 upgrade.
I probably won’t because it seems unusable/unstable.

The worst bug is that the presets window randomly goes permanently blank and all preset browse and searching is dead until you reload the plugin.

Anyone else seeing this?

Hi @wpostma,

while hoping that I understand you correctly: with HALion Sonic 7 and during its first install, there should also be an additional installation of an updated version of MediaBay.

Are you having these strange effects with HALion Sonic 7 in standalone mode, or within Cubase?

Perhaps you can also check inside Cubase if your MediaBay has all licensed content (- including that of HALion 6 -) found / visible / marked as active. Even in my Windows context, the HALion 7 (- full and Sonic, standalone and within Cubase -) VST instrument sometimes re-reads (refreshes) all “known” MediaBay content by itself, which can take a second or two. But then I can always access all my licensed *.vstsound content. One more thing is the included filtering (- tag buttons and manually -). Once one chooses any manual search filters (- or tags -), HALion’s internal MediaBay access will represent and use that filtering as any other database search function does:
so that, during a session, less content will be visible according to any choices made before. Once one removed the filters, all available content would become visible again.

It may not be visible at first sight, but there are two more functions in the HALion 7 (Sonic) MediaBay:
Reset Filter” and “Synchronize Filter Settings with Selected Slot”.
(please see screenshot)

Another thing: MediaBay can only find content that has been correctly registered, as it’s to be seen in Steinberg Library Manager. One should check this one too, whenever anything related to licensed MediaBay content seems to produce errors (or any unexpected content omissions).


It appears not to be:

  1. reset filter.
  2. synchronize filter settings with selected slot.
  3. a media registration issue

It appears to be a bug.

The bug is that even with everything reset, the content of the mediabay browser will be empty, but after a re-start of halion (delete plugin and create a new track and plugin instance) it will come back.

When I say “randomly goes permanently blank” I mean that even if the content comes back after a restart, it goes away again, and none of the “UI hacks and kludge” buttons that get added over the years are working to get it to come back.

If it’s not a bug then it’s the usual Halion gotcha; The problem with extremely powerful UIs, I think, is that there are too many different ways to do everything including filtering.

This morning as I tried to turn on the light in my bathroom, I thought my lightbulbs were burned out or my power was out but it was that I have both a power on and a dimmer switch and the dimmer was set all the way dim.

In halion, there is not just one switch, and one dimmer slider, but rather, ten switches and twenty sliders, and you have to set them all correctly to use the program.

And then, there’s bugs on top of that. Perhaps the media bay will get a further rethink in halion 8 or 9, and we’ll get a simple way to browse content and to view all content with one button that is guaranteed to clear all filtering.

1 Like

I have same.

1 Like

I have the same problem as well and we’re over what, 6 months later? you’d think this would have been addressed.

1 Like

I still cant find a way to fix this. I reinstalled everything. Deleted preferences, nothing works. I would say other Cubase issues looks small now :). Working on it.

1 Like

Still happens here and I’ve given up on Halion Sonic 7. I tried the Halion 7 full demo and don’t see the issue there.

(I bought halion 7 full and now I see this issue!)

Please try if renaming the following folders will fix the issue:

/Users/Username/Library/Preferences/Steinberg MediaBay Server

/Users/Username/Library/Preferences/Steinberg MediaLib

Add an “x” at the beginning of the folder’s name to hide them. Should look like this:

/Users/Username/Library/Preferences/xSteinberg MediaBay Server

/Users/Username/Library/Preferences/xSteinberg MediaLib

If you can’t fix the issue by renaming the folders, please submit a support request ticket.


1 Like

One thing I forgot to mention is to check, if there are content-updates available in the Steinberg Download Assistant.


There was update in the Steinberg Download Assistant. But today i opened Cubase and same again - mediabay is BLACK empty space :grinning: :smiley: :smile:

Seriously, what is this? You’ve gotta be kidding me right?

Everything was blank for me as shown in the image from the latest post. Then I did some updates from the Download Manager, and now I am least getting a few things to show up (would post an image but new users can only embed one image, getting the following: All / Flux / FM Lab / Sonic Selection / Tales / Trip)

The instrument I’ve been using in this project is “Melodrama” in Studio Strings. If I use the Browser I can get there and load it, and it plays:

I’ve checked that all relevant paths are displayed under Studio / VST Plug-in Manager. Rescanned everything. Please somebody tell me how to fix this and get ALL of my instruments to show up again!

It’s the same for me with the empty preset panel. In the meantime, you can solve this by turning the “USER” button (next to the library icon) off and on again. Then suddenly all presets will be displayed again.

It turns out that there are still massive problems with the new license/media managing system. Far too many things are going on in the background. If you take a look at the Activation Manager log files, your jaw will drop seeing what is being logged and pinged every second…

Since the reorganization of base content I sometimes get similar issues.

In Dorico I need to install a special instrument table to get it working again.

I’d kept a copy of Sonic SE 3 on the system for the sake of hosts that cannot run VST3. It is almost unusable now. The General MIDI portion is seriously borked. Oh well, I plan to just remove it and use bidule to bridge Sonic or HALion 7 to those old hosts.

Aside from HSSE 3 or older being seriously broken if the ‘newest set of base content’ is installed…it seemed to help if I just launched a stand alone instance of HALion and Sonic, and just let them sit there for a while. As in, launch them, and go out to lunch.

Theory being…whatever database and such that Steinberg is using these days gets time to ‘build/rebuild’ in the background?

Seems to have helped in my case. I’m getting all the instruments I should get. I did notice that sometimes I need to clear/reset the filters! There is an option in Sonic and HALion that automatically syncs filters with the selected instrument slot, or something like that.

Give it a toggle and see if it helps.

The only way forward for me on this was to reinstall the media bay MANUALLY , something corrupted the fresh install from the DLA

Steinberg MediaBay | Steinberg

1 Like

Same just happens to me. Did no updates nothing. Suddenly all Absolute 6 Instruments are gone from the Halion 7 Mediabay. And yes, all there and all activated. And yes, I did a filter reset.
Waisting time now for fixing, instead of making music.
Unfortunately the link is not working. Clicking on it, opens the Steinberg main webpage. So no idea how to reinstall the media bay. A joke.

Not working. Will open an ticket

Ticket closed. After restart all back. Hope this will not repeat to often.