HALion sounds not loading


After using NotePerformer for a while I was trying to get combined sounds from HALion and NotePerformer. However, the HALion sounds refuse to load.

As a picture tells more than a thousand words, see the VST instrument editor window.

As you can see, different instances of HALion are created and when having the instrument windows open and playing the score I see flashing numbers (1 - 16), you probably know what I mean.

What I’ve tried (after searching the Dorico forum thoroughly):

  • Reinstalled “HALion Sonic SE 3.5.10 - Instrument” and “Sound Content for Dorico Pro 4” from the Steinberg Download Assistant
  • Removed any Dorico and/or HALion folders and files in ~/Library/Preferences (actually moved them to a temporary place). Especially “Dorico 4 AudioEngine” and “HALion Sonic SE”.
  • Used Play > Load Sounds For Unassigned Instruments
  • Switched Playback Templates multiple times. NotePerformer works fine, the HALion ones don’t.
  • Restarted Dorico a couple of times - in between above actions.

How could I get this working?

FYI: I’m on a Mac, don’t know if that matters.

Together with Dorico comes the Steinberg Library Manager app. If you open that, what sound libraries do get shown in there? Please provide a screenshot. Thanks

And in the HALion window where all the empty slots are, if you click on the little down arrow to load sounds manually, is there anything shown as choice?

Yes, the Load Program… window is filled as I expect.

And also the All Instrument Sets button shows tiles of the libraries I expect to be installed:

This is a screenshot of the Steinberg Library Manager:

Please create a string quartet project from template and then do from Dorico’s menu Help > Create Diagnostics Report and post the corresponding zip file here. Thanks

And you can load manually sound patches into HALion Sonic SE, right?

Here’s the diagnostics file with a new string quarter project file.
Dorico Diagnostics.zip (413.5 KB)
(I couldn’t help but notice there are several recent file lists containing references to yet to be announced projects…)

About your other question: yes, I could manually load patches as expected.

Thanks for the data.
Actually Dorico resp. the audio engine is doing everything as it should, but I saw in the logs that although Library Manager recognizes all your contents files, actually Dorico does not. It only sees
2023-01-11 21:25:28 : /Library/Application Support/Steinberg/Content/VST Sound/FCP_SMT_005_Reverence_ImpulseLibrary_04.vstsound
2023-01-11 21:25:28 : /Library/Application Support/Steinberg/Content/VST Sound/FCP_SMT_005_Reverence_ImpulseLibrary_03.vstsound
2023-01-11 21:25:28 : /Applications/Dorico 4.app/Contents/Applications/VSTAudioEngine5.app/Contents/VST Sound/FCP_SMT_012_Dorico.vstsound
2023-01-11 21:25:28 : /Library/Application Support/Steinberg/Content/VST Sound/FCP_SMT_005_Reverence_ImpulseLibrary_01.vstsound

But there shall be lots more. Let’s try and enforce a rescanning.
Please go to the Dorico Preferences dialog, choose the VST Plug-ins tab and scroll all the way down, there is a button Reset Audio Engine Data. Click that and restart Dorico.
How does it behave then when you open a new project from template?

Unfortunately, that didn’t make a difference. While I was in the Preferences > VST Plug-ins > Audio Engine Data section, I tried in a second attempt to use the Clear Audio Engine Cache button. That didn’t fix the issue either (of course restarting Dorico after clicking any of the buttons).

Also I tried in a new project from template as well as an existing project.

But I did notice the second time a strange icon I didn’t notice before:

Don’t know if it was there in before. Just reporting :slight_smile:

I think there are some vstsound files missing on your computer. Can you please run the attached shell script?
First unzip it, then do Spotlight Search for Terminal.app and launch that. Drag and drop the shell script into the Terminal window and then press the enter key to start it.
After a few seconds the file VAEDiagnosticsReport.zip should appear on your Desktop. Please post that here. Thanks
CreateVAEDiagnosticsReport.zip (467 Bytes)

Sure, here you have it.

VAEDiagnosticsReport.zip (3.9 KB)

Thanks for the data.
Well, the files that I suspected are there but at a different location than expected.

Please do the following: Go to the folder /Library/Application Support/Steinberg/Content/HALion/VST Sound
In that folder is a file called FCP_SMT_027_HSO_Presets_01.vstsound
Double click that one and see what message pops up. Something about already registered?
If something else, try to start Dorico again, and do like before, creating a project from template. Anything changed?

The …already registered… message appeared, shortly after in the top bar (next to the search field) a lot of filenames were displaying very quickly. Couldn’t read them, but I think I saw “.vstsound” at the end for most of them.

For completeness I tried the same with the template, but no difference.

I know that I had the same case years ago, probably at the time of Dorico 1 or 2 .
I need to go through the forum and search for the corresponding thread, will come back asap.
Feel free to also search the Dorico forum…

Hello again, I found this thread , and there the HSO preset file was in a completely unexpected place.
Well, with you it is a little bit same, but that preset file is not completely away in outer space and I think it should also work from where it is right now.
However, you could try moving FCP_SMT_027_HSO_Presets_01.vstsound from
/Library/Application Support/Steinberg/Content/HALion/VST Sound
/Library/Application Support/Steinberg/Content/VST Sound

Then do a double click again on that file and try again.
I also found another thread with the same issue, but that case solved itself by installing Dorico 3, so this won’t help you either.

Hi Ulf,

Based on that VST Audio Engine diagnostics report I went to look myself in the .vstsound directory. I reset all the permissions to default (including extended attributes). That seems to do the trick, at least for the majority of the libraries.

Unfortunately this didn’t help for Olympus Micro. Still no automatic patch loading. Is there maybe also some preset .vstsound file for the choir library?

Oh, excellent that you fixed it yourself.

And regarding the Olympus choir, if I’m correct, then those sounds will never be chosen by default, you always have to load them in by hand.
Or you create your own custom playback template with Olympus sounds. Maybe you can try it out…

Okay, good to know there’s no automatic patch loading mechanism. I’ll experiment soon with playback templates, endpoint configurations etc.

Thanks for your help, I appreciated it very much!

1 Like

There is an automatic patch loading mechanism. If you have HSSE+HSO (Pro) selected as your playback template, then Dorico will load patches automatically when you add players and instruments to your project. If that’s not working, then there is still something incorrectly configured with the sounds on your system.