Help - no sound!

Here is my next problem:

While the playback sound in Dorico did work the first day it does not work anymore now (with same test project).

Current symptoms:

• During playback only in the first Mixer channel strip I can see an activity (in this test project I have only one player). No activity in the Output strip and in the Reverb strip (as it was in the first day).

• Also in the first day the Halion window showed up. Now it isn’t visible anymore. How can I open it?

In the Device Setup, could you please check that the correct driver is loaded?

Next thing to try, go to Play Mode and choose Play > Apply Default Playback Template.
If that doesn’t do, could you start a new simple project and try what that does for you?

For the HALion window, go to Play Mode. On the right side you see the list of instruments. To the left of “HALion Sonic SE” there is a button with a strangely shaped ‘e’. Click on that (maybe twice) and the HALion window shall come to front.

Currently I use the the Generic ASIO driver:

But also the other drivers do not work.

When using this command:

Apply Default Playback Template

This made the Halion window show up. Also now when playing the score there is activity in the Mixer Output strip. Also when clicking on the Halion keyboard there is activity in the output. But I don’t hear anything. (Yes, other sound applications can be heard). Also, when looking at the Windows sound configuration mixer the Halion device is not shown.

When I create a new project the sound does work. Then I reload the first test project where the sound does not work.

I attach the not working project here:
test (154 KB)

I also have no sound in any file. Visually there is activity in the Halion Sonic window, and I can also get sound by loading it into my DAW, so it is working, but no sound comes from Dorico.

I don’t see where in the interface to Dorico or Halion I can check the device driver or audio prefs, anything like that.


How do I access the Device Driver, I can’t find it anywhere?

Please check in the Edit menu: Edit > Device Setup

Thank you. May I suggest that the Play menu would be a better place for that?

It’s also available in the Play menu. I think there also a link in the Preferences dialog.

In fact we moved it from the Play menu into the Edit menu and into the Preferences dialog, because it seemed important enough that it should be in the same place as other application-wide dialogs, like Preferences (which is also in the Edit menu on Windows).

I have the same problem with sound - it was working fine then suddenly nothing. No activity in the level meters in the mixer or the Halion Sonic SE window. Have selected the correct device in device setup, have done the Play > Apply Default Playback Template which reset Halion, but still no sound.

I’m not aware of having changed anything between the working and non-working versions.

On previous occasions when this has happened, I’ve had to create a completely new project (which then works) and then copy and paste the data across.

iMac i7
Apogee Quartet
MacOS Sierra

Could you please send me that non-sounding project file to u dot stoermer at steinberg dot de ?
Also, please zip up the folder /Users//Library/Preferences/VSTAudioEngine and also send me.
From the project data and log files I should be able to figure out what is wrong.

Rgonski sent me his project file and it turned out to be the known ‘missing port mapping’ issue.
I applied my little magic and it’s now working again for him.

Same problem, it was working fine, now no sound.
The green lights go up and down showing it is active, now no sound.
No sound in the HalionSE window either. (plz forgive the terms, I’m a composer, not a tech.)

A new project in a template works fine.

Could you post the fix? This has happened in multiple documents, so fixing one may not fix the next one.

What to do? Thx for the help!

You should be able to fix the problem yourself as follows:

  1. Quit Dorico.
  2. Find the affected project in the Finder or in Windows Explorer.
  3. Make a copy of the affected project so that you’re not tinkering with the original.
  4. Change the file extension of the project from .dorico to .zip. Confirm that you want to do this when the operating system asks you whether you’re sure.
  5. Unzip the zip archive: on Mac, you can simply double-click it; on Windows (which I don’t have access to right now) I believe you can right-click and choose to uncompress a compressed folder.
  6. Go into the folder that has been created: it will contain four items, one of which is a folder called supplementary_data. Go inside this folder.
  7. Delete the vstaudioengine folder from inside the supplementary_data folder.
  8. Now go back to the folder that contains four items (e.g. score.dtn, scorelibrary.dtn, etc.), but NOT the parent folder, i.e. the folder that contains these four items.
  9. Select these four items (again, NOT by selecting the folder that contains these four items), right-click and choose to archive (Mac) or compress (Windows) them.
  10. A new zip archive called something like will be created. Change the filename and the extension from .zip to .dorico.
  11. Now open up your fixed project in Dorico and you should find that it will reload all of the default sounds again for you.

Daniel forgot to mention that you need to go to the Play Mode and choose the menu item Play > Apply Default Playback Tempate. Only after that the default sounds will get loaded.

And probably needless to say, don’t forget to save your new project.

Thank you! Working now.

Is there a description somewhere in the existing documentation of the play back system? I have read this thread with interest, but also the realisation that there are a lot of terms in it whose meaning I have yet to learn.

No, I’m afraid as yet there is basically no formal documentation for Play mode. This is obviously a high priority for us to develop once our new writer has got her feet under the desk.

Speaking of which … Daniel, are you still looking for someone to help document the program / write a comprehensive manual? I saw an ad a while ago. Cheers.

No, we’re not looking any longer. As I have said in this thread and elsewhere, we have employed a new writer, but she will not be starting with us for another couple of weeks, and then she will need some time to become familiar both with Dorico and with the documentation toolchain before she can start publishing updates.