HiDPI support in C11

Hi,

great, the only reason to update I was looking for proper support of HiDPI.
Now what I see in C11 is somewhat blurry with screen estate not optimally used.

Am I missing something? Using an 34" 3840x1440 wide screen, font scaling applied in windows.
Or is there an option to revert to the “sizes” of C10.5?
E.g. Mixer channels in their smallest width are too large and somewhat blurry.

Can the GUI be scaled, or is it “fixed” in its size of symbols etc.?

Cheers

Hi,

Could you attach a screenshot, please?

Here are some Screenshots of C11 vs C10
In general, only the fonts are much bigger now as well as the borders, graphics etc.
This wastes a lot of screen estate, essentially there is much less information visible in C11 than C10.
Honestly, looks like on my old 1024px screen.

What you see here is 34" 3840x1440

Additionally, Mixer looks more blurry in C11.



adding one more file

Hi Martin, I think that something is off with C11 hdpi, with C10 I could use windows at 125% and cubase at 100% so I could use all the screen real state in my 4k tv, now, no matter what I do (hdipi on or off in cubase, high dpi override in cubase.exe) Cubase won´t use 100% scaling

Same for me, Windows at 125% and Cubase way too clunky as shown. C10.5 was fine.

I think before cubase used to display 100% when windows was in 125%
Now, windows and cubase always share the same scaling, (plugins show at 100%) which is too bad for me.

Something is totally screwed up now - The reason why I set 125% in windows is that fonts and graphics are scaled well in the complete system (browser, windows etc).
Only Cubase looks clunky as shite with a font so big my grandmother could read it from other side of the town.

Yes, I hope they can revert to C10 behaviour, or give us an option, but knowing how steinberg works, wouldn´t have much hopes about it.

I asked for one keycommand 3 years ago and still waiting

+1 The same here Plus Ghosting and double lines
https://www.steinberg.net/forums/viewtopic.php?f=307&t=202240&p=1065296#p1065296

How could we expect this would ever work? :frowning:

I’m also having issues, I randomly loose the cursor or playhead. It simply disappears. I can see it move in the top ruler but it’s invisible otherwise. Working on Windows 10 at 125% with a 4k monitor. Another issue is that the Windows taskbar is over and hiding Cubase’s transport controls.

Beta testers must have seen that if it only took us a day to have all these issues. I guess Steinberg has to deliver updates on schedule regardless of quality. I’d like to point out it’s the second time we pay in part for this particular feature.

Sad :frowning:(( And your last sentence - Exactly!!! … and I paid 4 times 9,5, 10, 10,5, 11 (and not even counting my crossgrade to nuendo, that I thought the flagship will be first to get the proper update to solve this pain (even on the same engine)) . Cubase/Nuendo The best DAW … with the worst and outdated basic UI feature. Weird.

btw… see my post
https://www.steinberg.net/forums/viewtopic.php?f=307&t=202240&p=1065296#p1065296

+1 count me in
Worked fine in C10 though.
2020-11-13_100944.jpg

https://youtu.be/VWzKWgL0hJ8

Hi,


I am sorry to hear you are encountering issues with the new iteration of HiDPI support with our software.

To me it appears that your former Cubase might have been “rounded down” to 100% in the past, making it then smaller than it should have been.
Today Cubase will be rendered according to the scaling factor that is set on Windows. That means that in most of the cases with HiDPI the Window might in fact appear larger than it used to be. It is per se the feature. If you were satisfied with the former size in 100% you can disable HiDPI Support in Preferences / General.

We could offer an option to be able to specifically allow Cubase to be rendered in another scaling factor than the one mentioned in Window’s display settings. I have to study the feasibility of this with the rest of the devs. :slight_smile:

We have also spotted several plugins not behaving properly with HiDPI and are already in touch with the main manufacturers. Some happen to be working on new releases working with HiDPI actively right now.
We recommend you report any GUI bug that occurs while running Cubase in HiDPI directly to the VST manufacturer.
We have also made a special option for the DPI-Unaware plugins that you can use to see whether this might solve some of the problems you encounter.
https://helpcenter.steinberg.de/hc/en-us/articles/360017509919-Cubase-11-Using-DPI-unaware-plug-ins

1 Like

I will be forced to leave your platform if you do not solve this simple problem.

at 110% the appearance of the cubase with the HIDPI option enabled is the same as at 100%.
But this is not very convenient, since I’m used to 125% in windows

Hi Armand, an option to use cubase to work at 100% regardless of the windows settings would be great
Thanks!

Hi Armand,
great you are taking this up.
Being able to choose Cubase 100% although windows is at 125% would indeed solve many users issue.
I understand that Cubase adapting to Windows scaling is somewhat desired “logically” - but somehow anyway Cubase at 100% has the more or less ideal size of GUI and fonts already. With 125% it is just way too large.
Also any other program I use does not have such large fonts and GUI when at 125%.

Please may I ask to provide this option “out of line”, i.e. rather quickly - that would be great.

Thanks for letting us know your are working on that, as you may be aware this is really an issue for many users, here in the Cubase forum as well as other places like facebook, forums et al from what I have seen.

Cheers