How do you delete a MISSING VSTi

I opened an old project that I want to remix in ATMOS. When I opened the project, It told me that my Prologue VSTi was missing. I assumed it’s no longer supported. No matter. When I tried to delete it from the list by highlighting it and selecting the NO VSTi OPTION, nothing happened. Since it’s missing, it’s not in the rack list to select and reassign to no VSTi.

So how do I delete this kind of VSTi?

Hi @Keyplayer,

is this Nuendo 12, and do you still have an USB eLicenser with the former version’s license?
If so, you could perhaps temporarily install the former version to a separate folder (or better: on a second PC) and open your project there, and then remove / replace that Prologue entry by something that would work in N12.

Besides, last year Steinberg did indeed remove a few things when stepping up from Cubase / Nuendo 11 to the current version(s) 12:

Can't find Prologue / Mystic / Spector in Cubase 12

Upgrade from N11 to N12 Instruments missing - #3 by David_W


1 Like

Thanks so much for your reply!

I opened the project in N11 and found the VSTi STILL MISSING even though it was listed as an option in the VSTi List. So, I could make a new Prologue, but I couldn’t delete the old one for the same reason in N12 (It wouldn’t show in the list to then select No VSTi)! :flushed:

So, I tried opening it in N10. Now Nuendo was giving me error messages about not having a built in renderer in addition to no Prolgue! :laughing:

It should not be this difficult to delete a VSTi!

1 Like

Copy the MIDI information to a new MIDI track. And then delete the entire instrument track?
After that: Create a new instrument track and copy the MIDI information into it?

1 Like

Thanks for the tip. I’ll try it. But I can’t see why that would work, since the MIDI track is bussed to an instantiated VSTi. You can swap out the part to any instrument created in the drop down menu. So, the two are separated.

What I don’t get is why I couldn’t delete it in N11. I could select it and make a new one. But the problematic version wouldn’t show up in the list to be deselected. This seems to be the case with several of these plugs.

Given this aggravation, there should be some kind of “nuclear option,” where you could just delete all of the VSTi’s and start over.:triumph:

Does Nuendo use the F11 shortcut, As with CB, for the Vsti Rack? If so, remove it from there.

1 Like

I often test different drum VSTi for a song. And then copy the MIDI track from e.g. originally toontrack to slate or hertz drums. Or use two String VSTi and copy the content from EastWest to Native Instruments.
You can copy / move the content / events of the MIDI track to any other instrument track. And then delete the old instrument track. I’ve been doing it for years.

1 Like

Thanks. I tried it and it didn’t work. As you can see from this screen shot, the Prologue is selected from the Project window, the VSTi Window and the little VSTi Window (F11). But instead of showing it as selected item in the dropdown menu, it shows NO VST INSTRUMENT.

If I scroll down to the SB Folder and try to force the selection on Prologue, it launches another one!

What happens when you select “No VST Instrument”?

Nothing. Absolutely nothing.

It looks like the link between the Rack Menu and the VSTi’s is somehow compromised. If I select an instrument in the Project Window, that instrument will light up in the VSTi Rack. But when I do the same for the Prologue and by extension the Halion Sonic SE version that has the Prologue, this doesn’t happen because it’s not there. What’s more disturbing is that no matter which instrument I select (working or not) The rack list still shows NO VST INSTRUMENT. So, it’s no longer talking to the actual rack.

When I selected the Prologue and hit the Expand Button to show what it was connected to, I got nothing (see screen shots below).

Now that’s super strange. In CB, with F11, you can remove the instrument by selecting “No VST Instrument”

At this stage, I’m also at a loss.


1 Like

It didn’t work. I copied a MIDI track and bussed it to the Prologue. Then I deleted the track. but the Prologue remained. Well the shell remained, since the instrument isn’t actually there.

Did I not do it correctly?

That’s the issue. No matter which window you use to access the No VSTi command, it has to first show the selected target. Then when you select no VSTi, it deletes whatever was previously selected on the list. But it opens already showing No VSTi. So when you select it, the window just closes.

1 Like

Seems like Nuendo’s bugging out. I could be wrong. Maybe, a re-install of Nuendo might fix it, or deleting preferences, or maybe starting up in safe mode. We may also be missing something simple here. This is weird to say the least.

Maybe, just maybe, uninstall Prologue, and see what happens, and then reinstall.

1 Like

You could try exporting the MIDI file and starting a new, clean Project with Prologue and the exported MIDI file. The current project could be corrupted.

1 Like

I just tried doing a reinstall of N11, since it has the prologue. It didn’t correct the issue. I got the same non-action when I opened the project.

How do I uninstall Prologue?

Should be listed in Windows Add/Remove Programs. Just locate it and uninstall.

Is this the “smoking gun?” I got this message when I tried to repair N11. Now I’m getting it for Halion.

1 Like

Could well be.

Tied up right now, I’ll check back later.