How to change MIDI Remote MIDI port after creation?

I’m working on a MIDI Remote but it seems that once the remote is created you cannot change the MIDI port assignment? This is true when done via the JS scripting API and via the manual remote creation.

This is not good because it assumes that the remote will always be connected to the same device and using the same MIDI ports. If you are using a device that has WiFi ports and then subsequently get a USB MIDI device the MIDI Remote must be completely destroyed.

2 Likes

I totally agree.
BTW, you can edit the created script. It’s in “MIDI Remote\Driver Scripts\Local\Vendor’s Name…”
If you open the .json file with a pad, you 'll find at the end of the script the name of the in and out port. It’s better to create a back-up first :slight_smile:

Yeah this is an issue. I’m creating a remote for a commercial product and editing a JS script is a large amount of friction for a user. You can supply the driver makeDetectionUnit function what port names it can expect to find but this again assumes that the developer knows the port names in advance which we may not if we want to support any generic MIDI connection.

It also seems that the MIDI remote takes exclusive control of this MIDI port. This is an issue if you want to pass through commands to the track. I could be wrong about this as I haven’t tested it much.

I see in one of the factory supplied scripts they didn’t actually supply a port name but do have a sysex response. This could be the solution? You’d need to have your MIDI controller listening for this sysex message. It’s not a bad solution if so.

Apparently help is on the way:

You are indeed wrong about this :grinning:

The MIDI Remote only takes over the midi messages that are mapped in the MIDI Remote. Any unmapped messages are still arriving at the various other Cubase routings (Tracks, Generic Remote, …)

1 Like

:partying_face: Sweet

1 Like

I am also wondering if there is any way to delete a midi remote. I cant seem to figure that out also.

New thread with it’s own subject line, so future users can find it easier?

Except when the Surface Editor is open, because it needs to receive all MIDI messages. Otherwise the rapid learn mode wouldn’t work. I see a lot users leave the Surface Editor open while using MIDI Remote (at least the YouTubers do that). Please always close the Surface Editor AND the Mapping Assistant when you’re done with your mappings.

Btw: The first maintenance will relax the rule of “consuming” MIDI messages. If a control element is bound to a MIDI message but NOT mapped to a Cubase function, the message will NOT be “consumed”. It will be routed through to tracks and other connected devices (like Chord Pads etc).

2 Likes

That will be even better! Thank you for making that change!

I downloaded the latest patch but still can’t see a way to change the MIDI port after remote creation without totally destroying the remote. Am I missing something?

Please unplug the device and wait until the surface GUI switches to “inactive mode”. Then you can remove that “inactive” device in the MIDI Remote manager. Then plug your device in again and use the BIG FAT PLUS button to activate your device using the MIDI ports of your choice.

I came here for the same question (although Nuendo 12). I did as you mentioned, and it worked initially. My situation is that I had setup an Xtouch One with the Xtouch One as the ports. Then decided I wanted to go through Bome Translator to get extra functions, so I turned off the Xtouch, then removed it, then added the same script again selecting the Bome ports instead. All was good. If I then start Nuendo without the Xtouch on, then turn on, again, great it uses the Bome ports.

However, if I have the Xtouch turned on when I open Nuendo, it immediately adds it back with the Xtouch ports as a new controller.

EDIT: I originally said nothing works, but it does still all work from Bome. But it would be nice to remove reference the Xtouch ports so that it doesn’t keep reappearing?

Thanks.

You can remove the entire Device Script that uses the XTouch ports. Just turn your XTouch on without the Bome-thing. When the XTouch device becomes an active MIDI Remote device, you can use the dropdown menu on the upper-roght of the device-view and choose the trash-button. That’s it!

Thank you. But that deletes the whole script doesn’t it? As the Bome ports use the same script, wouldn’t I have to start again and rebuild the whole thing?

Ah, sorry. Yes, could be. I thought you had two scripts.
If you’re brave enough you could open the json-file using Visual Studio Code. Then right click the code area “Format Document”. That’d make it human readable. Search for DetectionUnit …

… nay, can you send that json to me, I’ll do it!

1 Like

Thanks! Here it is.
Behringer_Xtouch One.json.zip (3.3 KB)

However, I would certainly like to know the full procedure for doing this of future reference if that is possible?

Thanks, I appreciate your quick replies and help!

So, the “BMT” ports should remain, right?

Yes please.

It’s on your own risk, so please rename your existing json-file to “XXXXX.json.bak” first.

Behringer_Xtouch One.json_onlyBMTPorts.zip (3.3 KB)

That did it! Thank you.

1 Like