How to setup up Maschine Plus as both MIDI pads and controller

I’m using Cubase Pro 11.
I’m also sometimes hooking up a Maschine Plus to use it as a controller and pad player.
I do not use the Maschine instrument or software when using it on the computer, I use Cubase with a variety of VSTs (including NI Komplete and others.)
(I also use a “regular” USB MIDI keyboard for playing chromatic instruments.)

I know how to make the Machine think it’s in MIDI CC mode and/or MCU controller mode using the NI Controller Editor program. I can even edit buttons to map some buttons to “MCU” actions and some buttons to MIDI actions.

However, when it’s in MCU mode, it sends MIDI notes even for the command buttons. And the MIDI buttons end up also doing things in the editor windows. I assume the MCU is a standard that sends “controls” over MIDI notes as protocol. I can turn this off by turning the Maschine Virtual MIDI off from “in All MIDI ports” in the Studio setups, but then the pads don’t send notes to the instruments (which is especially sad when using VST drum synths.)

In MIDI CC mode, I don’t get the feedback on the Maschine screen from the eight pots.

Is there some way to set this up to actually work well in this hybrid mode, or is it just “not gonna work?”

Separately, and this may be better asked over on the NI forums, but is there a way to use the knobs and displays on the Machine Plus for the macros/browser UI when using the Komplete Control meta-plugin to browse and select instruments/presets?

The way i use MCU mode (Which is the best as you get screen feedback) AND the pads in Cubase is to create a virtual MIDI port (Such as loopmidi) and loop the pads through that so they have their own device.

  1. Firstly you set the pads to a different MIDI Channel (I use Ch.2) via the NI Controller editor. (Just do one bank/group first so you can check it’s ok).

  2. Then, You create a new port in loopmidi called something like ‘Maschine Pads’.

  3. Download a tool called TransMIDIfier, and use this to route MIDI Ch.2 data to the virtual MIDI Device, i.e:-

(I use a Mk2 so i have also applied a velocity map to my mapping too - handy if you don’t find the pads very responsive).

In Cubase:-
4. Set the standard Maschine ports as the IN/OUT for MCU. (As you have done)
5. Ensure that the standard Maschine ports ‘all midi’ is deselected. (This prevents the MCU pads from sending to each track)
6. Your virtual ‘Maschine Pads’ port should be showing and set to ‘all midi’. (Which it will be default)

And you should be good to go, you can just create mappings as to which notes you want the pads to send in the NI software. I have a group for chord pads, one for minor scales, major scales, and another for drum mappings. Works great.

The other option is to set the pads to MIDI Ch2 and use MIDI channel filtering within Cubase, but this method works so much better. It sounds tricky, but it’s really simple to setup, and will work for any other DAW too once you have it running.

Really curious what the MCU mode is like on the Maschine Plus/Mk3 - as screenshots are quite sparse on it. I’ve hesitated buying one as i’ve seen no-one else doing this to confirm if it works, so please report back how it goes if you try it.

Loop Midi: loopMIDI | Tobias Erichsen
Transmidifier: Be Wary Software - Products - TransMIDIfier

Edit: One other note, is that you’ll have to modify the default MCU control to really get the best from Cubase. As it doesn’t use traditional MCU mapping. i.e. the instrument button is ‘save’ on the standard mapping which is confusing. And you need that instrument button to control VSTi parameters.

So, I created a reference sheet here which may help if you want to dive deeper:-

If it helps, load my Mk2 mapping in to the controller editor to see how i’ve got mine setup:- (145.1 KB)
(Select Mk2 as the controller and then File > Open config)

Thanks for the answer!

I had really hoped that this would be a little more automatic, because I have little enough time for the music as it is, and this sounds like another day of setup :frowning:

Regarding Maschine-Plus as controller, AFAICT, the device is actually a plain Maschine controller, wired to an Atom-based quad-core Linux board that runs the Maschine software on the inside, and a sound interface. (The sound interface shows up as a USB sound device, so I could use it for play-out if I wanted.) Once you set it to “controller” mode instead of “standalone” mode, it just disconnects the internal Atom/Linux board, and runs the controller like any other controller. Now, I don’t know for sure that this is what’s happening, and I don’t know for sure that it is just like a plain controller, because I haven’t had a Maschine before the Plus, but it sure looks like this to me.

Dunno if this helps, but here’s a screen shot of the Controller Editor for the Plus:

And here’s what that same (all MIDI controller) page looks like on the device:

Ah they look nice those plus models. Be interesting to see how the MCU controls display once/if you decide to give it a try? When running as MCU, and you have mapped the instrument button (Shift button in standard MCU mapping), you should see parameters from VSTi’s show up on the display and report their values as per the screen (i.e. delay times will show ‘ms’ etc.)

Unfortunately, it does require some work - If NI made an option whereby the pads were sent across different MIDI ports by default you wouldn’t have to mess about like this. But all you can do is split by channel number as above. :frowning:

You can split it within Cubase, but it becomes a little harder to manage as you have to create filters for each track that the MCU/Maschine pads will control. And that didn’t work out so well for me, personally.

I created loop-MCU and loop-Pads in loopMIDI.
I set up transmidi to forward note events on channel 15 to loop-Pads.
I set Cubase to read loop-MCU and write maschine-virtual for the MCU device, and read loop-Pads for all-midi/notes.
Unfortunately, I can’t make this actually route the events through; I think they’re not making it through transmidi (loopMIDI shows no events going into the port) although it’s also possible the maschine isn’t even sending them.
I’ll jiggle it some more and see if I can make this work, but there’s a limit to available time for this…

Update: I did get the midi into and out of the two tools, but I couldn’t find a way for the MCU notes to not end up in channel 15 on the note output anyway. Like, even if I select “input: maschine-virtual, channel 15” and send it by note-on range c-1 to C9, the remote buttons will also be forwarded in that same rule :frowning:

In MCU mode, it’s still quite bizarre. There’s a list of MCU command names that say “shift” is button 70, but punching in 70 in the controller editor says it’s called Ctrl. Ctrl in the spec/list is 72. Punching in 72 says it’s Snapshot in the controller editor. Neither of those buttons map to anything interesting in Cubase.
Using the user-defined buttons editor in the studio setup, what action would I choose to start seeing parameters from the VST? There are of course tons of categories with tons of available commands in each, but none of the obvious ones (“edit” or “edit instrument”) seem to do the deed.

Pre-mapped parameters (channel pan / volume etc) do show up with values on the screens.
I would expect to somehow be able to bind the vpots to quick controls per plugin/channel, but not finding that anywhere.

Ok. so:-

  1. You need to map your pads to be channel 15 in the controller edit software (if thats what you want). There’s 8 different banks of pad modes and they’re assessable by using the ‘Group’ buttons on the hardware. (Pink on screenshot)

  2. You have pad and knob pages in the mapping software, you can use these for multiple functions/pad layouts
    i.e. you can have a pad layout for each octave, and a knob layout to extend functions (Buttons along the top you can assign to ‘instrument’, ‘plugin’, ‘sends’ modes etc. - Brown on screenshot, and you swap between knob pages using yellow circled buttons)

  3. Use that parameter list that i linked to previously MCU Params Cubase, and then assign keys based on that to get to different modes. Cubase MCU mapping is non-standard so you’ll need to use this to correct the standard mapping.

i.e. Parameter 80 = Instrument mode, assign it using parameter ID (red), and then give it a name (blue) will display on your screen what that control does.

You can get quite deep with the mappings, for example i’ve got buttons for preset browsing which is really handy when auditioning sounds.

Also, if you hadn’t noticed - you can keep the controller editor open while Cubase is running and remap items on the fly, which is handy.

1 Like

Thanks for the suggestion. I did in fact map all the keys, and channels, and even went hunting for specific Cubase commands to bind the F-keys and user-assignable keys to.

What I couldn’t get to work was the loopMIDI → TransMIDIfier. I think it was TransMIDI that didn’t want to play. I may end up just writing a simple MIDI crossbar myself that routes only note events to a second channel.

I’ve been using this list of MCU control numbers: Mackie Control (MCU) Parameter ID codes/template | NI Community Forum
It says 80 is “Save.” Your sketch with the dual label names is helpful, though.
But, what I couldn’t figure out, was what to map that to in cubase.
Specifically, you’re saying “And you need that instrument button to control VSTi parameters” – what is the binding in the Cubase commands I would bind it to, to affect the macro knobs, and/or bind the instrument edit?

I’ve tried the “VST controls” and “Quick controls” bindings, and while I can get them to bind to channel volume/pan/etc, and also to mixer effects, I somehow can’t bind them to instrument macro knobs.
I’ll download the zips and see if there’s something I can compare to.

Not sure what the issue is with TransMIDIfier, but i use it as it’s one of the most simple utilities out there. Perhaps you’re forwarding the wrong ports, or they’re still selected in the MIDI setup of Cubase (Under ‘All’) and thus still making it through to the track?

As for the mappings, go only by what i’ve drawn out, or other Cubase mappings - as you’re confusing yourself with Logic Pro mappings from that link. Cubase has a unique system for MCU hardware which i’ve never seen before and they don’t use the standard button layouts. It’s really their own take on things.

Also, don’t try and assign anything to quick controls etc. as that’s not how it works, it operates entirely using the MCU remote protocol and the remote editor for parameter mappings, when you see it running it works really well. however.

As i owned MCU hardware for many years it’s made it so much easier for me to make sense of, perhaps. As i can imagine which hardware controls i want emulated via the Maschine controllers.

Most importantly, which i’ve missed and presumed you knew of already is the MCU section in the official docs, this is really key if you haven’t already.

You can see on page 7 how their mapping compares to an actual MCU default hardware (Just google image search a hardware panel to see).

So, to get you on the right track - the absolute easiest way for you to get instrument mapping running is to follow this example:-

Create a shortcut key to instrument mode (Orange), which will map to MCU parameter ID 80 (As seen on the chart i made).

When in that mode you’ll be faced with page 41-42 from the above Remote Control Devices.pdf manual.

You then have channel left and right buttons mapped on your Maschine (Circled green) to navigate the pages, and use the vpots to control each parameter. Hopefully that should get you to the point where things start to tick.

Likewise the inserts mode work the same, except you can roll Vpot 1 to select the insert to control and then channel bank across the pages of each insert.

If you load my mapping (.zip) file into a Maschine Mk2 selection on your (NI) Controller Editor software, it may give you a few ideas on how I have mine laid out. But i don’t know how much sense it will make to you at this point lol.

If you fancy doing a screenshare or something so i can help you better, just throw me a message, more than happy to.

1 Like

Gotcha, thanks! I appreciate all the help – I’ll try to pay it forward when I have the opportunity :slight_smile:

One additional confusion for me was that, after I uninstalled the loopMIDI driver, it also seemed to nuke my Maschine virtual MIDI port driver, and thus things that “should work” just stopped working. Some helpful advice on the NI boards suggested re-installing the Maschine software, which re-installed the drivers, which made things start working more as intended again.

I’m now up and running – thanks for making that happen!

One thing that confused me a lot was that the track selection in Cubase doesn’t match what I’m controlling in the MCU mode.
I can have track 6 selected in the main window, and the same channel highlighted in the main mixe window, but when I turn the “VST instrument” knob, it changes the instrument assigned to track 1.
Instead, I need to focus the track to edit for instruments using the Vpot1 pot – some other track is selected with the select buttons on top.
And when most of them are called “Komplete Kontrol” it makes them harder to tell apart :wink:
And the “Chn < >” buttons (code 48/49) seem to just jump to beginning/end of the parameter set, rather than page one at a time. Is that what you see? If so, how do I page to the next page? The PDF manual doesn’t talk about that.

… aand I reloaded the project and the controller mode, and now the Cnh<> buttons page between each page, not just to the begining/end. I didn’t change anything else that I know.

Computers were a mistake :wink:

Ah, perhaps NI use the same driver for their virtual midi ports too, i know they use BOME software in the pipeline somewhere.

I’ve seen people complain that as NI use virtual ports, they could easily branch off the pads into their own MIDI port as an option for users who’d like to separate pads from the controls.

It’s a shame you had to uninstall it, though, because it really adds to the experience when pads are on their own port - plus it’s part of your original question lol. :slight_smile:

The other way you can filter them out is to use the input transformer on tracks where the pads will be used:-
Set it to global mode:-
Then pick the Pass Ch2 pre-set (Or Channel 15 in your case? Whatever the pads are on)
And only Channel 2 (15) items will make it through to that track.

Using the global mode you can just pick global for the other tracks and the same settings will be used.

That’s VST Instruments ‘Global’ mode (Page 43 of the remote control.pdf), it sounds as though you have a shift button held down somewhere - perhaps you have mapped parameter 83 to a button that is set to toggle/gate mode?

It should be as per “VST Instrument Settings - Selected Channel” on page 41.

That would explain why the channel selections were taking you to the end of parameter pages also.

One other thing to note is that you can re-order and re-name parameters using the remote control editor (See here)

I uploaded an example mapping for retrologue, if you want to try it - i have a load of mappings like this that i was going to upload somewhere so people can share setups. (Retrologue Remote Mapping)

But as it’s a little convoluted how to install them, I’m holding off until I get some time to make an app that will backup/copy them into the correct positions direct from the cloud. Cubase userbase seems so sparse in regards to community patches it needs a good kick! :slight_smile:

1 Like