IK Multimedia Amplitube 5 displaying a black blank GUI when loaded as an insert in Cubase

Hi,

when I insert IK Multimedia Amplitube 5.4 as a plugin in a Cubase Elements 11.0.40 project, the GUI is blank (all black) with only the menu bar visible.

System is Windows 10 on an i5 DELL Latitude E5410 laptop with Intel HD Graphics and native screen resolution of 1440 x 900, with an additional Asus VW202 SR monitor connected via VGA cable at a native resolution of 1650 x 1080, scaling in Windows is set to 100% and in Cubase to follow Windows.

Things I tried to do before posting here:

  1. Launching Amplitube 5.4 in standalone mode, with and without Cubase open → The Amplitube GUI displays correctly

  2. Installing older versions of Amplitube (5.2 and 5.3) and different VST versions of it (VST3 and VST2) → the problem persists

  3. Installing newer versions of Cubase (Elements 12.0.0, 12.0.20, Pro 12.0.20) → the problem persists

  4. Disabling HiDPI in Cubase, as well as keeping it enabled and trying all different scalings within Cubase → the problem persists

  5. Resizing the Amplitube GUI within Cubase → the problem persists

  6. Dragging the Cubase/Amplitube windows to the main laptop monitor → the problem persists

  7. Physically disconnecting the external monitor and opening Cubase/Amplitube on the main laptop monitor → the problem persists

  8. Opening Amplitube as a plugin within another DAW (Harrison Mixbus 32c) → the Amplitube GUI displays correctly

  9. Opening other third party plugins within Cubase (e.g., Waves, XLN Audio, …) → the third party plugins GUIs display correctly

  10. opening a support ticket to IK Multimedia → they were not able to solve the issue but they (obviously) confirmed they have Amplitube 5 installed on various Cubase versions including 11 and 12 and were not able to reproduce the issue

Based on all the above, I’ve come to the conclusion that it must be a complex interaction issue between Amplitube, Cubase and my system:

  • if it was an Amplitube-only issue, it wouldn’t work in standalone mode or at least it wouldn’t work in Mixbus

  • if it was a Cubase-only issue, I would have the same issue with most other plugins

  • if it was an issue purely between Cubase and Amplitube, the folks at IK Multimedia would have the same issue on their systems

So there must be something in my system that prevents Cubase to do something special it does with Amplitube that it doesn’t do with other plugins, and that other DAWs such as Mixbus don’t do with Amplitube: quite weird!

Any help would be most appreciated: I also just opened a ticket to Steinberg support, but I assume they are still super-busy with the obligatory major release ticket burst, and at the same time this looks like a quite peculiar and difficult issue, so perhaps it’s more likely that some other user here has experienced it and potentially found a solution, than they are able to replicate it and suggest a solution from the support team.

Many thanks in advance!

hello, on my laptop it loads, but it takes at least a minute, just like Bias Fx (the most basic versions of both) but they load. My system is a bit old, just like yours. Also, I have some graphical problems that I have patched that I discovered after doing many tests. It probably won’t solve your problem. could you put a screenshot of your mixconsole, for example?

Hi,

I don’t use Amplitube, but I do use T-Racks, and I open Cubase as administrator.
Maybe try opening Cubase as administrator?

I found a couple of threads that might help.

https://cgi.ikmultimedia.com/ikforum/viewtopic.php?f=5&t=12536&start=30

1 Like

Hi Pablin, thanks for the super quick reply! It takes a long time to load for me as well, only the first time, but it loads with a blank screen, see attached screenshot I took for the Steinberg support. I’m not in front of it right now so can’t take the mixconsole screenshot at the moment, but happy to do that later: may I ask why the mixconsole though? This issue is with the plugin window.
By the way, what graphical problems did you have? I’m asking because this is not the only one I have: for instance, when I load the iZotope Vocal Doubler plugin, it won’t load the main animated picture at the center of the GUI and pop a message saying I need OpenGL version 2.0 or later, which I do have (I think I’m on 3.1 or something), and the people at iZotope just told me my graphics adapter is too old and has too little memory, which is fair enough but then the error message is still wrong :slight_smile:


The screenshot :slight_smile:

Hi Trevor, many thanks to you as well for the super quick reply!
And you might just have nailed it with the threads you shared, as I also do have an issue with OpenGL on another plugin as per my reply above to Pablin. I’ll go through the tweaks recommended there and see if I can get around the issue, will report here once done
Also the Administrator thing is something I haven’t tried yet, will try that as well
Thank you so much for pointing me in what may well be the right direction!

I’m not sure, but maybe you have the same problem that I had.

I have solved it by patching some Open Gl files and I have to have a plugin loaded in Control Room, which luckily I have and also a specific version.

you have cubase elements, maybe you should create a default template and always start with it… you could do some tests to verify that Amp5 does not load.

Thanks, I think this goes back to the same direction Trevor was pointing me towards, i.e. patching OpenGL: did you do that with the same GitHub page Trevor’s linked thread points to? I’m trying to read through the procedure described there and to be honest I don’t find it very straightforward (I am a pretty tech savvy guy but never went as far as opening binaries and things like that…)

I am in the process of creating a default template and that’s when I realized Amplitube doesn’t work (I was trying to put it as default insert on a few tracks). That was on Elements 12. Now to avoid bugs from the new version getting in the way of this troubleshooting, I’m doing all tests on 11.0.40. But I also installed the trial of Pro 12, just in case. However, the plugin should work in Elements too, so the issue wouldn’t be fixed if I found a solution in Pro that is not applicable in Elements (no Control Room).
Please also note that Amplitube does load, the problem is just that its GUI won’t display.
I’m going to take the screenshot of the mixconsole in a few minutes and share it anyway.
Thanks!


Here is the mixconsole for this test project that I created specifically to test the Amplitube GUI issue: not much to see and no graphics issue that I can see there, but please let me know if you see anything that reminds you of your old problem
Thanks!

Absolutely, i know that problem

You have a graphic issue, your graphics card is too old,like the mine one.

1 Like

Hi MicheleS76,

That’s Okay! Hope the threads can help!

Another thing I did was to update my Laptop intel HD Graphic drivers, because Lenovo stopped updating it. There is a way to do it, and it works.

I now have the latest intel HD drivers from Intel own website. The Laptop drivers are still on my machine, and if you press update via the properties tab (Device Manager) after the ‘intel fix procedure’. Windows will update your old Laptop intel HD drivers, so I don’t bother with automatic updates, after I used the method in the article.

I check intels website for any updates, and run it manually via intels download installer. If you decide to use this method, untick ‘Automatically run WinSat’ when the installer starts. When I did it the first time, it just keep looping asking for the same thing.

1 Like

Thanks again, I’ll try that as well! The “run as administrator” thing did nothing, but I haven’t tried anything else just yet. Later today I will do this driver update thing and then if it’s not enough I’ll try to make sense of those other OpenGL patching procedures… I do have a working solution which is recording guitars in Mixbus (where Amplitube opens correctly) and print the audio to Cubase, but it would be so much easier to just be able to use Amplitube directly within Cubase, so I am determined to try all these potential fixes :slight_smile:

Ok, I ran the Intel assistant and it confirmed I have the latest available driver. I then turned to the OpenGL fix but all sites and links I find about that are extremely suspicious, two out of two files I downloaded were identified as trojans by Windows Defender so I didn’t launch them. There is this GitHub page that looks the least dangerous one, but it suggests 3 different methods and doesn’t provide step by step instructions for any of them. What method/procedure did you guys exactly follow, if I may ask? Thanks again!!

They are the only solutions I could find/think off, regarding intel hd graphic cards.

I have only followed the ‘How to fix your intel hd graphics driver method’ and that works with keeping my intel hd graphic drivers up to date.

I can’t really provide you with an answer on how to patch older intel hd graphic drivers, has I have never done it… It does sound like an Open GL problem though.

Sorry! that I can’t help you any further.

1 Like

No worries at all, you’ve been super kind and helpful!! From your earlier messages I (mis)understood you had gone through the same process, hence the question… I’ll wait to see if Pablin has any additional input, and in the meantime I’ll try to dig deeper in the GitHub stuff
Thank you so much again!!

Hello, give me your email address in a PM and I will send you the 4 files to replace. You need to know a little about permissions in windows, otherwise I could try to help you by remote control.

sorry,my english is pretty bad,and i use a translator if needed.sometime tomorrow i can send you the files.

Sure, will do straight away! And thank you so much for the offering of remote control, that is so kind of you! But I should be able to do this without disturbing you so much, I am quite familiar with permissions in Windows and quite tech-savvy, to a certain extent :slight_smile:

1 Like