Inquiry about the 'Externally clocked' setting

Hi all,

I have a conceptual problem with this one… The background : I have a RME Fireface UCX (USB2 to DAW) which is slaved (ADAT in) via an unique TosLink cable to a Behringer ADA-8200 (ADAT out), set as master. In the UCX control panel, I have this :

In Cubase, I had until now the ‘Externally Clocked’ source setting unticked, in the Studio>Studio Setup>ASIO Fireface USB panel. It has always worked perfectly this way but, as I am experiencing issues when attempting to use the UCX with a 128 samples latency, I was wondering if this setting, overlooked until now, could do something about it, even if both don’t seem to be related (DAW often don’t behave as logically as expected…). So, I tried this :

Result : absolutely no change and, more strange, I was expecting the Clock Source drop down box to be activated. Nope… Seems like the Externally clocked setting is dead, somehow.

At the end, my question is : does anyone uses this setting and if so, in which context ? I’m still wondering, with my setup, if this one should be actually activated or not. I RTFM, of course, but I’m sorry to say that what I saw in it hasn’t enlightened me.

Thanks for any advice…

I use the ada8200 with a Babyface pro fs but I use two optical cables in and out so that the Babyface clock stays internal and clocks the ada8200. You also get to use the inputs and outputs on the ada8200. There is nothing to do in Cubase. I leave the clicking as internal.

I have considered many times this way of doing, as I more or less consciously trust more RME over Behringer for the clock messages steadiness. But actually, my present setup has (surprisingly ?) worked without hassle until now and still does. So, I just followed the well-known saying : ‘if ain’t broken…’, this, with a little amount of procrastination. But maybe it’s time for me to add another TosLink cable at my setup, but what for, actually ?

And I’m still wondering about the Externally clocked setting, beside this : in which context this one should be activated and why is the Clock source drop down list disabled ?

Thanks for chiming in… :slightly_smiling_face:

I know this is not the answer you would like to hear, and I’m aware of the advice given sometimes to make the A/D converter the master (and what do you do if you have more than one A/D device?), but I have always had my RME RayDAT set as master and all connected ADAT and S/PDIF devices as slaves.

I would not want the RayDAT to be clocked externally unless I could see (hear!) a measurable improvement, and so far, the opposite has been the case. In my case, the RayDAT is the best clock in the system, and that’s why I’ve configured it to be master, which in addition simplifies operation.

Have you tested making the Fireface master to see if the issue with 128 sample buffer goes away?

So that the ADA8200 can get its sync from the Fireface. You could also use wordclock between those devices.

I’m to hear anything, actually. And I note what you are saying : as I previously said, I more or less had the same feeling since a long time, even if nothing was truely supporting it. So, I’ll probably modify my whole setup as you and @mkok are suggesting, one day or another. But still, it doesn’t answer my initial question : in which case the Externally clocked setting has to be used and how comes that, when ticked, the Clock Source one is greyed out (a ‘Word clock only’ setting, maybe…) ? The manual is useless, on the subject.

Just did (with the TosLink cable connections swapped and after adjusting both the ADA-8200 SYNC selector and the Clock Source setting in the UCX control panel, before relaunching Cubase). Result as shown :

The issue remains the same : an Audio processing Load = 0 with no audio of any kind available from Cubase…

You need to leave to clock internal , your not using an external clock module for your master so it should be set as internal

And here is the ambiguity : shouldn’t my interface (even being slaved to an ADA-8200) be considered as an ‘external clock module’ ? OK, I’m going to let as is, but overall, I still don’t have an answer to my initial question (I’m a kind of stubborn chap… :grin:).

AFAIK , your interface is classed as internal , that’s the way i’ve always run Cubase ,never external , your interface is doing all the recording data and clocking but if you use an individual clocking box then as you are still recording via your interface the clocking source is "external " if that makes sense . so you should be set on internal

OK, I’ll take your explanation as the most relevent one I got. I don’t expect any Steinberg dev crew member to shed light on this one, so…
Thanks again ! :slightly_smiling_face:

1 Like

OK let’s look only at audio interface clocking for the moment. The reason you’re not able to select anything other than internal as per your screenshot is because the Fireface sees no other viable clock source:
If you want to clock the Fireface from the ADA8200, you need either a wordclock cable between them or an ADAT optical from the ADA8200 output to a Fireface input. The ADA8200 would then need to be set to master (IIRC a slide switch?).

Yes that’s spot on , but i can’t for the life of me see why you would want to use the Behringer clock over the RME , the ADA is certainly causing the issue here ,it seems they do not like you switching settings at all if it is slaved , i wouldn’t trust a Behringer clock lol

I agree with “Freq”. Another way of looking at it is that there is one interface connected to your setup using one driver, and that is what is “internal” to your setup. In other words the interface will set its sample rate based on what you set in Cubendo and will then be considered the master by the DAW.

If you set it as “external” then you would have to set both the interface and Cubase to the same rate that was set by the external device, it wouldn’t be automatic. At least that’s what the manual implies.

I also agree with the rest that RME probably have better clocks, so leave that device as master.

I think that you haven’t read carefully enough my first post, so I’ll quote myself :

IOW, what you are suggesting is EXACTLY what I’ve been doing since I got the ADA-8200 (something like 3 years ago…), for two reasons :

  1. Because, and it’s something you evoked in a previous post, it has been a rather commonly accepted idea to keep the first AD converters as master.
  2. And also, because I have only one TosLink cable, due to the previous point : at the time, I knew that only one TosLink cable would be sufficient for this configuration. This thread is interesting, as it makes me see things differently. So, again, I’ll probably change all this, as soon as I’ll get an added TosLink cable.

But the fact is that even with the UCX set as master, the same issue remains : at 128 samples, the audio processing drops directly in one second to 0 and no more sound is available from Cubase…

Yep, another way to explain this, thanks. I think I have a better perception of the setting, now, and thanks to the answers I got from this thread, even if it’s still rather obscure.

It’s been my idea (should I say a ‘bias’) for a long time. The problem is that my setup, with the ADA-8200 as master, has constantly behaved to make me think that this idea is wrong : not a single issue, beside the 128 samples one, and the relation between the two is still uncertain - I can’t actually test it with the gear I have at disposal : I need another cable for this. So, I kept it as so until now : again, if ain’t broken…

Well the way I understand it, if we’re talking about clocking in general, is that if you have two devices and the second receives sync/clock from the first what happens is that it’ll resolve that using it’s own internal clock. It essentially re-clocks the signal. So you have a stream of values coming in on that digital wire and they’re in the right order and if all you’re doing is storing them then all is well. If you’re “re-syncing” that clock or not won’t matter much.

The bigger problem though occurs when you have multiple streams of data on multiple connections. So if you had multiple ADAT sources feeding the one interface that connects to the computer you’d then potentially run into problems if those different ADAT sources were outputting their streams out of sync with each other into the one interface. That’s when the solution for sure is to have one master clock.

PS: If you recently lowered your buffer to 128 and then got clicks then I’d guess your problem is mainly that your CPU is getting overloaded, or something along those lines. So clocking wouldn’t solve that problem I think. That’s just a guess though.

In order to have the UCX as master (my recommendation) you need two optical cables.
UCX out → ADA in – that’s your sync, and also gives you 8 outputs
ADA out → UCX in – that gives you 8 inputs
The ADA needs to be set as slave.

Alternately you could run a wordclock cable between them instead of the first optical listed above, if you don’t need the extra 8 outputs.

The important point is that the ADA cannot sync via its optical output alone.

Surely getting a 2nd cable is not a problem. When I got my ada8200 I already had a single cable and ordered another of eBay which arrived in a couple of days. Cheap as well. I read up on the best ways to connect and using two toslink cables was the obvious way to keep the master as the rme interface.

I agree, but it’s not the case, here. I just have a rather basic setup : the UCX as audio/MIDI interface wired to the ADA-8200 via a single TosLink cable, the second unit being set as master.

No clicks or glitch of any kind. See my last screenshot : As soon as I set, in the UCX control panel, the latency to 128 samples, Cubase stops working… It doesn’t crashes, it doesn’t behave in a weird manner. It just no longer delivers any sound and the audio processing load drops down almost instantly to 0.

Actually, I’m used to work at a 256 samples latency, even for tracking. Before purchasing the UCX, I’ve been using for 15 years, first, an E-Mu 1820m, then a 1616m, both with a latency of 6 ms. So, it’s not a huge problem : I can live with a dead Cubase at 128 samples latency, actually. What is surprising me is that the RME driver is supposed to be the best one in the world and actually, it’s not better than a discontinued soundcard range, coming from a 20 years old design : on one hand, there is the hype/reputation and on the other, there are the facts.

Yes, I got this, and again, i’m ready to get the necessary added cable. And no, I don’t need the outputs. Actually, I use the ADA-8200 strictly as an added inputs unit, as the UCX doesn’t have enough inputs for all the external gear that I use. I’ll avoid the wordclock connection, though, as I have no experience of it.

Here, I disagree : how comes that I’ve been able to use, for more than 3 years, the ADA-8200 as master with just a TosLink cable without any audio issue?

No, it’s not a problem, beside this one : seeing the result of the test when setting the UCX as master (screenshot in one of my previous posts), I’m not even sure that it’s a true solution… :thinking:

I’ll try it, though, just to make all this clear, once for all.

I suppose we have all been preoccupied with the clocking as it was the first thing you mentioned. So what is the spec of the computer you have and have you set the power plan to ultimate (search ultimate on google ) if it’s a pc and also any other windows tweaks. Have you run latency mon to see if there is a problem? If you have a Mac maybe someone else can help.

I have three PCs. My main one is a i9 with 32gig memory and I use 64 samples buffer and don’t change it as it works fine on big projects. My 2nd computer is an oldish xenon 4 core with 16gig memory and for this one I use 128 samples for buffers. It will go lower but is stable at 128 on a biggish project. My last old i7 (13 years old) is used by my son so I don’t use my rme interface but that runs on an old m-audio FireWire interface at 64 samples for buffers.

I put those down just as an example

Until now, as per your screenshot in the initial post, you’ve had the ADA as master and the UCX as slave. To have the UCX as master you need to run another optical cable from the UCX (ADAT out) to the ADA (ADAT in) and set the ADA as slave, not just switch one optical cable around.

1 Like