Jump bar key commands

I can’t get the key commands Ctrl-1 or Ctrl-2 to activate the Commands or Go To modes in the Jump Bar. When I press either one with the Jump Bar visible, nothing happens. I’ve already checked the Key Commands preference pane and there don’t seem to be any conflicts, nor are there any conflicts in my Mac’s main Keyboard preferences. What might be keeping these commands from doing their job?

(While we’re on it, is there a reason the Mac and Windows key commands for this function are so disparate?)

Same issue here on two different Macs (my post on the issue came after yours). I tried changing the key commands and neither of them did anything. It is as if the Jump Bar buttons are not receiving any key commands.

-Jonathan

Oh I just found something. When the Jump Bar is on screen and I press Ctrl-1 and Ctrl
2
, the Write menu flashes, as if there’s a command in there that’s being activated. I hunted through and there’s no such shortcuts listed. But: a while ago I appropriated 1 and 2 for increasing/decreasing the rhythmic grid (somebody’s fine suggestion on this forum)—both commands that are in the Write menu—and I can see now that the rhythmic grid is indeed changing when I type Ctrl-1 and Ctrl-2 with the Jump Bar on screen. So the 1 and 2 key commands are overriding Ctrl-1 and Ctrl-2.

Same issue here, and I also use 1 and 2 for the rhythmic grid, probably the shortcuts I use more than anything else.

I’ve been trying to substitute other shortcuts for Commands or Go To in the jump bar, but so far I haven’t found anything that works.

EDIT: Now I am also finding I can’t manually reset these two commands (control 1, control 2). I supposed I could try resetting all keyboard commands, but I have lots that I’m using and I’d rather not reset to factory.

I hoping the next update will simply allow you to tab between the two.

2 Likes

See Daniel’s comment yesterday.

1 Like

Damn. I still think tab would be better if they could substitute something else for the function tab is currently filling. Luckily for me, I almost never need to use the GT feature, so it doesn’t matter too much to me. Thanks for the link though; I had missed that.

This is one of the disadvantages of defining your own shortcuts. After a while I stopped doing this in Sibelius, because updates redefined them to something else and I had to unlearn my shortcut.

In my opinion, it would be preferable if some shortcuts could be reserved for user definition, so that this problem is avoided.

Opt-Tab, perhaps? Cmd-Tab would conflict with the OS of course.

My approach with Sibelius shortcuts was to assiduously keep my own list of the ones I had altered so I could restore my preferences individually when needed.

In Dorico your custom shortcuts are all kept in a separate .json file, so it’s easy!

This is precisely why the new jump bar will allow me to delete a host of previous key commands I had created. Less chance of conflicts.

Ctrl-1 and 2 activate the Export current page as PDF command automatically and dismiss the jump bar. A bit strange and unnerving.

Oh and now I’ve found another problem, perhaps related: Cmd-W doesn’t close the project window—it just does nothing at all! But W by itself does flip between part and score layouts.

It should be Cmd-Shift-W, yes? It’s always been Ctrl-Shift-W on Windows.

2 Likes

Whaaa…??? In every Mac app it’s Cmd-W to close a window, and in Dorico it’s not? Have I never tried closing a window in Dorico before today?? I must not have because Cmd-Shift-W works just fine. It looks like Cmd-W closes an open tab. How did I not notice this before?

Only on your Mac, where you have defined custom key commands, Vaughan.

Dorico is not alone in using Cmd-Shift-W to close. In Logic Pro, Cmd-Shift-W closes an open project. I interpret this as a way to make sure you really want to close your project; I think Dorico has worked this way since version 1.

I checked this carefully in the Key Commands list but I haven’t defined any keyboard shortcuts relating to PDF export.

Well, they’re definitely not coming from Dorico’s defaults, Vaughan. Do Help > Create Diagnostic Report and attach the zip file here, and I’ll find out where they’re coming from.

Is it possible to use Jump to, e.g., filter the upper voice? When I type in “filter”, none of those types of filtering show up.