Key Editor goes to beginning, not cursor

Hi, call me stupid but I cannot find an option to force a double click of a clip to open the Key Editor at the position of the cursor. It always open at the start of the clip and I have to scroll through just to find the cursor and make my MIDI edit. How can this be? Is there something I am missing? I have searched the forums but it’s not easy to know how someone would have described a similar issue. Please help. The extra steps every time I need to go into to edit MIDI is driving me mad.

+1 I’d like this feature too!

Here’s my quick fix: open the Key Editor with double-click, press F (to engage follow) and tap spacebar. You’ll instantly be transported to cursor position.

+1 please Steinberg. Didn’t used to be like this and needs addressing, definitely. I actually programmed a macro to step back and forward one measure but it’s not ideal.


Yeah. Editor windows just seem to open at any position/zoom that they see fit. 90% of the time I’m totally lost. Often when doing VariAudio stuff, I end up doing editing on a vocal part—only to find out it wasn’t the correct part! Unacceptable.

Totally. This broke somewhere around v4.

+1000. When you’re doing a lot of MIDI editing in an orchestral piece with over a hundred tracks, it is really a pain. I would love for Steinberg to address this!


I’ve tried that, but sometimes it doesn’t work. It seems you have to focus the window before the F will apply to the Key Editor rather than the arrange window. For some reason this is erratic.

If you double click to open MIDI part in Key Edit, the editor should be frontmost. Are you saying it’s not?

How do you have autoscroll set? On or off?

How about the command “Zoom to Event?”

Naw, we’re griping about how the Edit window shows up with the focus NOT on the clip you’ve clicked. It’s often not where the cursor is either. It’s just in its own little world… :wink:

And yeah, you can do my F+spacebar trick to get where the cursor is, or zoom to cursor. But it’d be nice to have the Edit windows more predictable—always open to the clip you clicked on.

But I was replying to this…

Ah so! Ignore me. It’s easier that way… [emoji51]

That is weird. The Editor window always open in-focus for me and pressing F applies to the Editor window.

Yes, that’s why I’m asking… :slight_smile:

I’m with ya, bud! Let’s see if we get more detail. I’m fascinated by this one!

Ok, since there is some curiosity going around I tried to observe myself to see what was causing the erratic behaviour. Turns out I am doing something strange. I often am only single clicking a clip and this doesn’t bring the focus to the front and so F will do nothing useful (as far as the Key Editor is concerned). You need to double-click and then everything works as it is supposed to in terms of window focus (but not in terms of cursor positioning). Here’s some more details for you: The reason I usually try just a single click is because I am often working on a single screen and I have the key editor open in the lower quadrant and the arrange window in the upper, sort of pretending Cubase is a dockable UI. If I double click a clip, the Key editor title bar (on a Mac the bit with the red yellow green traffic lights) surfaces and covers up a lot more of the Project/Arrange window than I’d like. So I tend to want to avoid double-clicks and instead single click the clip to edit the MIDI in the Key Editor. I would be happy to see both modes of selection show the clip in the Editor at the right place with regards the cursor.

The problem is worse for the List Editor because using the Follow on/off workaround centres the window on the play cursor, horizontally, but it doesn’t scroll vertically so you still can’t see the notes you would like to edit!! This is why I wrote a macro (jog left, jog right) to move back and forth by one measure because the only thing that makes this window scroll vertically is to move the play cursor! That’s quite a pain to have to do…

Yes, only double click, or the Enter key, or a choice if you want to set your own will give focus.

I’d really like this issue addressed because most of the time I’m opening a midi window I’m expecting to edit the notes right at the play cursor. And TBH, what’s the point in having AutoScroll on if it doesn’t scroll to the position when it’s opened whether in play or stop mode?


Can you imagine? Focus leaving the window containing the clip you’ve just clicked?!

Sorry, Rappy, you lost me. That would be a pretty unworkable idea. Focus needs to stay on the window you’re working on!

To get focus back on you’re already-open window, why not just… Click it?

No. You’re not listening to me.

I never said I want focus to move after a single click, in fact I am saying the opposite. I want the behavior to continue to be the same regarding focus. As things stand, one click presents the clip in the editor but it doesn’t bring the Editor to the front. This is how it should be. But the position of the clip that is presented is the problem and has no bearing on where the cursor was in the project window. The clip logically should present itself where the cursor is (or at least where you click) and this should work the same no matter if the editor is in the foreground or background. (If you haven’t noticed, you can still check edits in the Editor window even if it does not have foreground focus. Hence why in my setup bringing the Key Editor to the foreground is both annoying and often unnecessary if you are simply wanting to check the MIDI - except to do the double F tap.)

Easy with the tone, there, bud. We’re taking time out of our day to help you, and you’re gonna step like that?
The biggest challenge on this forum is explaining detailed, technical behaviours in writing. If two of us misunderstood you, then it’s time to wonder if you’re explaining yourself clearly, non? :wink:
…Reading your post about the single-click behaviour, it’s hard not to think you mean you want single-clicks to bring the window to focus—so be careful what you’re typing.


Yep. That says, 100%: “I want the editor window to open and focus on cursor on a single-click.”

Anyway, after doing some looking into the way you have your windows laid out (if I am understanding your written explanation), I gotta say, Cubase behaves in a pretty logical way now, in v7.5.3. I’m actually very glad that you posted this, Rappy, 'cos Steinberg has really cleaned up the behaviour.

  • Recreating your window layout (as I understand it):
  • I have the Key and Sample editor windows open, as in screenshot:
    Screen Shot 2014-11-13 at 3.23.37 PM.png
  • I click on an audio clip, the Sample editor will show that audio at the location that the clip starts at.
  • If I want the Sample editor to show the clip at cursor position, I enable Auto-Scroll in that window.
  • Same goes for the Key Editor.
  • Focus does not move to the window—and nor should it. If I single-click a clip in the Project window, I want any key/file commands I perform to apply to the Project window.
  • If I want to go to the editor I can ⌘+tilde to it; click it; or—best of all—close it and let double-clicking open it and in-focus! …and in its previous size and location!

It seems to me that you can only have one or the other—you can’t have single-clicks do double-click behaviours and you can’t have the editor windows know whether you want it to focus on the cursor or the clip start.

So, again. what is it that is not happening that you wish was happening?

It’s really only you misunderstanding me. And as far as me saying “No. You are not listening to me.” What is wrong with calling a spade “a spade”? You have not listened to what I or other people on this thread have said regarding the behaviour of clips when they are presented (via single or double click) into the Editor. The point being made by multiple posters is that when you select a clip (either with single or double click) it shows up in the Editor at the clip start position. It is obvious and logical that if you click the clip where the cursor is, you are wishing to see the notes that have just been or are about to be played. We do not want to have to scroll all around to find the cursor position in the Key Editor. Simple. Other DAW’s consider this behaviour a no-brainer.

No, it really doesn’t say that at all. You are confusing two terms. Focus and Centering. For the umpteenth time and for the prosecutions benefit, I do NOT wish the Editor window to Focus (ie. surface) with a single click. I DO wish the clip was displayed somewhere close to the cursor where sense can be made of relevant MIDI data.

Only that does not happen at all and that is the point of this thread. Look at the other people in this thread who describe exactly that this behaviour does not work. Auto Scroll only works at finding the cursor if you press play or as the previous gentleman suggested, by creating a macro to back up and forward one measure, or by toggling ‘Auto-Scroll’ off then on again (assuming the Editor is the window in focus – not in my case). Instead you are presented with the clip start, which is a PITA.

It is not my intention to be rude to you, but you are making it increasingly difficult by insisting I am saying something that I am not. I have already said to you that I do not wish Single click to do the same thing as Double click. If you so desire you can reread what I have said. In no place have I suggested I want the focus to move to the Editor with a single click. I never said it and never meant it, so I suggest you move on from that.

It’s really not rocket science. Other people understood the point straight off the bat. Get with the program, man.

Good luck with your issue, Rappy.