Legato Function Does not Work

This has been an issue for me since Cubase 10.5 and it’s still happening on 12.
Legato Function is just not working at all. If I touch the parameter “scale legato” in the key editor then it works. The Shortcut won’t work. either from the key editor or the edit window. Sometimes I mess with the overlap and then it works for a little bit then goes back to now working.

Cubase Pro 12.0.20
Mac osx Catalina 10.15.7
Mac Pro 6,1 12 Core 128 gb RAM

Legato working here.

Are you doing the following?

If that’s not the case, can you provide a reproduction sequence so others can see the issue? Like in the guide:

Following here… Legato is weird for me but I’m sure it’s user error.

  1. Launch Cubase
  2. Create Empty Project
  3. Open preference >editing>MIDI
  4. set Legato Overlap to 240 Ticks
  5. Checkmark on Legato Mode: Between Selected Notes Only
  6. Create New Instrument track (any VI will do)
  7. Using The Draw Tool Create a New Empty Midi Event
  8. Open Key Editor
  9. With the Draw Tool Draw a Midi note EXACTLY from bar 4.1.10 to bar 6.1.10
  10. With the Draw Tool Draw another note EXACTLY from bar 6.1.1.0 to to bar 8.1.1.0
  11. In the side inspector, select EXTEND TO NEXT SELECTED from the lenght dropdown menu
  12. Select the previously created notes using the lasso tool
  13. Hit Apply Legato
    => NOTHING HAPPENS

To demonstrate this is an actual bug and not a user error do the following:
Drag back the right edge of the first note you draw from bar 6.1.0.0. to anywhere before that. (try 5. 4. 3. 0 for example)
Select the two notes
apply legato
legato works as expected.

this is NOT user error. This is a bug and it’s been happening since version 10

Adding a Video for it

People are just trying to help, and are not casting aspersions on you or your report.

I could reproduce, but only when the end of the earlier note ends at the same location as the start of the latter note. If I shorten the first note by one tick (120 bpm), it appears to then work correctly.

Is this your finding as well, @Aulicon?

Yes I can confirm that when the notes end are at the same position as the next notes start, the overlap does not occur.
Also there is a bug with Extend to Note Selected. When it is not checked and you apply Legato to the last note in the container, it will extend this note’s length to the end of the container.
That must be fixed in such a way that Cubase detects that this is the last note, so it does not expect to find the “next” non-existing note, and does not extend the length.

Please, let’s have one bug in one topic.

So the repro for this is

  1. Create two midi notes such the end position of the first equals the start position of the second.
  2. In the Length tab in the Inspector activate Extend To Next Selected
  3. Select the notes
  4. Hit Apply Legato

→ fails

One workaround is to reduce length of selected notes by 1 tick.

Note: if the end and start positions of the notes are not the same this sequence doesn’t reproduce the problem:

Does this correspond with what you see @Aulicon, @Kearley @Louis_R?

Correct

correct. The bug only occurs if the note is at the same location as the start of the latter note.

1 Like

Thanks, I’ll send in a report. If I hear anything back I’ll post here.

Yes this is correct.

Still not fixed in 12.0.30. :face_with_raised_eyebrow:

Additional videos for the technical support :

When the notes are touching, Legato Overlap isn’t applied unless we touch the Scale Legato slider :

When there is a gap prior to applying Legato, it works directly :

In either case, note that the Scale Legato slider (0 to 100) is completely buggy and does not work as expected.
It is supposed to scale the Overlap based on its value, set by the slider just below, but this is not the case.
In fact, that scale is applied to the distance between the notes End and the following notes Start, prior to applying the Legato. This distance can be a gap or an overlap.

In the first video, we can see that the Scale Legato isn’t working at all, because there is nothing to scale. The notes end are on the same tick as the next notes start, so there is no distance value.

In the second video, we see that the Scale Legato is working, but in reality applies based on the gap distance, although on the video I unintentionally made the gap roughly the same length as the 240 ticks overlap value, so it is hard to see, but you can verify this with bigger or smaller gaps. I may change the video so we can see better.

In other words, 100 will correspond to the Overlap value, and 0 will be the Overlap minus the gap.
So, it does not scale the legato at all, which is the issue, yet this slider is called, Scale Legato, and it is even explained in the Operation Manual !

Also, when the notes are already overlapping (up to a certain limit), the Legato Overlap length is added to the original overlap, instead of replacing it, causing the notes to be abnormally long, as shown in the following video.
(If the initial overlap is too long, then no Legato Overlap will be applied at all, and the Scale Legato will not work)


The Scale Legato (0 to 100 range) simply does not scale the Legato at all, it is malfunctioning, and instead scales based on the existing gaps or overlaps prior to applying Legato, which is absolutely not the expected behavior.
The expected behavior is that the Scale Legato setting should scale the applied Legato based on the selected Overlap value, which is exactly what it is supposed to do if we refer to the Operation Manual.

Such bugs should get fixed as soon as possible.


Bonus :
The slider is only called Scale Legato.
I think it must be renamed to be more explicit, like Scale Length/Legato, to reflect what it really is supposed to do.
The –100 to 0 range is the Scale Length, which scales the notes length. That one is working fine, how surprising ?
The 0 to 100 range is the Scale Legato, which scales the Overlap length.

It really should be updated so people know what they are actually tweaking.