Lock the Playback cursor to mouse when zooming from timeline

in all previous version of Cubase, when one would click and drag on the timeline and use the cursor to locate + zoom simultaneously, the location of the mouse pointer does not scale. for example, in Cubase 7.5 if I click and drag downwards on the timeline, the cursor locks to the position of the mouse pointer and stays this way while zooming (up+down movements while holding the click) and locating (horizontal movements while holding the click).

However, while doing the same click and drag in Cubase 8, the cursor becomes ‘detached’ from the mouse pointer, and does not scale 1:1 when zooming in or out and locating at the same time. I often use the cursor as a point of reference, and being able to locate and zoom at the same time is a huge priority of mine as far as workflow efficiency is concerned.

I am using windows 8.1 and Cubase 8 64 bit. was able to replicate this both in and out of projects as it seems to be a transport/mouse issue rather than project related

Same here and it’s really annoying!! I attached a video showing the behavior

Edit: attachement didn’t work. Here’s the link: https://www.youtube.com/watch?v=_rnxq3bS1b8&feature=youtu.be

I can confirm this as well on my Mac Pro. Please fix!

In the previous cubase 7 and 7.5 there was a problem with zoom with mouse where there was a latency. Now they have managed to add a new problem to this…bravo!.

+1 for fix

Same problem for me. (Win7)
And the graphic is also a bit more laggy when I zoom with the mose compared to Cubase 7

+1 for a fix on this… It’s mildly frustrating.

Happening to me too! Absolute nightmare when trying to edit drums - please fix!

Cubase “Pro” 8 - OSX Mavericks - Mac Pro

This is a pretty blatantly obvious one-- no idea how QA didn’t catch it before the release.

+1 for a fix, this is a major hamper to my workflow

This is not a bug, actually, as the function has been redesigned- though apparently not documented.

In brief, horizontal and vertical mouse movements are completely separate, and yes, the mouse pointer doesn’t ‘ride’ along exaclty. But I found, once I learned how it changed, it is easier to zoom and navigate.

If you take some time to learn the new method you might find that it’s a better system.

I’ve recorded 2 EP’s already with C8 and it’s still a hindrance for me personally. Steve, how does it make workflow easier for you?

I used to drag from the timeline and I would confound my horizontal and vertical movements- i.e., if I wanted to zoom to a certain spot in the project it was difficult. With the new function I find it completely predictable- vertical movements zoom, and horizontal movements navigate, and they do not mix.

I also do not like when functions change without documentation, but in this case, for me it worked.

(I’ll move this to General., so each response doesn’t require approval, in case others want to weigh in.)

I guess I don’t understand what you mean by “new function”. What is quicker than click/holding on ruler at the spot where you want to edit and dragging straight down, zooming out the project area to desired width? The issue is the mouse not staying locked to the timeline marker as is shown in the video example above. Sometimes working quickly the mouse and timeline get far enough apart that they are no longer on the same screen and I loose my place in the project.

I guess I don’t understand what you mean by “new function”. What is quicker than click/holding on ruler at the spot where you want to edit and dragging straight down, zooming out the project area to desired width?

My current machine does not have C7.5 on it… When I get a chance I’ll look at this on my laptop to compare the behavior with C8 and try to come up with a better explanation. (or maybe someone will chime in with one.) :blush:

I hope you are wrong and it’s a bug cause I can’t find any good use of this … it’s just annoying and frustrating :frowning: This and the MCU being broken again are the 2 main reasons why I miss 7.5 atm. I’m a Cubase dfender but I’m getting tired of buggy upgrades!

Trashdinner’s vid above is a great example, but I’ve included a couple as well. Here is Pro8 compared with 7.5. Notice the difference in the way the arrow stays with the timeline. In 7.5 it’s a tight lock, in 8 it’s all over the place which results in loosing my place in the project. I just wanted to show things moving a little faster and how in 8 it can slow the workflow. Side note in Pro 8, notice too the blackouts throughout. I’m getting these occasionally while zooming in any C8 project. Not as bad as this video, but they are occurring. Don’t know why. Hope this is helpful.

[mod edit- dead link removed]

opps, sorry, deleted these vids. After a couple of weeks working in 8, I finally went back to 7.5 and it’s much tighter editing there. Waiting to see if this is addressed before committing to 8+.

This is the most frustrating “Feature” ever. Any time I try and locate my cursor in the timeline it goes haywire. I mean Haywire. Zooming out randomly, then if I change direction, it zooms back in then switches randomly to zooming out again. It’s absolutely ridiculous. Why are Steinberg so lame at basic functionality? It’s embarrassing. I wish I didn’t make the jump from Logic sometimes.

I have to agree with Steve on this, I find it an improvement. What might be screwing people up though is that if snap is on, at certain zoom levels, the snap takes effect, and at other zoom levels (zoomed in) there is no snap. I can imagine that with some snap settings this could cause confusing cursor jumps. Try it with snap off to see how the control actually handles ("F"to toggle snap).

I can hardly believe we are talking about the same thing. There is no way this behaviour is on purpose.
It also seems like my issue is different from the OP’s. SInce my cursor doesn’t move at all when I move horizontally if its drag zooming.

I took a screen recording… https://vid.me/emdl

As you can see the response is so erratic and unpredictable. I have tried with snap on and off. Makes little difference.

I just submitted a ticket for this issue, since it seems no one has mentioned before that horizontal dragging now seems to sometimes engage the zoom and other times will move the cursor (as it should always).