Losing connection to midi controller

Hi,

Every day i randomly lose connection to my midi controller. It’s inconsistent what fixes it. Sometimes i just restart C8 and sometimes I have to restart the whole computer. I have changed the midi controller and tested another one out and still experienced the same thing. I even went from USB connection to midi and still the random lose of midi connection. Any idea if this is a C8 issue i’m not aware of? Thanks!

Hi, I just posted a message with the same question (didn’t see your message first):
http://www.steinberg.net/forums/viewtopic.php?f=226&t=75941

Do the symptoms look familiar?

are you guys by any chance flip flopping between different versions of Cubase? I noticed if I open Cubase 8 while Cubase 6 is open (or vice versa), Midi stops working until I reboot my pc

In my case - no, it’s a virgin install of entire Win7 x64, single Cubase x64 install v.8.05.

The fact that I DO NOT need to restart computer and just need to reload Cubase to get my SL61mkII “found” again really directs me to the software issue hypothesis…

One thing to try is to update your BIOS settings and other mobo drivers. Also perhaps if you’re using a hub you could try plugging it directly into the mobo (at the back, not at the front which may well just be another hub).

Sometimes Cubase loses my Midex8 device but this only happens rarely and on giant projects with lots of MIDI running. I always put that down to the fact that the Midex8 driver was provided with no guarantee to work on Win7 because it hasn’t happenned with any other USB device I use (although they’re not actually taking the same throughput because they’re only a single device…).

Having said all this, I still don’t fully trust the Cubase midi reliability because ever since the Atari days its always periodically stopped chasing correctly or dropped notes/CC values with high throughput. For this reason I tend not to run a lot of live MIDI anymore, I’ll render out to audio as quickly as I can. I hope that Steinberg will keep looking at improving the MIDI reliability with each release.

Mike.

I lose it everyday too. It’s a massive waste of time to load a big project first thing in the morning again (after restarting the Cubase, since this is the only way to fix it), since during the night controller connection was lost. Must be some sleep mode thingy, since connection never breaks under usage only during the iactive period.

64-bit, Win 8.1, Panorama P6, USB.

Interesting. Lately I’ve noticed that this happens to my Novation Remote as well. Switching off/on the Remote usually fix the problem.

Thanks, Mike - I did plug it in the direct USB port in the motherboard, and not an external hub. Although afaik the board which I have - Asus Z97 Deluxe - has one ‘native’ set of USBs and there is also an internally wired hub from ASMedia if I’m not mistaken. I will try those “authentic” Intel USB ports and see if this makes any difference.

Switching it on and off would be such an easy solution - but unfortunately, I have to close Cubase completely and restart. Only then the keyboard is “seen” again. :frowning: This is a major creativity/work process killer.

I see you have a Panorama keyboard - so we can rule out a Novation specific issue…

I wonder if any Steinberg folks would care to give their advice how to solve it? I’ve never got anything like this on my XP/Cubase 5 setup…

p.s. forgot to mention that of course all BIOS settings were checked for any “energy saving” features related to USB ports. All mobo drivers are the latest available from Intel.

Not a real fix for your disconnect issues but try this procedure to “reconnect” the controller without having to restart CB or the PC. Hopefully it works and it will save you a bit of time. :wink:

I originally posted this procedure to reconnect a usb midi device that somehow got disconnected but hopefully it will work with a controller loosing connection too.

  1. Shut off your USB midi device
  2. Re-plugin your USB midi device
  3. Turn on your USB midi device
  4. Go to Devices>Device Setup…>MIDI Port Setup
  5. Find your USB midi device in the list and uncheck the box “In ALL MIDI” this will make the state “Inactive”
  6. Recheck the “In ALL MIDI” box to make the state “Active”
  7. Hit OK

You would think just hitting the “reset” button instead of doing steps 5 & 6 would work but it doesn’t work for me. :question:

Let us know if it works.

Regards :sunglasses:

Worth noting here that MIDI is different on MacOS because the OS enables connections to come and go in Cubase whereas this doesn’t happen in Windows. You can’t just turn on and off the MIDI device, that doesn’t work. And we’ve been campaigning Steinberg for years for a MIDI USB re-scan button!

Mike.

Good point and I should have attached the link to the ongoing feature request for those who want to support it. :wink:

http://www.steinberg.net/forums/viewtopic.php?f=228&t=74134

Regards :sunglasses:

Well old topic; but I finally fixed this.

It’s was a power problem with my P6. I bought USB3.0 hub with an external 5V/4A power supply and now it won’t lose the connection anymore overnight.

Bump I too have this issue

Hi everybody

i am sorry for my bad english

i can say this thing today , "only one solution is external power supply for your midi keyboard "

i have got 2 different midi keyboard and when i use them with my laptops usb ( for power ) i see same problem two different midi keyboard too

now i use an external ac/dc 9V 300mAmper for my samson graphite 25 and it work maybe hours perfect.

i can tell , when your laptops USB voltage outputs blocked (stopped) or fall down very short time (miliseconds ) your USB device is a mouse or computer keyboard or another device ; they can continue their work from where . We dont feel any problem

but if your midi keyboard is connect your USB port and it dont have another power supply , when voltage fall down or stop very short time (ms) all midi protocol will lost so your all connection is lost and you need restart your DAW and midi keyboard again.

finally if your midi keyboard support external DC power supply i think you need,you must use this

if your midi keyboard only have USB port , you need USB multiplier device WITH external AC/DC power supply
your USB port must to be feed another DC power supply ! You never trust your laptop or PC 's USB power.


I read another topics and another forums, you can do upgrade your BIOS and install your latest USB drivers too

Regards :slight_smile:

I think the advice above is right - go for power adapters where possible, not just USB

However, I seem to have sorted my issues out another way

I opened device manager and updated every entry that dsaid the word MIDI in it, most were stating ‘your device is already using the most up to date driver’ but a few did update, including two MIDI drivers for my Asus X99a Mobo. Since then, three days ago, no issues

Z

Spoke too soon, still happening on Cubase 9. Stand alones also loose MIDI.

Everything is checked here. Power management does not switch off anything here. All device drivers up to date, three controllers go dead simultaneously. No hubs in use. I think this is windows 10 (PC)

Z

From Japan. My English is not good sorry.

Although I had been also afflicted by the same problem, possibly it solved.
Please try the following.

eLicenser Control Center Update
A maintenance is performed
Then, Anti Virus Softwere is set as " permitting with eternal rule " for eLicenser Control Center.

In some cases it works to go to ‘Devices’ => ‘Device Setup’ => ‘Midi port Setup’ and turn ‘In All Midi Inputs’ off and on again.

Hope that helps.