Loss of Quality When Rendering

Hi there,

I’m experiencing something strange when rendering audio from. a montage.

I have the Good Dither 3 set at 24 bit at the end of the output chain of the montage. When I render I have both channels and sample rate to match the input stream. After rendering, the tracks lose detail in the top end and warmth in the low end and partially reacquire a noticeable harshness in the mid highs, which I spent hours cleaning up in the mastering session and was the whole point of it.

There are no fx in the master section, and I also tried to render in real time but the result its still the same.

I’m using Wavelab 10 and I tried in Wavelab 11 with the same result.


Since WaveLab does not process audio in any way behind your back, that means a plugin is causing this. Remove your plugins and check it from scratch.

1 Like

Since I use Good Dither all day every day, I decided to run a test to make sure there wasn’t an issue. I think your issue must be related to something else, and not Good Dither specifically. Did you try replacing Good Dither with Lin Dither Pro that comes with WaveLab to see if the issue is still there?

I did a test at both 96k and 44.1k sample rate. I rendered a long continuous file of a 6 song EP in two different ways:

  1. With Good Dither set to dither to 24-bit, rendering to 24-bit.
  2. With Good Dither removed and rendering to floating point bit-depth.

In my case, the audio was fully processed already in terms of loudness, EQ, etc. already. This lets me really test just the dithering artifacts because the rest of the sound is already baked in to the files.

Then I used the WaveLab File Comparator Tool to see what the difference was. In both cases, the differences nulled down to roughly -128dB. If there was such a change in sound that you mentioned, it would be apparent in the null test files.

You can download the cheek the null test files here:

1 Like

Thanks so much Justin,

I tried again using the FX on a track so I was able to do a null test within Wavelab, both with and without dither, placing the export on a different track and when I inverted the phase and in both case the meter showed -103db.

However, when I play the resulting file in Quicktime and Elmedia Player, or the newly created montage with the render, and compare it to the Wavelab playback it definitely sounds different, less dynamics, particularly in terms of the harness of the mid frequencies. And the orchestral string pads in the background definitely have a smaller swell and their dynamic is flattened.

The Master Output is bypassed and I have no effects on the Montage Output.

I only use FabFilter Plugins (Pro-MB, Saturn, Pro-Q3, Pro-C2 and Pro-L2) which should work without any issue.

I understand that the variables that could cause that multiply exponentially, but the difference is really obvious, I wish I could send you the files for comparison but the production company owns the copyright so I can’t legally do it.

I’m a complete beginner to Wavelab, so I must miss something really obvious - but I really like the way my tracks sound now when I play them back in Wavelab and it would be fantastic if I could deliver the same sound.


Are you hearing anything musical here? Or just noise? The files I shared with you are copyrighted too but since the null is just noise, I felt it was OK to share it.

Is it possible that your interface and WaveLab are not at the same sample rate when listening to your rendered file?

If you bounce a file without Good Dither (to either 24-bit bit or floating point), does it sound better than if you use the Good Dither plugin?

1 Like

Also, are you sure you’re not rendering through any room or headphone correction? Some screen shots of your plugin setup, rendering settings, etc. might be able to help us sort it out but I’ve been using Good Dither for many years now without an issue, and I know others who use it too so I don’t think it’s Good Dither directly.

1 Like

Hi Justin,

Thanks a lot, when I mentioned the result of the null test I meant that the file sounded absolutely the same and so when played in the same montage they sounded fine.

I couldn’t hear anything and the result was silence.

Interesting. It makes me think the file is rendering fine, but something with how you’re listening to it is changing the sound. It’s hard to really say more without having more info and visuals.

1 Like

The sample rate is the same, and I don’t use any corrective software. I don’t think it’s the dithering at this point.

I saved the track plug-in chain so I’ll start a new montage from scratch and see if I get a better result in the rendering.

Do you think that rendering in real time might make a difference?

I’m using your 00 render preset with the only difference of just rendering a marked region instead of the whole montage

I don’t think so. If you’re getting an essentially silent null test when rendering with or without dithering, it makes me think it’s something about the playback path, especially if it sounds bad in both QuickTime and the WaveLab audio editor or a new montage.

I’ll let you know if I think of anything else but I think it will be hard to troubleshot without any visuals.

1 Like

Thanks so much!

To make sure I didn’t screw up something, I trashed the Preferences, and reinstalled your folder.

I stored all the presets in the Fabfilter plugin, so I recalled them and rebuilt the plugin chain.

One thing I did differently is that this time I used your 48k template on opening, which I don’t recall doing the first time, and that helped me from changing some parameters unwillingly.

I re-exported one of the cues and did the null test both at 64 and 24 bit with the same good results within Wavelab.

When playing the new render in a different montage or Quicktime, the result is much better than before, and it’s acceptable, however it still it has less depth in terms of the string swells and in general in terms of dynamic excursion between foreground and background.

I used your 00 Initial Montage Render changing the source to a specific range just as a test.

I attached the audio midi setup window on Mac and the audio connections tab in Wavelab, and the plugin chain I’m using

I really appreciate your great help, and I’ll ask permission to the producers to send you the file privately.

Screen Shot 2023-07-03 at 11.30.30 PM

Screen Shot 2023-07-04 at 1.15.57 AM

These are the other plugins


Could I suggest inserting that same chain in the Montage Output (as opposed to the Clip plugin) and see if that makes a ‘difference’.

Hi Paul,

I tried but no luck. What’s really strange is this ''flattening" that happens between the Wavelab playback and the resulting render outside of Wavelab, where instead if swelling nicely between elements in the foreground and background and without mids harshness, it sounds “cheaper”.

And that takes away the point of having spent hours perfecting the sound, so I realize I must miss something very obvious.

Hmmm … I guess you have already double checked the obvious: that is the playback settings in Elmedia Player (a codec player that I am not familiar with) and Quicktime.

This is part of why I have long since requested that WaveLab add. “null test track” feature so that regardless of where and how you have plugins inserted in an Audio Montage, you could load in your rendered master files to the “Null Test Track” and either play the two files at the same time to see if there is any difference in the audio, or render a new file to visually inspect any differences between what you have going on during playback vs. what you have rendered.

You have kind of done that by using only Clip and Montage Track Effects but a proper “Null Test Track” would be nice.

Anyway, it’s hard to say more but if your rendered files are nulling with the active montage when you’re working on it, it leads me to believe it’s more of a playback/monitoring thing than a WaveLab specific issue.

Do you have another computer/interface/setup you can use to test the rendered file?

1 Like

Thanks Justin and Happy 4th of July!

Unfortunately this is the only setup I have with Wavelab.

I tried to “syphon” the sound of Wavelab into ProTools and Logic with the Loopback app - and I recorded as Wavelab was playing . The quality this time was consistent with the playback of Wavelab and when I exported from Pro Tools the resulting file had the exact same depth and sheen that I hear playing back in Wavelab.

The problem is that it’s very CPU intensive so after a while there are jitters that get recorded in ProTools or Logic.

This probably means that the problem is in the rendering from Wavelab. I moved all the effects to the Master Output, for fear that there might have been something there that could have altered the sound, when I was putting the FX on the track.

I think it’s worth for me the effort to find out, because then I can incorporate Wavelab in my production process, because it’s a really fantastic software.


There were a couple of earlier threads which centered around render issues and I’ll share these in case they are helpful in your case.

I was one user affected. The solution for me was suggested by PG
\AppData\Roaming\Steinberg\WaveLab Pro 11\Preferences\PluginSettings.dat
and restart WaveLab. and that worked.

Here is the thread: WL11 Render Issue and specifically post#56 on.

Here is another: Rendering is changing audio - Maat thEQ Orange Problem It was solved.

WL 11.0.3 clip effects not rendering [SOLVED] - #22 by Bob_Weston THis was also solved.

1 Like

Thank you so much Paul!

It DEFINITELY improved the quality!!

1 Like