M1 chip. New computer, no functionality?

I have the Macbook Air, brand new. Comes with Bug Sur 11.2.2 , and the new M1 chip.

Cubase loads, but I have blank pink boxes on everything I click. Transport panel, mixer, new project, everything, and anything comes with a bright blank pink box.

I do very much hope there is an update. I just purchased the upgrade from Cubase 8 and was counting on some of the new functionality for a mix I am doing in a few days… Disappointing if this latest greatest version is useless to me for an indefinite indeterminate period.
Cubase 11 will not run on my 10-year-old mini mac, So ordered a new mini Mac coming (yes M1 chip) and this MacBook air for the road work… My old computer has as new an operating system on it as will allow, and that is not recent enough to run Cubase 11. SO if the new computers just can not run it, nor can the old ones, and I am left with nothing for the upgrade at this time.

Thank You
David Renaud

not sure, if you’ve seen this page yet: macOS Big Sur and Apple Silicon product compatibility – Steinberg Support

And an already existing forum thread about various experiences: Cubase 11, Big Sur and Apple-silicon M1 Macs

Just update to Cubase 11.0.10 and the pink boxes should be gone.

This… Just this.

Tom

I did upgrade to Cubase 11.0.10 . I did not help.
Pink boxes for everything. zero functionality.

@Drjazz

So, I guess you solved the problems from your other post?

Can not activate licence for cubase 11 - Cubase - Steinberg Forums

:interrobang:

Yes, thank you.
Activation is solved. V11 just does not function on my new M1 Macbook Air.
I will try my V11 activation code on 10.5 download.

Thank you for your responses.
DR

Something is WRONG then. Cubase 11 Pro works on the M1’s. Period. I’d suggest fully uninstalling and reinstalling. Again, something is wrong with your install. NOT CB11.

Tom

OK. I will attempt to uninstall and reinstall and report back.
I see an abundance of people reporting pink empty boxes opening on the M1/ Big Sur with Cubase 11.
will report back. Worse case, I revert to 10.5 for now like others have reported doing,

Yes, this was absolutely the case with 11.0. I experienced it myself. However, with 11.0.10, this was fixed.

Tom