Manage Instrument Filter dialog window is blank


In galley view, in the ‘Instrument Filter Overlay’, when clicking on the 3 dots to call up the ‘Manage Instrument Filter’ dialog window. It appears blank. No matter what I do, close/reopen the project, reboot, switch to normal view and than back to galley view…It appears blank. Any Idea?

Have you actually created any instrument filter presets in your project? If not, try clicking the button that looks like a map of an orchestra to create some default filter presets. For more information, see here:

Yes I do have some presets loaded but still it does’nt change the status of the manage filter dialog. Here are some screenshots.

Aha, I see – it’s not that the list of presets is blank, but that the entire window is blank.

That suggests there may be some kind of problem with your installation. Can you please try uninstalling Dorico 4 via the Programs and Features applet in Control Panel, then download and run the Dorico 4.0.31 installer again from here:

It didn’t fix the problem. I tried to reinstall several times and I still have the same behavior on different project.

Did you uninstall before reinstalling?

Could you please create a Microsoft System Information report about your computer, zip it up, and attach it here? Some example steps for how to do this can be found e.g. here:

Yes I did uninstall prior to reinstalling.
Here is the System information report. (107.8 KB)

Thanks for the system information. Everything in there looks to be in order.

Can you try choosing Library > Library Manager – does that window open as expected, or does that too also open completely blank?

You are right, the library manager window is also blank.

Thanks for confirming. Can you please see if there are any updated graphics drivers available for your computer, and if so, install them?

This has been done already. With no change in behavior.

Can you please try the following: first, quit Dorico; then open a command prompt (you can type cmd into the search box on the task bar). In the command prompt, type:


and hit Return. This should produce some output listing all of the environment variables on your computer. Please copy and paste the complete output here.

Sure, here it is:
CommonProgramFiles=C:\Program Files\Common Files
CommonProgramFiles(x86)=C:\Program Files (x86)\Common Files
CommonProgramW6432=C:\Program Files\Common Files
Path=C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0;C:\WINDOWS\System32\OpenSSH;C:\Program Files (x86)\Common Files\Propellerhead Software\ReWire;C:\Program Files\Common Files\Propellerhead Software\ReWire;C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;C:\Program Files\dotnet;C:\Users\Utilisateur\AppData\Local\Microsoft\WindowsApps;
PROCESSOR_IDENTIFIER=Intel64 Family 6 Model 158 Stepping 10, GenuineIntel
ProgramFiles=C:\Program Files
ProgramFiles(x86)=C:\Program Files (x86)
ProgramW6432=C:\Program Files
PSModulePath=C:\Program Files\WindowsPowerShell\Modules;C:\WINDOWS\system32\WindowsPowerShell\v1.0\Modules

Thanks! I am still consulting with my colleagues about this issue and will come back to you as soon as I can.

Yes, no problem. By the way I realized that this also occurs with othe window. For instance, the mixer (F3), the transport (F2) and as you know, the Library Manager and the Manage Instrument Filter.

Yes, most of the new or redesigned windows in Dorico 4 use a specific new user interface technology that requires the use of ANGLE, which is a graphics translation API that translates OpenGL instructions to Direct3D, so that it can be used with drivers that don’t have especially good OpenGL support. What isn’t clear to us at the moment is why this isn’t working on your computer. We’ll hopefully have some more ideas for you to try on Monday. Sorry for the delay in the meantime.

Hi, any update on this? it begins to feel limiting not to have access to a lot of dialog window.

Unfortunately as yet we have no further ideas, but I will ask my colleagues again today if they have any other suggestions for you to try.

I’m really sorry for the long radio silence on this issue. We do have a few more troubleshooting steps to suggest.

We would like you to try to set the environment variable QSG_INFO=1 on your system before you try running Dorico. The easiest way to set environment variables is using a tool like Rapid Environment Editor (it’s free, and safe to download):

When you run RapidEE you’ll need to add a new System Variable, which means you need to run it as administrator: there’s a button Restart as Administrator you can click to make this possible.

Once you’ve done that, we’ll need to capture the output from Dorico when it runs. This requires a further additional tool called DebugView:

Run DebugView, then start Dorico, and it should log out some output into the DebugView window. Save that data as a .log file, zip it up, and attach it here.

You could also try setting the following environment variables to see if they make any difference:



Let us know what you find.

No worry, I managed to work around this.

Here’s the first variable change:

Here’s the second one:
And these are the logs. The first one after the first variable change and the second one… (9.6 KB)

In both cases I had the same result. Still blank.

Thanks for taking the time and trying to solve this issue.

All the best