Middle mouse button Drag - resolved anyone?

Is anyone running OSX 10.9? Has the 3rd mouse button problem ben resolved in the 6.5.3 update?

Thanks

I’m running 10.9, but can’t figure out what issue you’re referring to. Of course it’s 4:30am and my forum search skills are doubtless impaired-- but I can’t find anything on the subject.

I’m using a Logitech gaming mouse with about as many buttons as you can cram onto something this size, and am having no problems. But I wasn’t in 6.0, either…

Can you elaborate?

Chewy

Thanks for your post Chewy.

The mouse I use is just the plain old cable attached Apple mouse, the one with a silly little wheel which can act as a mouse button 3 if activated in the mouse preferences.

For years, nay decades probably, I have used this button (and disabled scrolling completely from it) to navigate my screen in Nuendo. It is very ingrained in my neural network. Basically, click in the project area with the 3rd button, and you can drag the project around vertically and horizontally. Great!

I upgraded to 10.9 and found it didn’t work anymore. It affects N6, and might affect N5 too but not tested this. There is a thread going on over at Cubase forum (http://www.steinberg.net/forums/viewtopic.php?f=181&t=59649&p=359694&hilit=middle+mouse+mouse+button+#p359694)

So problematic was this for me that I stripped my Mac and re-installed Mountain Lion. So I’m kinda waiting in the wings to see if this has been resolved.

My son uses this space age thingy. Where ever you touch it its got a button or wheel…lol…
I bet, it can make coffee, too…

http://www3.pcmag.com/media/images/282850-mad-catz-cyborg-m-m-o-7-angle.jpg

Big K ( and his MX518 …)

I don’t use a mouse in 10.9, but I have one thing possibly that can help.

Cubase needs to receive a middle-click for the drag-scroll to work, and it sounds like Apple changed something.

Better Touch Tool (in spite of its name) can translate what your mouse sends into other clicks and a variety of other interface controls. It’s free. IF you try it can you tell us if it works to fix this problem?

I might have to try that Better Touch Tool myself, sounds like a good idea.

In the mean time this might help:

http://www.steinberg.net/forums/viewtopic.php?f=181&t=45878

I really should update my signature as I’m back on osx! :unamused:

Better Touch Tool is very cool. I use it on my laptop when working mouse-free on the road. Am still training myself, and haven’t really scratched the surface…

Chewy

Would love to know really if the third mouse button just “works”. I’ve tried 3rd party ideas as above but not really what I want.
Can anyone confirm if the 3rd mouse button works as at always had, in Mavericks?

Crunch. Bump. Shunt…

This is Middle-Click on Mac, there’s no actual button called ‘3rd’

I tried this on Cubase 7.5.3 on a machine running 10.9.4:

I’m using a Kensington trackball with a button assigned to middle-click. When I press the button, I see the hand icon, but moving it has no effect. Are you seeing the exact same thing?

Can those of you on Mac who are having this issue please post the mouse manufacturer or the driver you are using?

Hello people! I just bought a new MBP Retina that came with Mavericks 10.9.5. And I’m having this annoying problem too, both in C6.5.5 and 7.5. It was never an issue under Mountain Lion on my old Mac.
Like for most of you here, this way of navigating in the arrangement has been part of my workflow for years and years and I can’t survive without it. So far, I’m using the workaround of pressing the middle/wheel button and then pressing the left button. While holding down both of these I’m able to drag around the arrangement like before. But this is definitely not a solution from my point of view.

I’m thinking there should be a way of writing a simple app or driver that runs in the background and just does this (kind of):

On MiddleMousebuttonDown
MiddleMousebuttonClick
delay(2 ms)
LeftMouseButtonClick
End

But I’m not a programmer and have no idea of how to do it…
I’m using a Logitech M310 Wireless mouse and a B110 wired mouse, by the way. Same issue with both.

@adunion, Do your Logitech mouses generate still generate a middle click if you uninstall the logitech mouse driver and use the Apple built in pref pane?

I can’t test that here since the device I’m using, a Kensington trackball, does not. However, I have learned that some Logitech mouses are correctly working with middle-click-drag when the Logitech drivers are not installed.

If you can check that it would be helpful.

Hello Steve! I’ve tried both with and without the Logitech driver. My mice will still generate the middle click without the driver, but dragging in Cubase still isn’t possible with any of them. I downloaded BetterTouchTool, and it looked promising at first. You can convert a middle click straight into a middle+left click (and even put a slight delay in between), but unfortunately it appears to be releasing the click regardless of whether you hold down the mouse button or not. Thus, it doesn’t let you drag so it’s pretty useless.

I cannot get it to work on any of the systems here. It disappeared some time ago, I recall using it frequently.

The link in that post goes to a login page… is the app you described still available out there?

I just tried it and it downloaded just fine. Maybe give it another shot?

Chewy

Heh. It worked. I must’ve been confused. :blush: Thanks.

Did you solve it, Steve?

I found yet another workaround - I have another logitech mouse (M510) with a tiltable scroll wheel. The wheel tilt gesture can be set to work as a regular left mouse button click. In other words, I’m now able to drag the arrangement around like before if I first push down the mouse wheel and then tilt it to the left or to the right. Not very hard to get used to, after all.

Did Better Touch Tool solve it? I found it a nightmare personally.