MIDI Instrument Setup for VST Connect

Well, I’m “ALMOST THERE!” I’ve been running LAN testing between my PC and my laptop and I’ve finally got everything working as expected. The last test is to get my MIDI Keyboard to play in VST Connect.

I’m trying to run the test from the Performer’s perspective. So I’ve connected my Korg 01/W Pro into my laptop via a simple Yamaha US 16 MIDI to USB adaptor. The Yamaha connection showed up in the MIDI dropdown menu in the configuration page. So I selected it for the I/O. But I’m not getting a handshake between the laptop and the PC’s MIDI port. The MIDI light still isn’t even lit.

Can somebody talk me through the connection process to get this working?



are you missing the final part in Cubase/Nuendo? You need to create a MIDI Track and select “VST Connect” in the “Input Routing” of your MIDI Track. Now you should receive the MIDI events of your Performer

Does this help?

1 Like

Thanks so much for your reply.

I have 16 MIDI Tracks available. I have the VST Connect plug inserted in the MIDI track (see screen shot). Still no MIDI light or having my Halion VSTi show up for selection in the Performer’s Control Window.

You need to read the manual, sorry. a) to hear any MIDI Instrument you need to activate the record and/or speaker icon in the Track. b) this would then mean that the Performer plays the VSTi of that Track. The Performer needs to install and select a VSTi Instrument on his side (left top menu) to hear what he plays.
This is basic operation, pls. refer to the manual.



You need to read the manual, sorry. a) to hear any MIDI Instrument you need to activate the record and/or speaker icon in the Track. b) this would then mean that the Performer plays the VSTi of that Track.

I already know that.

The Performer needs to install and select a VSTi Instrument on his side (left top menu) to hear what he plays.

I already know that too.

With these facts now in mind, this would be WHY I’m asking here. I did all of that and it’s not working, or at least not as expected.

If I were doing an IN STUDIO session and wanted to use a MIDI instrument. I’d know exactly what to do. I’ve been using Nuendo since Version 1. But because this is a VST Connect, things are very different.

I followed both the manual’s instructions and the one video tutorial I could find on YouTube. My keyboard is plugged directly into my laptop via that Yamaha MIDI to USB2 connection. The performer setup side sees it. The Studio side sees it. I turned the monitor/record switch on. The MIDI indicator light did not light up. If I played the keyboard, I can just barely hear it, even though I have the volume on full. You can see from the screen shot just how low the volume is.

When I engage the record function, nothing happens. So, SOMETHING is off. That’s what I’m trying to determine.

Sorry, can only judge from what you write, and the pictures.
Speaking of which, last Performer pic doesn’t show any selected instrument (top left VST INSTRUMENT). Thus, there is no meter action on the VSTi Channel - the others just show the noise from hitting the keys I guess :slight_smile: Not quite sure if that is required for sending MIDI to Studio, give it a try.
Second, you should then check if the MIDI LED in the Vst Connect plugin becomes active, it should. Then, the track Monitor (speaker icon) should also be engaged although I guess it should do without. If the VST Connect plugin shows Performers’ MIDI activity, it should work in your MIDI track as well (maybe better try an Instrument track).

I have tried everything I know to get that top left window to show something besides “REMOVE VST PLUG.” I even tried to show the path to the Yamaha Interface. Zip.

I have no problem getting signal with my normal setup on the studio side. I just can’t get anything, MIDI related, to light up coming through my laptop. Analog signal from the laptop? No problem. MIDI input from the Studio Side? Also No Problem (see screen shot).

Video connection is good. I don’t have any echo either. But I have noticed that, despite the strong signal showing during recording and playback, that the volume seems low. I really have to crank the volume on my audio interface to hear a comfortable level of signal. But, at this point, it’s a minor concern.

I was able to get the MIDI light to come on on the Performer’s Side! I tracked that down to a bad MIDI cable.

However, I still can’t get it to light the MIDI Activity light on the studio side when I play it.

When I open the channel to check the routing, it says no destination. So, I’m thinking that’s the issue. But all of the options to address that section are grayed out. Meanwhile, the Yamaha interface only shows up in the setup section, not in the drop down menu for the instrument channel. !
I’m not sure where it’s supposed to show up now. It’s not showing up in the MIDI Select option or the channel. What’s left?

I can’t get a screen shot of this with the volume indicator while I’m playing it. But when I do, I see a relatively healthy signal coming through from the laptop side. My routing is ANY MIDI CHANNEL IN>VST CONNECT CUE>NO TARGET???

I don’t know why this doesn’t say stereo out on the last part. Nor do I understand why it won’t let me change this. I know it’s “Pilot Error.” But I don’t know what the error is. Very Frustrating! :confounded:

The Cue signal is what Studio sends to the Performer (audio). You can see its level in the VST Connect plugin aside the CUE dial, as well as Control Room Cue send (VST Connect Cue), provided you have not changed anything to the routing applied by “Create VST Connect”. It has absolutely nothing to do with MIDI. You can receive the audio signal from the Performers’ VSTi though, if that’s what you’re after.
I’m a bit lost, it would be helpful if you could let us know what you want to acheive in the first place and always mention which side you are talking about (Studio or Performer), otherwise it’s hard to follow.
I assumed you want to get MIDI from Performer to Studio and asked if the MIDI LED gets lit in the VST Connect plugin (Studio) when Performer plays his keyboard, so we can follow step by step.

1 Like

Your assumption there is correct. I want the Performer’s side to send the MIDI performance to the Studio side.

I’m using my keyboard. But I know a couple of drummers who use MIDI Kits. I would like to capture their MIDI performance, along with the audio and be able to change the samples, if needed, on my side during the mix.

Ok. So…does the MIDI LED in the VST Connect plugin lit?

No, NOT from the performer’s side. If I use my regular setup (as if I weren’t doing a VST session), the light comes on and I can record MIDI dat just fine. There’s a screen shot of that above.

But when I switch the cables to go into the laptop and then try to record into Nuendo, I get nothing.

I see the activity light in the Yamaha Interface. The Performer Side Configuration shows the Yamaha Interface. But the MIDI light in the Performer side isn’t lit nor does it show any activity on the Studio Side.

I was encouraged last night when I got the MIDI light on the Performer’s Side to light up. But, as of this morning , it’s gone back to dark.

I understand you know how to record MIDI w/o VST Connect.
You want Keyboard connected to Performer → send MIDI to Studio → VST Connect Plugin receive MIDI. If that is correct, let me ask you once again:

That is the plugin in Nuendo, you know. There is a MIDI item that should become active when you play the keyboard connected to the Performer MIDI Input.

Keyboard connected to Performer → send MIDI to Studio → VST Connect Plugin receive MIDI.

The answer is no, not from the performer side. NOTHING MIDI from the performer side will get ANY MIDI ACTIVITY from the Studio side.

I got that. But we really need a specific answer to a specific question in order to follow the route. So…does the MIDI LED in the VST Connect plugin lit?
This particular one:


Oh, okay. Yes, the performer light is lit. That was shown in an earlier screen shot. But here it is directly on the VST Connect.

Okay, I’ve FINALLY got it to record and playback MIDI data coming from the PC. :grin: Still not certain why the volume is so low. But otherwise, I appear to be “Over that Hump.”

I’d been using a passive hub just to get the keyboard into the laptop. I suspected that might be part of the problem. So I got a powered hub. Clearly THAT made a difference! The Path was the straight forward VST>KEYBOARD (with channel monitor on). It recorded and played back to the keyboard.
But I can only monitor the Keyboard performance directly from the Keyboard’s headphones out.

Now that I’ve finally got the two computers working together for content capture, I have zero output from VST Connect Pro. My monitors are OFF. There’s no echo on the Studio side. The analog recording I made sounds great. The VST Cue is up full in the Performer Record Track. But the playback from this track is not even showing in the VST Connect Plug, let alone sending it over to the performer side.

So now, what am I missing?

Look at how strong the signal is on the Performer Record Track. You would think that the playback would be showing a similarly strong signal in the VST Connect Plug’s Master/Studio Channels. But I’ve got nothing.

The talkback mic is screaming and there’s an expected slight echo since all of the components are in the same room for this setup test. If I snap my fingers the VST Connect Plugin LEDs jump to -10db. If I clap, I’ll get a +4db reading. But the actual playback of the recording isn’t even registering.

My settings look like the settings in the manual. So what’s blocking the routing back to the performer?

You have activated Talkback during playback. Set the auto mute talkback function to prevent that from happening, either in VST Connect Plugin settings, or Nuendo preferences.
Probably the DIM function then comes into play. Raise the “Dim” control in the plugin (should be the same as dim in Control Room Monitor), does that make a difference?
It is not recommended to override Talkback during playback or record, because for the Performer, your Talkback will be very much out of sync (delayed) relative to playback. If you want to coach Performer, use “Rehearsal”, but you cannot record then (well you can, but it will be entirely out of sync).