MIDI note display in Project view is inaccurate in 12.0.40

MIDI notes off the grid.

Even being inside the grid in the editor, in the channel it is outside the quantization.

Cubase 12.0.40

6 Likes

I haven’t installed .40 yet, is this a visual glitch only or does it sound off? Don’t have this issue in .30, all notes are snapped in the editor and project window.

@Riggs, Everything is docked in the editor and inside the Grid. It’s a visual glitch in the project window, which can confuse the reference of our edit.

2 Likes

@Thorsten_Marx , @Louis_R , Can you confirm this problem?
Windows 10 with the latest updates.

Absolutely, this sort of glitch is unacceptable at this point but at least it’s not affecting the playback, I’d be terrified if so.

Did you try to reboot your computer? Update graphics drivers? Just to rule out any bugs related to your system.

@Riggs , It is very bad to work with this problem. My Graphics Drivers and OS are all up to date. I’ve already restarted, installed the previous version of Cubase 12 and that doesn’t happen. This problem only happens with this version 12.0.40, which seems to have a good performance but has this problem that hinders our work. Install this version and confirm here with me please.

I confirm the issue on Cubase 12.0.40.
In the project window the notes extend by a few pixels on both their start and end. This is not related to the zoom level as the length excess is always the same regardless of the zoom value.

3 Likes

I can conform that this is not happing on Mac Pro Monterey 12.5 M1.

I know thats no consolation to anyone on windows who does have the issue. But its not across all platforms.

1 Like

@Renato_Borges and @Louis_R

Please check Cubase Preferences → User Interface → Disable Hardware Acceleration

With that ticked I get the issue, with it unticked (the default) the issue goes away.

Not sure that will work for everyone but it worked on my Mac.

Obviously thats not a solution, its a workaround.

@RTT1 We don’t have that on Windows. GPU acceleration is enabled all the time.

2 Likes

@Louis_R sorry hear, that is a shame. I guess Windows has no workaround until its fixed :frowning:

I’m sure that’s not the case. However, it is also not inconsistent with how problems seem to “appear” out of thin air after updates.

Funny, not funny

Preferences, event display, midi, change from blocks to lines (for now).
This fixes the issue 100%

3 Likes

Thanks for checking Louis, I don’t understand how testers if any miss something this obvious. I adjust midi offset visually in the project window all the time so to not have basic functions like events position working reliably is very concerning. Skipping this one… damn

1 Like

Did you see the fix? Post 13

1 Like

Ridiculous bug, but not going to break anything for me luckily :frowning:


Tested on
i7 | Win10 | iGPU | 3440x1440 | Windows @ 125% Scale

One other oddity when I was checking mine, the track image also scaled strange when i expanded the track to see what was going on with those MIDI blocks - anyone else? (Red circled)

Not sure if it’s related.

1 Like

@RTT1 , We don’t really have this option in Windows 10. This problem will interfere a lot in my work, because it doesn’t give me the correct reference of how my MIDI events are quantized. Needs to be fixed urgently!

1 Like

@Renato_Borges Yes its a shame windows doesn’t have that.

But it you read up there was another workaround suggested by @vinark to change it to a line.

Might be more workable until it gets fixed.

2 Likes

Also set the brightness to minimum in the same preference. Makes the line clearly visible.

1 Like

@vinark e @RTT1 , This line configuration works within the grid yes. With the block configuration, we can more accurately see the event because it is larger. For now, a workaround. We never had this problem in any version of Cubase. Needs to be fixed! Thanks @vinark e @RTT1

3 Likes