Missing Automation Parameters for MIDI Modifiers Insert

Hi,
I find this problem by doing the following:
1-Open a project
2-Create an instrument track
3-Add a MIDI Modifiers as MIDI Insert in the track
4-View (open) the automation track and choose the Random 1 Min parameter as destination and create an automation
5-View (open) another automation track and now you can’t find Random 1 Max parameter as destination of the automation. Also Random 1 Min is missing now.


This doesn’t append if you…

4-View (open) the automation track and choose the Random 1 Min parameter as destination and don’t create an automation
5-View (open) another automation track and now you can find Random 1 Max parameter as destination of the automation.

Hope it can solved soon.

Hi,

I’m sorry, I can’t reproduve it here. I did following:

  • Add an Instraument Track.
  • Add a MIDI Modifier as MIDI Insert.
  • Open Automation Track and choose Random1Min. Ins 1 parameter from the MIDI Channel > Inserts > MIDI Modifiers.
  • Open another Automation Track and choose Random1Max. Ins 1 parameter from the MIDI Channel > Inserts > MIDI Modifiers.
    => The Random1Max Ins 1 parameter is available.

Could you maybe please make a video screen recording?

Hi Martin. Thank you for your feedback. While running the video screen recording, I defined the issue better. I’ll list a new procedure to get the bug:

  • Add an Instrument Track.
  • Add a MIDI Modifier as MIDI Insert
  • On the MIDI Modifier select a Random 1 Target, for example Pitch
  • Open an Automation Track and now you can not select (and find) the Random1Min.Ins1 or Random1Max.Ins1

Hi, if I understood and followed your procedure correctly, don’t these show up for you?

Hi mchantzi,
You got the issue! In your list are missing in the MIDI Modifier of MIDI Insert list the 2 parameters.
Look in the integrated Midi Modifier, they are there, but they are missing in the insert.

Is curious that if you don’t select a target, for example pitch, you will find the 2 parameters…
But once you select a target in the MIDI Modifier to find again them, you need to close and reopen the MIDI Modifier.

I guess a ui dev forgot to put them to the other section as well :slight_smile:

No, please read again my previous post, I update with more information…

Hi,

Interesting, I can see it here in my side (Mac).

Hi, I can confirm the issue.

@Martin.Jirsak, checked this on a Mac as well, no difference.The min/max options once we select a target disappear from the inserts section.
Here’s the original window screenshot before we set any target:

εικόνα

We can see the Random 1 & 2 Min/Max appearing.

However, if we select a target (pitch for example):

εικόνα

Furthermore, if we set the random 2 (I’ve set it to position, but doesn’t really matter) as well, the corresponding parameters disappear too:

εικόνα

A workaround is to select the min/max in the automation comboBox, BEFORE we set the target.

@Martin.Jirsak , if it works correctly there, maybe we have some corrupted pref file?

1 Like

Hi,

I’m sorry… What am I missing here, please?

Hi Martin, please select a random preset and then re-open the params screen. Sure, as I’ve noticed too, you can always assign the automation, but only before you select a random choice.

1 Like

As your screenshot:

  • Delete the automation tracks
  • Select a target for random
  • Then try to open again the automation tracks. Now you will not find its…

1 Like

Hi,

Got it, now I can reproduce it. I will report it to Steinberg.

2 Likes

I wanted to use and modify the “velocity compression” modifier of the same effect. This one seems to be missing entirely. Can it not be controlled? It’s also missing as target for the “MIDI-Parameter” section.

I thought that’d be the perfect way to modulate my MIDI input for velocity-dependent instruments: You can program a local articulation at any velocity (e.g. to get some groove for the Hi Hat) and then modulate it via insert to get nice velocity curves. How would you do that if not like this? Seems an issue common enough.

Hi,

Cubase 13.0.20 maintenance update, which includes the fix, has been released. Please, download and install the update.