Negative Track Delay doesn't work properly

Cubase 11.0.41 / Win10Pro

If the Track Delay is negative, then CC may not be reflecting the delay value correctly.
Check out this video.

If Track Delay is 0, of course there is no problem.
But when the Track Delay is set to -400, the behavior of CC#1 is weird.

The output destination is on Vienna Ensemble Pro, and the phenomenon does not change whether the VEP buffer setting is set to 0 or maximum.
Also, changing the buffer in the audio interface or ASIO-Guard settings does not change the behavior.


Yeah, it’s really a bug. The thing is if you don’t use curves the cc controller lane stays perfectly in sync with midi notes data (not depending on the track delay) but as soon as you have at least one curve in lane, it begins to ignore the delay (no metter positive or negative). As far as I know the bug is still present in Cubase 12.0.20. I personaly think that if there are curves in lane they treat it as an automation lane (under the hood) which is sort of separate from track. Any ways it is a BUG! Steinberg, please fix it.

1 Like

This is not a bug. I’ve read on other topics that you should not use large negative values. In fact you should never go beyond -50 at great maximum or it will more likely cause issues.

Sounds very wierd, any reason for that? Because lots of libraries recomend negative delay up to 400ms… For me being software developer it sounds like: “you should never open your windows more than 10%”. I don’t see any problems (exept may be visual perception) to make it more than an hour, though it is limited to 800ms. But the problem is in different place, it should behave in the same way regardless of presense of curves in cc lane.

Indeed! I strongly agree with the possibility Cubase treats curved CC as data in an automation lane.
Thanks for that information. And I hope Steinberg recognize this issue.
This is clearly a bug no matter what the numbers are, because the situation doesn’t accomplish the functionality Steinberg are trying to provide.


I posted the same problem before finding this thread. Please Steinberg, FIX THIS!

It is almost impossible to work with the CC lanes not in sync. I have to manually drag all the automation points to the right everytime I edit the slow legato patch (-250ms) of the Cinematic Studio Strings. Trying to sync this with the actual midi notes shown in the editor is true nightmare.

I’m on Cubase 12 btw. So that means Steinberg must know about this for a long time

1 Like

I posted about this as well (Negative Delay CC Curve Issue (with example project)). I think I’ve narrowed down the issue to be with the nodes themselves as the interpolated values between them seem to respect track delays, but every time a node is encountered, it’s like it comes in twice or something: once “in time” (according to negative delay), and another “late” (as if delay wasn’t applied).

I’ve also posted a workaround that seems to work that also shouldn’t be too hard to undo if this ever gets addressed. To those encountering these issues, I’d give that a try.

1 Like

Of course it’s a bug. If you can type more than -50 into the negative delay, and it doesn’t play back properly, it’s a bug. Calculating MIDI playback negatively is a non-issue, it works in EVERY other DAW that supports this function.

Hundreds of sample libraries requires Negative Delay to be used. If not:

  1. Notes will be all over the place, and
  2. Quantize can’t be used, which will royally screw up any real deadline that requires post-work writing scores, etc, and:
  3. If all tracks are instead positively delayed to compensate (= using Quantize but playback is delayed to compensate for the track that has the most delayed instrument), it’s not possible to use metronome properly. And adding a new instrument that is more delayed will require to rebalance the entire project.

The workaround with a latency plugin is creative, but doesn’t work in practice. I have 1500+ (disabled) tracks. Adding delay plugins would take a week, and when recording stuff, the playback will be delayed if not using “contrain delay compensation” all the time, which screws up the over-all mix of the track, requiring a lot of extra work.

It’s a joke that this isn’t fixed yet. This is an essential function for anyone using Cubase/Nuendo for media/game composing, which is basically the only professional market Cubase is standard in.


Yep, the more negative delay the more glitchy it becomes on playback.

Has this been fixed in Cubase 13?