No video sound in Dorico 3 with UA Apollo 8

Hi, love the new update but I can’t get the attached video sound to play when using Dorico 3 with my UA Apollo 8 audio interface. The Noteperformer playback works great and if I open the same project on my laptop (Dorico 3 as well) without any audio interface it plays back just fine. I have obviously double checked the mixer and also tested several different video files.

I’m not seeing anything on the mixer meter.

If I open the project in Dorico 2 (on the same computer and with the Apollo) the video sound is working.

Any clues as to what’s causing this?

MacOS Mojave, UA Apollo 8, Dorico 3, Noteperformer 3.2

Welcome to the forum, earv. I’m afraid we’ve not had any other reports of this problem as yet. I wonder whether, as an experiment, you could try replacing the videoengine.bundle file in Dorico 3.app/Contents/Components with the one from Dorico 2, to see if that helps?

Hi Daniel, that did it. Now it’s working with the Apollo.

I noticed that the video engine bundle was twice as large in Dorico 2 than in 3.

If anybody else has this issue also note that after replacing the video engine bundle you have to go into the mixer, unmute it and put the level back to 0.

Thank you for your help.

Thanks for confirming. I’ll bring this to the attention of our video engine team.

I am having the same issue of no video audio, no output is visible in the mixer, and sound works fine in Dorico 2. I copied two files from Dorico2/components, they were .dll files and not the videoengine.bundle file you stated. After replacing, the video AND audio would not play in Dorico 3. I may need to reinstall D3 to get back those files I replaced.

Any advice??

DV

I just figured it out, I had to go to the mixer and specify Fx Reverb above the video output. Problem solved!

I am also missing video sound, I’ll try this out later (I’ll have to download D2 again though!).

Always make a copy of any internal files you would delete/change in case you need the original back!

If you have the original broken versions of these project files then we would like to see them so we can investigate the cause of this problem. I don’t think we need the video, just the Dorico project.

Hi Paul, can we send the projects to your email (which is?) rather than posting them here?

Sure, p dot walmsley at steinberg dot de

Hi again,

I think I figured out what the issue is. If my Apollo is set to 44.1 I can’t play video files that are 48. This was not a problem in Dorico 2 but now as far as I can figure out this is why I’ve been having these issues.

I also tried going back to the Dorico 3 version of the videoengine.bundle (after Daniel’s fix) and it works as long as my interface is set to the same sample rate as the audio in my video file.

Thanks for this feedback – I’ll make sure the video team are aware of this change. I guess it’s deliberate, but it’s not something that I, at least, was made aware of when we moved up to the latest version of the engine.

I think I might have an idea of what this could be. When you first load the a project that contains a video into Dorico, the audio track is extracted and saved to a temporary directory on disk, and if required, it’s resampled according to your current sample rate. If the system sample rate then changes then the audio track won’t be playable. Before you start Dorico try going to the folder ~/Library/Caches (I think it might be Edit > Go to Folder from the Finder) and delete Dorico 3 in there. Next time Dorico runs it should regenerate the video soundtrack with the current sample rate.

Smart, that could totally be it. I’ll try it next time I run into this error.

Thanks

Update:

The fix with clearing the cache unfortunately did nothing.

But I figured out when it works and when it doesn’t. If Dorico and my Apollo is set to 44.1 and I attach a video that has audio in 48 it does NOT work.

However if I switch Dorico over to 48 (the apollo switches with Dorico automatically) and re-attach the video it works. I have to re-attach it tho, it doesn’t work right away.

I should add that strangely enough this happens regardless of the version of the videoengine.bundle that I use. I have tried both with the new one and then one from Dorico 2.

Not sure I have anything to add here but I was starting a new transcription of apiece, which I do by taking an mp3, creating a video, and importing into Dorico. Not had a problem previously, but with this new one, sure enough, no sound with the video. Opened it up with D2 and it was ok. So first tried playing within the mixer with no luck including the comment on this thread - didn’t seem to help at all. Next attempt, switched sample rate from 44.1 to 48 and nothing. Then deleted the detached and reattached. Now it plays. Out of curiosity I then switched it back to 44.1 but alas, it changed the pitch and tempo to not be that of the original. Not sure what all this really means - didn’t have the issue in D2. Anyway, I’m not “blocked” now as I have a project I can work with normally - but it is oddly different than D2. Haven’t tried opening old transcription projects to see how the 48 setting is going to affect those…but those are done anyway!

Hmm, just now opened up the advanced config options for ASIO4ALL and noticed that “Always resample 44.1kHz <-> 48kHz” checkbox is not checked. Wonder if that’s the issue? Nope. I set the check box, changed preferences back to 44.1, no change. Then left it at 44.1 detached and reattached video. No sound at all. Reset to 44. Still no sound. Then detached and reattached video. Working again, with same pitch change if I then go back to 44.1

So… lesson learned for now…set preferences to 48 BEFORE loading in the video…and audio will play correctly. Don’t change back to 44.1 at this point as it changes the pitch of playback. So I have a working scenario for my project at least.

Hope someone finds this helpful.

Your experience is consistent with what we’ve found: the soundtrack of the video is extracted and cached at the sample rate in use at the time you first attach the video. If you then change the sample rate, the soundtrack won’t be re-extracted.

Important: I don’t have an Apollo 8, but a NI Komplete audio 6, but the problem is the same.

Has this problem been addressed yet?

I’ve had the strange experience today that a video that was playing its audio fine until Saturday, now has no sound anymore. This was a video I created with the export video option in Cubase since I had no sound some time ago as well, but because of this workaround there was sound.

Anyway, I attached the video in Dorico 2 and yes, there was sound, but not in Dorico 3.
In Dorico 3 I replaced the videoengine.dll as mentioned above, but then also video playback stopped working.Then I tried the ‘change-the-sample-rate’ trick as mentioned above, but also no luck there.
I’ve rendered a new video again in Cubase, but still no sound, so I’m out of options now.

Could you tell me if there’s a solution for this?

Have you changed the sample rate used by your audio interface? If so, the first thing to try is to set it back to its previous value. As described above, the video soundtrack will only play at the sample rate that was in use when the soundtrack was first extracted.

If you can’t get any joy, then the next thing to try is to detach the video from the flow (making a note of any start offset etc. times from the Video Properties dialog), then rename the file to have a different name, and re-attach it. That should be sufficient for Dorico to have to re-extract the soundtrack.