NotePerformer playback has bizarre gaps between notes despite my tweaks (help)

In the following example, I’m playing back an alto sax part and it’s essentially playing it back staccato (with very discernible gaps between each note), despite the fact that I’ve gone so far as to insert a hidden “legato” playing technique; I’ve “reset playback overrides” in Play Mode (just to be safe); and have set note durations for “default notes” (those without any articulations or slurs added) to 103% of written duration:

I honestly can’t think of anything else to do to make it NOT play back exaggeratedly staccato but to instead connect the notes as desired, and am wondering what I’m missing (or if this is some sort of Note Performer and/or Dorico playback bug?) Thanks in advance for any help!

  • D.D.

Are there any staccato marks (or instructions) before this section of music? If you add a “nat.” playing technique before the legato instruction, does that fix it?

There weren’t but that “.nat.” insertion idea solved it! Not sure why this is necessary but thanks!

  • D.D.

Check Play mode. There’s definitely a previously-applied expression from a playing technique, even if it was inadvertent. You should be able to see it in the PT track.

Sorry for my ignorance, but what do you mean by the “PT track”? (just checking!)

  • D.lD.

The expression track, which shows Playing Technique indications like “pizz.”

Just set up Noteperformer and I’m having the same issue with weirdly detached notes in all parts (brass, strings, reeds). I checked the PT and everything is set to natural. I followed the Noteperformer instructions for timing defaults.
Are there any other suggestions?

just as a general point, NotePerformer is programmed in general to play more detached than some would find natural. That’s one of the main reasons it’s good in strongly articulated music. But if you attach part of a project which shows this behaviour, it should be fairly easy to determine if it’s working as designed or not.

See this thread:

“And possibly send a value of 1 to CC 108 to trigger the permanent tenuto mode.”


that’s well reminded about the CC108,1 although it tends to kill the vitality of faster, strongly rhythmical sections in NP (which is precisely what NP is best at) so has to be used judiciously. I get the impression that Arne doesn’t exactly recommend this workaround but as it’s given scant mention in the Dorico version of the manual, it’s easily overlooked and might be the sort of thing @tsharli is looking for here.

One of the things that could cause shorter playback of notes is a tempo indication with an eighth note instead of a quarter note. See also this question. I fixed this with a hidden quarter note tempo indication right after the (visible) eighth note tempo indication and by manually lengthening the playback of only the first notes of the piece in play mode. (Because this fix only leaves the first note of the piece with shorter playback duration.)

Screenshot 2022-01-09 at 16.25.57

Thank you everyone for your comments.
@dko22 Great suggestion - here’s an XML snip of the project (jazz ballad).
noteperformer everything detached.xml (122.3 KB)

As far as I can tell, the only notes that aren’t detached are the ones explicitly under a slur.
I tried adding a tempo of h=36 (instead of q=72), but I didn’t notice any difference.
I’ve looked through the Dorico help and forums and can’t find what/where the CC108 option is.
I should add that overall, NotePerformer sounds great - it’s just this one issue that sounds so unnatural (to me anyway).

You will find CC lane editor in Play mode, below the player’s piano roll — you show the different lanes as you wish just below the player’s settings, on the left column. Let me know if you need a screenshot.

I meant a Dorico project if you could manage that!

I haven’t tried this, but I imagine you can get the default behaviour back by sending 127 to CC108.

I think 1 to activate and 0 to deactivate. (probably anything but zero to activate)


you just beat me to it --it is definitely 0 to deactivate which is the default state as can be seen in what the Sibelius plug-in produces if you have a copy still kicking around. Also 1 to activate is standard (but likely as you say anything other than 0)

@dko22 Ah yes of course.
noteperformer everything detached.dorico (452.2 KB)

Ah, I see, it’s the automation lane, thanks.
But it seems like this field is not editable? I tried selecting some/all notes, but that field is greyed out.