Noteperformer setup with Iconica Sketch

Ok,

Here ya go. Here is a cut down of the work. I have assigned 3 tam instruments in the Truestrike percussion map. I placed them in several ranges just as a test to see where they might fall between C0-C4. Hope that makes sense?
Colossus snipp. .dorico (1.4 MB)

Thanks again for your help. I know we’ll get there…

T

Ok, Thanks!!! I just checked, and routing seems ok… I’m not sure though about your percussion map. I don’t think it’s a good idea to have copied MIDI notes. What is Dorico supposed to do? Trigger four or five notes at the same time when one notated note is supposed to play? Not sure Dorico is wired to do that. I suggest you only keep the “original” notes (with tam-tam instrument — I see there’s a wind gong, it will not play on a tam-tam staff because Dorico will only trigger tam-tam. Remember, semantics! Call it tam-tam too if you want your tam-tam to trigger that sound)
Then, if no sound is out (or better, another sound from the library — this would suggest a C3/C4 pb), I’m running out of ideas…
Now that I’m studying the mixer, I see Large Gong (which is also routed to the same Kontakt instance) but Tam-tam and Small Gong are nowhere there. That could be a hint. I also notice that your percussion map says it’s a single instrument, while you have two instruments listed in it (so already multiple), and it’s routed to three instruments. You might change that as well, in order to be consistent, although I honestly have no idea if that would make a change or not.
Another thing I cannot check, since I don’t have that library: check out how Kontakt’s outputs are set up (make sure to make the window with outputs appear, the GUI is crappy, but it’s really interesting to see that window and set it up according to your needs. I made a thread about that.) They might be at -∞ and you don’t know!
Hope it helps!

1 Like

Good Saturday all,

Marc, thanks for giving it a try. This morning I took a step back and tried simplifying things. I only have one Tam Tam part and started with one Tam hit till I got a note to sound on the staff. The good news is, I’m able to trigger one sample! However, just the one. No matter what I write in the other key destinations, Dorico only plays back C2 Tam sample. (btw C2 for dorico is equal to C1 in my kontakt player).

Here are some screenshots of my session. FWIW, while I have the staff highlighted, I can hear all my sounds as I trigger them up and down the keyboard. So, somethings working. Here’s hoping for a little luck today from someone who may recognize my err. I’m wondering if I have to create a custom notehead or something? I was surprised that after writing in beater, it didn’t catch on either.






update,

I feel like I’m getting closer to making this work but am still puzzled why Dorico won’t change to the next instrument sound in the percussion map. If I load just one instrument, any instrument and assign it to a key, Dorico will play it. Hoorah!!! However, as soon as I add the second instrument in the map, Dorico looks the other way as if nothing gets entered. I thought it might be when adding the technique text, but am really unsure. I’ve tried all kinds of text that seemed logical to get Doricos attention to trigger the new sample on the same line. I even created a custom notehead in the edit percussion techniques page. nothing. For the love of PETE!! Where am I going wrong? Is it in the expression mapping and not Percussion mapping? The lower line is the new Tam part I created. The second passage marked triangle beater (And I tried multiple ways to indicate the metal rods on tam sound),which I get only the regular tam hit that is assigned to a different key. So close, yet so far…


Hi !
Not sure it’s related to your issues, but for completeness, can you post a screenshot of uour settings in Preferences > Note editing > Percussion?

Sure! I didn’t realize this was another place to make changes.

Maybe using Percussion map in the input preferences would be a good idea? FWIW, it is the setting I always use…

zero change Marc. I really appreciate you taking the time aside to try and help me out with this. Frustrating…

What ever new instrument I add to the percussion mapping, Dorico then defualts to that new sound. I even try and change the noteheads playing technique to crosses and indicate rods (beater) when I want to switch to that sample . I’ve spelled things out as best as I can for Dorico to see the channel,key sample change, but doesn’t seem to work, unless I create a separate channel/instance and a new dedicated staff. For whatever reason, it will not change samples within the single line perc staff.
I personally feel there are too many areas one can easily miss when applying changes to anything audio related. Where many DAWS use one section for AUDIO, Dorico chooses Play. However, there’s multiple areas to make these adjustments and not just one. There’s Setup mode that one has to keep track of, PLay mode (with multiple changes here), The Library pull down (which also leads to a whirlwind of areas, Expression and Playback Maps, Techniques, Playback options), however, each one does something different and can be overwhelming to keep track of all the nuances involved.

Maybe just an area for Audio or Play, and all things that are responsible for audio plackback and control starts and ends with one area.

Here are my percussion assignments. In this version, I chose Single instruments and only linked two Tam-Tam sounds. The first I entered (succesfully) was the beater. It played automatically with standard noteheads and without fuss. As soon as I added or pointed to another sample, Dorico made that sound the master. I tried everything I could think of to get the beater sound to play once again. nothing. How else would semantics come into play here? I wonder if in techniques options, there shouldn’t be a notehead specification like there is in setup mode? Rather than writing trill, roll, trem, or crescendo as a technique, if there was a way to signify a notehead shape to determine the percussion instrument sample change. There’s plenty of notehead styles that would cover a great many varieties of percussion for that family of instrument. Or, have a way in setup mode to point the new notehead to the percussion map sample. c1-c2-c3… I feel a bit defeated.


I’d say that’s something you should be able to do using the percussion editor. You can create a new technique with a new notehead and choose a playback technique (or two…)

I have done just that Marc, but nothing seems to change.

T

Good Monday morning all,

I can see that there has been a ton of activity since my last post yesterday. I was wondering if there was a way to do a virtual screen share with someone who has a handle on custom percussion mapping with third party software? I feel I’m at a point where I need some new direction to get me to the next stage.

Thanks!

T

Thought I would revisit this today to see if there were any more thoughts on getting the custom percussion mapping to work correctly with 3rd party software. Kontakt>Truestrike or other perc library.

One thing I have noticed is that I can trigger a sound (at times) correctly with the clip art image (icon) in the techniques window in the far right. However, adding text technique in the percussion mapping or changing notehead assignments in setup area does not change the sound sample. The loaded samples in the percussion mapping are being designated properly but with a hitch. I can only get the changed sound to play correctly by putting the icon (and only the icon) over each and every note to get it to sound. I suppose I could do this, then find a way to hide every unsightly icon and then write in the text?

Please help when you get a chance.

Thanks!

T