PitchBend Bug

When recording MIDI Pitchbend

The recording comes out different with a slightly rising pitch instead of returning to 0
I’ve updated to the latest version, this happened since the beginning of Cubase 13.

Only solution is to manually drag the points to 0 where they should be…
Is there a normal solution for this? Hopefully this can be addressed.

Could it be that your Pitchbend wheel is faulty?
A pitchbend wheel not returning perfectly to zero is a pretty common fault.

The problem started after I’ve updated from Cubase 12 to 13.
I’ve just tested it again in C12 and this problem does not occur.
I am using the Native Instruments Komplete Kontrol S61 MK2

I don’t hear the problem when using the pitchbend while recording.
Only after the recording in Cubase 13 the pitchbend data changes.

I’ve tried another keyboard as well, which does not seem to have that problem.
in this case the Nordwave2.

Nontheless this seems Cubase 13 related otherwise Cubase 12 would have the same result.

I’ve changed the controler to Step , which seems to be accurate enough and works as normal. However I always worked with Curve’s/Ramp mode in C12.

Somehow C13 does not work properly on some midi Keyboards Pitchbend resolutions. I think the NordWave2 Pitch stick is more accurate.

Hi,

Set the Key Editor to Jump, please. Since Cubase 13, the default settings is Ramp. In some cases, the issue you have, night occure.

There was another post recently about getting stepping (low resolution) from using Ramp mode. Are these two issues related and are you aware of any resolve?

Hi,

Could you link it, please?

You can just switch it and you get the Jump mode.

I used the forum search function to find it for you:

But I much prefer Ramp Mode, it’s much easier to work with. So using Jump Mode is not a resolve unless Ramp is now a depreciated function, which I would find hard to believe.

Pitch bend always runs when not in use in Cubase.
When I don’t use it or when I use it the pitch bend is not at 0. This happens on all versions of Cubase that I am using. I replaced the Midi controller but this still happens.
64a82126-e2ee-4284-823a-382981c5049a

Could you use the MIDI Monitor plugin to observe what data Cubase is receiving?

It receives the signal of the pitch bend and operates on its own and does not return to zero.
9f9d5d94-aadf-4b93-93db-02cb59ec00bb
edbcf6a6-9a19-4fd8-88a5-aa21ee791801

I would still verify using the MIDI Monitor plugin:

If your controller is continuously sending Pitchbend data, something is wrong with it.

Mine is like this.
You often help me find the cause. Thank you.

1 Like

That is a faulty Pitchbend controller I’m afraid.

ok. Thanks

Hi,

What hardware device do you use, please? Is the PitchBend a wheel, or a joystick, or a ribbon controller?

What Cubase versions do you use, please?

Could you try to switch the PitchBend from the Ramp Mode to the Jump Mode and test it again?

There still isnt a solution on the main question I’ve asked

Cubase 12 with the Ramp or Jump mode worked as expected.
Cubase 13 inherited the problem, which leads to the point from 0 to up and down causing a unwanted ramp up , seemingly beeing more a cubase bug.

The Pitch stick on a nord modular behaves fine in C13, the Komplete Kontrol mk2 causes a bug , while there was no problem in C12 with a direct test…
no problems with midi monitor.

A solution would be helpful for this feature in cubase to work as Expected.

Hi,

Does it really happen in the Jump mode too in Cubase 13?

Please excuse my intrusion but… and Just out of curiosity. Ahem…is it ok outside of CBase.
I imagine you have checked the pitcbend data in something like Midi-ox as an independent test outside of CBase ?

Best regards.