Playback Issue - Sampled Trills (Berlin Woodwinds)

I am trying to get OT Berlin Woodwinds trill samples to play in Dorico, but it insists on generating trills on its own. OT uses a “trill orchestrator” where two notes of the desired interval need to be pressed simultaneously in order for it to produce sound.

I notated the trill with Shift-O, have auxiliary note enabled in properties and have “Samples if Possible” checked in Playback Options.


Using “Trill” as the sole playing technique results in wrong type of playback - Dorico bypasses the Expression Map and generates a trill on its own using the sound from the previous sound slot.

I can get Dorico to spit out two short fragments of the trill from the correct sound slot if I create a blank “Trill” base switch and add to it two additional switches for half- and whole-stop, both pointing to the exact same location (Prog Change 9 in this case). This sounds as if this auxiliary note isn’t “held” long enough.

Appreciate any help, this is frustrating and so incredibly time consuming. Many thanks!

I don’t have the Berlin Woodwinds so the best answer will come from someone who has access to it. However, CSS Strings use a similar method (unless bypassed using a script) where you have to play two notes simultaneously as a chord to get a trill. From the screenshot, it looks like you’ve just entered a single note. Of course in the notation, you’d need to hide the note you’re trilling to which can on occasion be fiddly but it does work. Did you try this?

Thank you. What I take away from your suggestion is that the auxiliary note shown in my example doesn’t work as the trigger or as that second note needed in order to produce the sound. Or perhaps it works but its duration is not equal to the original, main note. The latter case might explain why I can hear a short fragment of a trill, equal to maybe a 16ths or a 32nd.

IIRC, the method in Cubase Score Editor is to enter two notes for the trill and then apply a hotkey that would display this combination as a proper trill of needed interval and duration. Instant playback and perfect display. Perhaps that’s why I keep expecting Dorico to offer an equally easy way to trigger and notate a trill that is hidden somewhere

I will try your workaround later today. But I wonder if there is a way to control the duration of the auxiliary note, as that solution seems half way there already…?

perhaps programmable hotkeys of this nature would indeed be a useful addition to Dorico! For trills, surely both notes would normally be of equal duration unless you’re trying to do something out of the ordinary so I’m not sure I understand the question of altering the duration of the auxiliary? Without hearing the short fragment, I can’t be sure what it means at this stage.

Just another thing to check – you do have entries in your Expression Map for trills, I assume? Whatever the method the Berlin Woodwind use for playing trills, there must still be some sort of CC or keyswitch entry to communicate with Dorico, otherwise it will automatically default to its inbuilt trills which is what you’re currently getting.

What I’m trying to say regarding the auxiliary trill note in Dorico is that I wonder if it is more than a graphical symbol for display purpose only and I think it actually does trigger playback. If so, it would be quite logical and perhaps similar to the Cubase approach of converting any note combination into a trill with a hotkey.

However, the length of the auxiliary note seems to be very short (almost like a grace note, just the way it looks in the score) and perhaps this is why I’m hearing this very brief trill that gets cut off after just a brief moment. So I am trying to find out if it is possible to control the length of the auxiliary note somehow in properties or elsewhere…

Many thanks again for your suggestions, I will try them later today.

There is a setting in Playback Options for whether Dorico uses the sample library or generates its own trills.

(For many libraries, I actually prefer Dorico’s trills.)

True indeed but the default is of course to use sampled trills where possible (i.e listed in the Expression Map), otherwise I fear we’d have a lot of people who were wondering why their trills never played back from sample libraries

I myself have never found a library where I prefer in general the artificial trills but I know you’re a fan of them :smiley:

Yes, I have this enabled, no dice.

I suspect this setting works very well when you have a sample of recorded trill being played and it is activated by a single note in the score.

In my case, two notes have to be pressed simultaneously to produce trill sound but only one needs to be displayed.

Can’t you just scale away one of them?(properties/common/custom scale, 1%)

Yes, I am looking at this right now:

  • turn off display of auxiliary note
  • input two trill notes as chord
  • scale the trilled to note (possibly color it too) to reduce its size

Very ugly, but I’ll take it… Will try it out later this afternoon to see how it works in terms of playback and expression map. Thanks for the suggestion!

Hi ebrooks,
I am a little late in responding, but I wanted to share my solution to these kind of problems. I use this work around for trills and tremolos etc when using samples that don’t work with the notation. Simply create a ‘staff below’ just for that one bar where you have your trills. Create your playback as desired on this extra staff (you don’t even need to use the trill symbol if you need it). Then make your notation look like you want and suppress playback on it. Only the music on the ‘staff below’ will sound. You then ‘Remove this staff’ so that you don’t see it, but the music will persist. You will get a signpost for the extra staff and you can ‘reveal’ it again if you need to edit it.
Maybe this will help…I really don’t like scaling things down to 1%…You can’t locate them very easily afterwards for one thing. Having an extra hidden staff is a wonderful feature…Just remember that any music on these extra staves will always persist unless you actually delete it, after which you can then remove the staff if you don’t need it anymore.

1 Like

I agree that this is usually the best solution for situations where you simply cannot get the notation and required playback to match. Particularly with measured tremolos where the playback side does not yet fully correspond to the notation, (in fact there’s a current thread on that here Tremolo playback) it could be a handy solution

Thank you so much @Grainger2001 and @dko22 for these suggestions. I didn’t know about hidden staff, but thinking through your description I wonder if it will also help me program a few additional articulations from OT: the tuplet and triplet repetitions. So I am looking forward to trying these out!

Unfortunately, Berlin samples do not start on the beat in order to preserve the attack transients. The result is the playback is horribly unsynchronized. I know I can offset (positive or negative) individual notes in Properties (in ticks), but since I recall Cinematic Studio Strings also require an offset, I am wondering if you might have a solution for this issue as well.

Many thanks!

The Cinematic Studio libraries document their legato offset to between 1/3 and 1./10 sec. depending on the legato speed activated. If the offset is constant within the Berlin library as opposed to being different for different lengths or articulations, then you can just add an included MonoDelay insert in the mixer (check with the Cubase plug-ins documentation, it if not already familiar) for the relevant instruments.

My solution currently is to use a 3rd party KSP Kontakt multiscript which automates the procedure but brings one or two problems of its own and CSS are due to release an update at some point which optimistically might combine some of the sound-improving advantages of latency without the obvious drawbacks . It might be worth checking in a forum like VI Control if there’s anything similar for the Berlin Woodwinds?