PreSonus FaderPort 2 (2018) midi remote script

Muchas gracias por todo el trabajo, tanto tú como CKB nos habéis hecho el trabajo más fácil y nos habéis dado más opciones para utilizar Fadeport V2 con Cubase :vulcan_salute: :alien:

1 Like

On this topic, which is discussed in depth in this other thread,
Steinberg is trying to get a handle on this. So the issue is known.
Anyone who continues to have similar issues should post this in the thread there. Then there is the best chance that it will be fixed soon.

1 Like

I received an eMail from a newcomer who asked me to summarize
the current files of fp-wizard including the current documentation
in a new zip file. Here it is:

fp-wizard_20240529_full.zip (2.6 MB)

2 Likes

Since I updated to Nuendo 13.0.40 every time I start the computer and start Nuendo, faderport has no output port available… I need to restart Nuendo once and it works again.
image
Is there anybody here with the same faderport behavior.

How can I roll-back to 13.0.30?

I’m going to buy the Presonus Fadeport V2 (I was looking at the Icon P1 Nano, but I see that as you say, the Fadeport V2 is better with this script). Is this file what I have to put in the folder to use Fadeport from the beginning with all the advances that you have implemented to date? Is it the same as the one in the update on May 29? Thank you so much.

1 Like

Yes, it is the same file.
The file, which must always be in a special folder, has the name
PreSonus_FaderPort.js

The script version corresponds to the timestamp of this file. Currently it is May 29, 2024.

All other files are documentation.

1 Like

Muchas gracias de nuevo!! Un abrazo!! :vulcan_salute:t2::alien::purple_heart:

1 Like

Hi Lluís,

maybe that helps:

Delete all program preferences of Cubase
per pressing together Ctrl-Alt-Shift (= Strg-Alt-Shift) left on the keyboard
when starting up Cubase to delete all Cubase preferences.

1 Like

Thanks for your kind help.
I started Nuendo in safe mode deleting preferences and disabling plugins with no success.

1 Like

I had a look at the release notes of Cubase 13.0.40 and there I find this topic:

MIDI Remote devices that were switched on after starting the application now connect correctly to the MIDI input (via “Windows MIDI” ports).

I think your problem has something to do with this and that Steinberg’s changes have unfortunately created a new error like your’s. It could also be the case that the problem only exists with your specific device (PreSonus ioStation 24C) and not with the FaderPort.

I therefore recommend that you report your problem directly to Steinberg via a support ticket.

I have opened the ticket at steinberg support, we’ll see.

1 Like

Issue fixed.
As Steinberg Support team requested:
In Studio > Studio Setup > MIDI Port Setup, uncheck the ‘Use Directmusic Device’ checkbox .

Regards,

2 Likes

Hello friends,

I pointed out in the thread ‘Midi Remote Randomly Disconnects’ that this problem has not yet been resolved.

Let’s hope that Steinberg will find the cause soon.

Maybe you can help find the cause and post your feedback directly there. In my opinion this is a difficult bug to pinpoint and requires some ‘trial and error’ so feedback from users can be very helpful.

Best regards
CKB

2 Likes

MIDI Remote Randomly Disconnects

Hi friends,

user exoslime reports a workaround that fixes the problem for him.
Maybe we could also try this with the FaderPort:

  1. Set up a dummy track in the actual project as a MIDI track.
  2. Assign the MIDI input of the dummy track to the FaderPort.

If there are no more crashes with it, this would also be a good hint for Steinberg.

Best regards
CKB

1 Like

Hi friends,

in the thread ‘MIDI Remote Randomly Disconnects’ a workaround is reported.
So it could be that Steinberg is able to fix this bug.

I think we should wait for Steinberg to fix this bug
before fp-wizard continues with new updates?

What do you think here? :innocent:

2 Likes

Thanks for all your effort @WEM and @CKB .
I’m having some issue, I’ll attach a photo that show.

this is how mine looks like, I dumped CKB’s newest .js file to the correct folder but somehow Cubase still recognize FP2 as older file.

I’m afraid that if I delete pref file (by starting cubase while holding CMD - ALT - Shift) it might delete key shorcut as well as template I made.

I tried to delete midi remote device and re-install it but cubase not allow .js file (greyed out) so can’t do that.

any ideas?

I’m not sure if I’ve understood this correctly.
Do you mean that you’ve installed the newest version of the script, but an older version is still running?

I think so. I’m new to cubase, so not sure how to check. Last night I deleted preference file and it still is same.
I’ll try again by deleting existing .js file and see

You can search your entire system to see where you can find the “PreSonus_FaderPort.js” file. If the file exists more than once on your system, you may not have copied the new version to the correct folder.

You may need to activate the script in the MIDI Remote Manager.