PreSonus FaderPort 2 (2018) midi remote script

Hi Michael,

the concept of a single-fader-controller is that all controls are always assigned to the current channel. Intervening in this would be quite complicated. I can’t do that now.

However, I myself also have a wish, as I’m often in the situation of controlling the same few channels of a project. That’s why I’m thinking about making it possible to mark certain channels so that I can then select these channels with different button combinations very fast. But that’s not easy either, because MIDI Remote isn’t designed for that. But I’ve already tried a few tricks that might work anyway. If I would manage that, it might help you too, although that’s not exactly what you want.

Best regards
CKB :innocent:

1 Like

I did delete and download again, copied it to midi remote folder.

and when I launch cubase 13(up to date) I see same screen as I posted above.

what I did was

CMD ALT shift - and delete preference.

Delete faderport.js file

reboot

then restart cubase

still some functions are not shown correctly. (when I hover my mouse cursor it says “no mapping.”

any idea?

Hi KYUMIN_SHIM,
most of what that has been discussed here on the topic troubleshooting has ended up in the setup-pdf below.
Perhaps you should try everything (each step) that is written there in the setup-pdf.

fp-wizard_setup.pdf (492.7 KB)

1 Like

No worries! Thanks for your help. I’ll try everything :slight_smile:

I love this script just not sure what went wrong.

I’ll give it an another try!

1 Like

Hi KYUMIN_SHIM,

I was having a similar issue a while back with the script not updating. This turned out to be because there were multiple locations containing the local user scripts.

What worked for me was to open the Lower Zone to the MIDI Remote tab and look for the Scripting Tools, then click the folder icon there to Open Script Folder and make sure that you replace the .js files in this with the new versions.

Apologies if you’ve tried this already, but thought I might chime in just in case!

Cheers,
Tom

2 Likes

Hi friends,

due to the solution hint from Lluís in the thread ‘Midi Remote Randomly Disconnects’ I have now included this hint in the setup-pdf.

So here is the current setup-pdf from June 30, 2024:
fp-wizard_setup.pdf (493.7 KB)

Best regards
CKB

5 Likes

Dear CKB
this is an amazing tool and it has brought new life to my faderport. However, I have noticed som strange behavior and I wonder if you could give me some advice: I have set up the latest version on my M2Mac running Cubase 13.04. If I start a new project and FP runs perfectly. In the midst of an ongoing project suddenly only the transport section and some functions are available. If I press e.g. the Marker button, nothing happens. Confused I started a new project and -bingo- FP behavior was back to normal. Now it gets weird: If I copy a section from the project where FP does not work into the new project where FP functions well, this new project shows the same odd behavior. What am I doing wrong? Thanks Oli

1 Like

Hi Blechreiz, thanks for your nice comment.

To your problem: Maybe it is the issue of Cubase, where MIDI Remote randomly disconnects.
(I hope Steinberg is working on it right now.)

At the moment, one (workaround) solution that fixed that was this:

Disconnect the connections between Cubase and ‘DirectMusic’ devices if the connection to the FaderPort is sometimes lost :
Studio > Studio Setup > MIDI Port Setup > uncheck Use Device ‘Directmusic’

Best regards

CKB

Thanks #CKB. I thought DirectMusic was a Microsoft OS only issue. Cannot find it on my Mac. Will keep searching. Maybe you happen to have another suggestion? If I only knew why all of a sudden this one project stopped working with FP…

Unfortunately, I can’t reproduce this on my system, so my ideas would be far too speculative. I work with Windows 10 myself.

Maybe there is someone here with a Mac who can test this project of yours with a FaderPort and with whom you can exchange the project data via a cloud? Otherwise I would also send a ‘ticket’ to Steinberg, as this seems to be a Cubase problem.

And …
Have you been successful now, KYUMIN_SHIM? :innocent:

Unfortunately… nope.

One last thing I could do is uninstall and re-install cubase. When I have some free time will do!

Hi KYUMIN_SHIM,

if you are doing a new installation of Cubase, you should also delete the Steinberg folder under Documents between the de-installation and the installation so that no older files are retained.

This is because, as I understood you here at the beginning, your problem is that only the new version of the script is not loaded. After the new installation of Cubase you should simply go through all the steps again as described in the fp-wizard_setup.pdf file.

Good luck.
CKB

1 Like

Hello friends,
I was asked again which rubber ring I currently use that turns the rotate knob into a jog wheel and if I can post a link to a store on eBay that sells it.
Here is at least a link for Germany, but I think you can also find this product internationally as the supplier is based in China.

Please note: Inner diameter = 18 mm is correct

Best regards
CKB

hey guys! I recieved faderport v2, I’m using cubase 12 in win11, I would like to try the script, sorry I dont know where I have to place the file, can anyone lend a hand? my faderport works but do some weird things like I select a track but once I want to up/down the fader suddenly selects another different track. Sorry if you explain this before, I couldn’t find the answer

Hi Valesigna,
In the following old post you’ll find a setup document that explains where to copy the script: